Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: SR - Fehler

  1. #1
    sedie Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Moin ,ich habe ein Programm erstellt in dem mehrere SR - Glieder vorkommen jetzt habe ich das Programm auf meine Anlage geladen doch irgendwie Speichern meine SR - Glieder nicht .(auf den Rüchsetzeingang gebe ich natürlich kein Signal ) kann mir irgenjemand helfen ,hab schon fas 3 Stunden probiert bekomms aber nicht gebacken.
    Zitieren Zitieren Gelöst: SR - Fehler  

  2. "Danke für die Hilfe ich habe mein Programm ganz klar in eine Ablaufkette geschrieben .Dann habe ich die Eingänge und Verknüpfungen die auf mein SR - Glied gewirkt haben noch mal gelöscht und einfach neu eingetippt schwupps die wupps und meine Kleine Sortieranlage leuft wie eine eins,also noch mal besten Dank"


  3. #2
    Anonymous Gast

    Standard

    Setz doch das Programm mal hier rein - dann kann man sicher eher was dazu sagen.

  4. #3
    sedie Gast

    Standard

    Wie kann ich das programm hier rein setzen?

  5. #4
    Registriert seit
    30.08.2003
    Beiträge
    2.197
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Hallo, kanns vielleicht sein dass du eine Mehrfachzuweisung im Programm hast? Vielleicht auch Byte/Wort/Doppelwortweise?

    MfG
    André Räppel
    Zitieren Zitieren Problem  

  6. #5
    Registriert seit
    25.09.2003
    Beiträge
    122
    Danke
    0
    Erhielt 8 Danke für 7 Beiträge

    Standard

    Hallo Sedi,

    es wäre schon hilfreich wenn Du ein paar Angaben
    über die eingesetzten Mittel machen würdest.
    Also : Step5 ; Step7 (300/400); Microwin (200)? oder sonstwas ?
    Auch wie Du die S/R-Merker aufgerufst.
    Ich glaube eher, dass die Merker nicht gesetzt werden.
    Ansonsten kann man nur vermuten...
    1.) Läuft das übrige Programm ? Kann man also davon ausgehen
    das die HW ok ist?

    2.) Wird der Programmteil ( FC;FB...) korrekt und unbedingt aufgerufen?

    3.)Wenn also keine Mehrfachverwendung vorliegt, wie André
    das schon geschrieben hat, dann vielleicht:
    Kann es sein dass diese S/R Merker mit Flanken gesetzt werden,
    die zum Zeitunkt des Setzens noch garnicht anstehen?
    ( Flanken werden 'später im Programm erzeugt als die
    S/R-Merker gesetzt werden -- Zyklusüberschneidung)

    4.) oder andersrum Flanken ( oder allgemein die Setzbedingung ) vor
    Aufruf des Merker's schon wieder geplättet werden ?


    Wie gesagt ohne nähere Angaben kann man nur vermuten.


    mfg.

    Rolf

  7. #6
    Anonymous Gast

    Standard

    Danke für die Hilfe ich habe mein Programm ganz klar in eine Ablaufkette geschrieben .Dann habe ich die Eingänge und Verknüpfungen die auf mein SR - Glied gewirkt haben noch mal gelöscht und einfach neu eingetippt schwupps die wupps und meine Kleine Sortieranlage leuft wie eine eins,also noch mal besten Dank

  8. #7
    sedie Gast

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke für die Hilfe ich habe mein Programm ganz klar in eine Ablaufkette geschrieben .Dann habe ich die Eingänge und Verknüpfungen die auf mein SR - Glied gewirkt haben noch mal gelöscht und einfach neu eingetippt schwupps die wupps und meine Kleine Sortieranlage leuft wie eine eins,also noch mal besten Dank

Ähnliche Themen

  1. Antworten: 9
    Letzter Beitrag: 17.06.2011, 09:02
  2. OPC BDE Fehler
    Von Power_Pete im Forum Hochsprachen - OPC
    Antworten: 13
    Letzter Beitrag: 19.05.2011, 14:53
  3. Wo ist der Fehler???
    Von husox81 im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 30.01.2010, 17:07
  4. Wo ist der Fehler???
    Von husox81 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 28.01.2010, 19:12
  5. S5 DB1 Fehler
    Von mariob im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 26.01.2009, 18:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •