Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: FB mit Temp Variable ergänzen.

  1. #1
    Registriert seit
    20.04.2008
    Ort
    Schaffhausen
    Beiträge
    87
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wolle eine FB mit einer Temp Variabel ergänzen.
    Leider funzt es nicht.
    Der FB besitzt keien I-DB.
    Wo werden die Lokalvariablen gespeichert.
    Muss ich noch etwas aktualisieren ausser dem FB.
    Ich benutze die Variable lediglich um eine Wert aus Nw9 ins Nw10 zu übernehmen.
    Zitieren Zitieren FB mit Temp Variable ergänzen.  

  2. #2
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Definiere "Leider funzt es nicht"

    Temp-Variablen sind eind ein globaler Speicherbereich, der von der CPU dynamisch verwaltet wird.
    Das FB keinen I-DB hat ist egal.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. #3
    Registriert seit
    20.04.2008
    Ort
    Schaffhausen
    Beiträge
    87
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Der Wert welcher am OUT einer Berechnung ausgegeben wird, soll
    via MOVE in den DB geschrieben werden.
    Zur glättung des Wertes möchte ich das Verschieben des Wertes etwas verzögern.
    Leider kommt im Nw auf der oben beschriebenen Variablen nichts an.
    Der Datentyp stimmt jedoch überein.

  4. #4
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.752
    Danke
    323
    Erhielt 1.526 Danke für 1.286 Beiträge

    Standard

    Verzögern in Verbindung mit Temp ist ansich ein Widerspruch in sich ...

    Kannst du mal nen Screenshot posten?

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  5. #5
    Registriert seit
    11.09.2007
    Ort
    Suedwestpfalz
    Beiträge
    917
    Danke
    81
    Erhielt 209 Danke für 192 Beiträge

    Standard

    Mit der Beschreibung kannich im Moment nicht viel anfangen...

    Poste doch mal die Codesequenz.

    Noch ein Hinweis zu TEMP-Variablen: Du kannst davon ausgehen das die am Bausteinende weg sind, zum Verzögern eignen die sich nicht sonderlich gut...
    Das Grauen lauert in der Zwischenablage !!

  6. #6
    Registriert seit
    20.04.2008
    Ort
    Schaffhausen
    Beiträge
    87
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Screenshot ist nicht möglich.
    Das Laptop ist noch auf dem Kran.
    Gehe erst später wieder hoch.
    Es geht jedoch noch gar nicht um die Verzögerung, denn die ist noch gar nicht programmiet.
    Ich schiebe den Wert lediglich.
    Nehem jedoch zur Kenntniss das es tatsächlich nicht gehen wird.
    Werde es über zwischenspeichern in DB realisieren.
    Aber was ist mit der Variable los.
    Zitat Zitat von MSB Beitrag anzeigen
    Verzögern in Verbindung mit Temp ist ansich ein Widerspruch in sich ...

    Kannst du mal nen Screenshot posten?

    Mfg
    Manuel

  7. #7
    Registriert seit
    08.04.2008
    Ort
    Köln
    Beiträge
    844
    Danke
    39
    Erhielt 244 Danke für 199 Beiträge

    Standard

    Hallo swisscrane,

    wie dtsclipper schon geschrieben hat, sind die Temp-Variablen nur innerhalb eines Bausteins
    und nur für einen Zyklus gültig.

    Grüße
    Gebs

  8. #8
    Registriert seit
    11.09.2007
    Ort
    Suedwestpfalz
    Beiträge
    917
    Danke
    81
    Erhielt 209 Danke für 192 Beiträge

    Standard

    Allerdings will er ja nur einen Wert ein Netwerk weiter schieben, da sollte TEMP eigentlich gehen...

    Steckt vielleicht irgendwo ein FUP-MOVE drin dem der Enable fehlt?
    Das Grauen lauert in der Zwischenablage !!

  9. #9
    Registriert seit
    20.04.2008
    Ort
    Schaffhausen
    Beiträge
    87
    Danke
    10
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Enable habe ich mit dem True Bit Merker gelöst.

    Zitat Zitat von dtsclipper Beitrag anzeigen
    Allerdings will er ja nur einen Wert ein Netwerk weiter schieben, da sollte TEMP eigentlich gehen...

    Steckt vielleicht irgendwo ein FUP-MOVE drin dem der Enable fehlt?

  10. #10
    Registriert seit
    20.10.2004
    Beiträge
    650
    Danke
    5
    Erhielt 26 Danke für 26 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ansosnten als static anlegen und dann sind sie vor fehler sicher
    wenn es schon nicht anders geht


    temp müssen immer nach denn aufruf des fb beschrieben werden mit t oder =

    und dürfen dann verwendet werden bis zum ende des Bausteins

Ähnliche Themen

  1. Problem mit Temp-Variable im FC
    Von Bär1971 im Forum Simatic
    Antworten: 19
    Letzter Beitrag: 20.01.2011, 12:15
  2. Ergänzen von Bitmustern
    Von Grilli im Forum Programmierstrategien
    Antworten: 11
    Letzter Beitrag: 19.06.2010, 11:03
  3. TEMP-Variable
    Von anne im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 14.06.2010, 19:55
  4. Antworten: 17
    Letzter Beitrag: 06.10.2004, 12:02
  5. Antworten: 2
    Letzter Beitrag: 23.09.2004, 09:26

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •