Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: S7 200 und TD200 von steuerung bild aufrufen

  1. #1
    Registriert seit
    07.08.2004
    Beiträge
    258
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi...

    Wie kann ich von der Steuerung (S7 222) ein bild am TD200 aufrufen
    lassen?
    Bei der 300èr und zB.OP17 mit einem Steuerbefehl ; aber bei
    der 200èr

    Danke

    Kojote
    Zitieren Zitieren S7 200 und TD200 von steuerung bild aufrufen  

  2. #2
    Anonymous Gast

    Standard

    Hallo,
    im TD 200 Assistent ein Projekt anlegen und das jeweils erstellte Meldungs-Freigabebit, welches im Datenbaustein hinterlegt ist, im Programm aufrufen. Geht bei mir aber nur mit Uebertragungsfunktion. Microwin Ver.3.2.4

    Als Hex-Wert das jeweilige Bit eintragen.

    LD xxx
    EU
    MOVB B#16#00, VBxx

    Gruß Uwe
    Zitieren Zitieren Gast  

  3. #3
    Kojote ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.08.2004
    Beiträge
    258
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke, aber irgendwas mache ich noch falsch
    In meinem Datenbaustein steht:
    //----------------------------------------------------------------
    //Anwendermeldungen
    //----------------------------------------------------------------
    VB67 ' ' //
    VB87 ' ' //
    VB107 'Hauptmenü $00' //
    VB128 'Temperatur $00$10$00$00°C ' //

    Bei betätigung von E0.6 soll das Hauptmenü(Temperatur) angezeigt
    werden.

    Und:
    LD E0.6
    EU
    MOVB B#16#00, VB128

    geht nicht


    Danke

  4. #4
    Anonymous Gast

    Standard

    Hallo,

    Beispiel aus einem Datenbaustein

    ------------------------------------------------------------------------------------

    //Meldungs-Freigabebit V15.3 // Dieses Bit muss angesprochen werden

    VB512 'Duese 1 '
    VB528 B#16#11 //
    VB529 B#16#11 //
    VW530 W#16#0000 //
    VB532 'Einschaltverzïgerung'

    ------------------------------------------------------------------------------------

    LD E0.6
    EU // Flanke muss nicht sein
    MOVB B#16#08, VB15 // Meldungs-Freigabebit V15.3
    ------------------------------------------------------------------------------------

    Ich hoffe es geht, habe aber auch keine S7-200 zum testen. Hat aber in einem alten Projekt so funktioniert.

    Gruss Uwe
    Zitieren Zitieren Gast  

  5. #5
    Kojote ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.08.2004
    Beiträge
    258
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für die Hilfe, aber ich verstehe nur Bahnhof

    Nachdem ich mit dem TD200 Assistent ein Projekt usw. erstellt habe
    steht im Datenbaustein aber nichts (oder ähnliches) wie:

    //Meldungs-Freigabebit V15.3 // Dieses Bit muss angesprochen werden

    VB512 'Duese 1 '
    VB528 B#16#11 //
    VB529 B#16#11 //
    VW530 W#16#0000 //
    VB532 'Einschaltverzïgerung'

    Die 200èr ist absolutes Neuland......hat denn jemand ein Tutorium?

    Das 200èr Handbuch ist echt für`en Ar.... !
    Da steht über das TD200 fast nichts drin, und das TD200 Handbuch
    .....wie gesagt.

    Ich weiss echt nicht weiter


    Kojote

  6. #6
    Registriert seit
    14.01.2004
    Ort
    Hattorf
    Beiträge
    3.201
    Danke
    297
    Erhielt 311 Danke für 266 Beiträge

    Standard

    Hallo,
    hier gibt es ein Beispiel von Siemens fürS7-200 mit TD200:
    http://www2.automation.siemens.com/m...t-bedienen.htm
    Vieleicht hilfts.
    mfg
    dietmar

  7. #7
    Registriert seit
    04.03.2005
    Beiträge
    26
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    wenn bei Dir das "Meldungs-Freigabebit" fehlt, hast Du im TD 200 Assistent wahrscheinlich keine Anzahl der Meldungen vorgegeben.
    Das kann man im 4. Bild des Assistenten machen.

    Gruss Uwe

    Ps.
    Sende mir mal Deine E-mail,
    ich habe ein Testprojekt erstellt und wuerde Dir das zusenden.

  8. #8
    Kojote ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.08.2004
    Beiträge
    258
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jetzt funktioniert es

    Daran lag es:
    Wenn im TD200 Assistenten Version 3.0 gewählt wird, gelangt man in ein ganz anders Menü.
    Ich habe einfach das alte TD200 gewählt (obwohl ich das 3.0 besitze)
    Mit der Steuerung des alten TD200 komme ich super zurecht.

    Die art der Steuerung unterscheidet sich bei den beiden TD`s
    (2.1 bzw. 3.0) stark !

    Danke Uwe fürs Prog - damit kam der Durchblick sofort


    MfG

    Kojote

Ähnliche Themen

  1. Bild aufrufen durch PLC-Variable?
    Von D4K!ZZ4 im Forum HMI
    Antworten: 1
    Letzter Beitrag: 21.10.2011, 13:27
  2. Antworten: 2
    Letzter Beitrag: 16.09.2009, 12:56
  3. Bild einblenden bzw. aufrufen in PCS7
    Von FHSei im Forum HMI
    Antworten: 1
    Letzter Beitrag: 27.03.2009, 11:07
  4. Antworten: 7
    Letzter Beitrag: 18.11.2007, 09:10
  5. Bild aufrufen beim TP 070?
    Von MRT im Forum HMI
    Antworten: 12
    Letzter Beitrag: 27.08.2005, 19:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •