Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 11

Thema: Problem - Sensor Skalierung

  1. #1
    Registriert seit
    12.04.2009
    Beiträge
    23
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo,

    ich habe ein paar Probleme..
    1)
    ich habe 2 Sensoren die ich skalieren möchte. Einen Winkel und einen Abstandssensor(Sharp Entfernungssensor GP2D12 mit Analogausgang http://www.roboter-teile.de/datasheets/gp2d12.pdf ) .
    Zum skalieren rufe ich über den OB35 mein FC1 auf wo ich 2 mal den SCALE FC105 aufrufen wollte.
    Wenn ich jeweils nur einen Sensor skalieren möchte klappt das wohl..aber wenn ich beide drin habe:
    Code:
     
    CALL  "SCALE"
           IN     :=PEW752
           HI_LIM :=1.000000e+001
           LO_LIM :=-1.000000e+001
           BIPOLAR:=TRUE
           RET_VAL:=MW3
           OUT    :=MD20
    
    
     CALL  "SCALE"
           IN     :=PEW754
           HI_LIM :=1.000000e+001
           LO_LIM :=0.000000e+000
           BIPOLAR:=FALSE
           RET_VAL:=MW2
           OUT    :=MD10
    dann habe ich das Problem das scheinbar der Winkel (PEW 752) den Positionssensor (PEW754) "überlagert"...die PEW's sind laut variablen beobachten anzeige in ordnung, nur das MD10 ist vollkommener unsinn....verändert sich auch nicht mehr durch Positionssensor, sondern den winkelsensor Oo
    Muss man etwas beachten wenn man 2 mal den SCALE benutzen möchte in einem FC? Habs auch mit 2 FC's probiert, aber selbes ergebnis.



    2)
    Meine nächste Frage ist wie ich den sharp positionsgeber am besten auf mm skalieren kann? Das PEW ist in Dezimal angezeit min.: 5552 und max.: 1440..falls damit jemand was anfangen kann...

    jedenfalls möchte ich wenn ich das PEW auf real skaliert habe gerne das ganze in mm oder cm haben..damit ich mit ner richtigen Größe arbeiten kann.


    3)
    Der Winkelsensor gibt -10V...+10V auf. wenn man den Kreis betrachtet:
    In Nord stellung : 0V
    West : -5V
    Süd : +-10V
    Ost : +5V

    Wie bekomme ich aus den -10V...+10V am einfachten rad oder Grad ?



    Ich weiß..viel Fragen, aber was muss das muss... ich hoffe das mir jemand helfen kann, weil ich im moment wirklich nicht so richtig weiter komme.
    Zitieren Zitieren Problem - Sensor Skalierung  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Hallo,

    PEW752 bipolar= true
    PEW754 bipolar= false ???

    wäre ein anfang


    Äh. Der Positionsgeber liefert was für Signale
    Geändert von Verpolt (19.05.2009 um 13:26 Uhr)

  3. #3
    Registriert seit
    15.10.2007
    Ort
    St.Pölten
    Beiträge
    875
    Danke
    98
    Erhielt 200 Danke für 188 Beiträge

    Standard

    wie sind die sensoren an den analogeingängen angeschlossen??
    masse?
    hardwareeinstellungen sind alle richtig??
    Beginne jeden Tag mit einem lächeln,es kann dir nämlich während des Tages sehr schnell vergehen.

  4. #4
    Registriert seit
    30.01.2004
    Ort
    Erfurt
    Beiträge
    961
    Danke
    42
    Erhielt 109 Danke für 87 Beiträge

    Standard

    Es gibt da gewisse Überschneidungen zwischen MW2 und MW3
    __
    Mit freundlichem Gruß Peter

    ...Wir sind Alle Zeitreisende. Die überwiegende Mehrzahl schafft allerdings täglich nur einen Tag.... (Jasper Fforde: "In einem andern Buch")

  5. #5
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.697 Danke für 1.949 Beiträge

    Standard

    Wird dein MD10 oder Teile daraus M10.0 etc. noch woanders im Programm verwendet? Setze mal testhalber etwas anderes ein, als MD10.

    Noch was anderes, was aber diesen Fehler nicht bewirkt. MW2 und MW3??? Die überlagern sich wirklich. Nimm MW2 und MW4.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  6. #6
    mac_hawk ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.04.2009
    Beiträge
    23
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Verpolt Beitrag anzeigen
    PEW752 bipolar= true
    PEW754 bipolar= false ???

    wäre ein anfang
    hab ich beides probiert, aber ich glaub der positionssensor liefert keine negativen werte, daher "FALSE"

    Zitat Zitat von Verpolt Beitrag anzeigen
    Äh. Der Positionsgeber liefert was für Signale
    Vout: 0,4V bis 2,6V typ. (80cm - 10cm) wenn ich mich nicht irre, laut datenblatt... das erklärt auch was ich oben geschrieben hatte mit den dezimal werten sry hätte ich gleich richtig schreiben sollen

    Zitat Zitat von Gerhard K Beitrag anzeigen
    wie sind die sensoren an den analogeingängen angeschlossen??
    masse?
    hardwareeinstellungen sind alle richtig??
    positionssensor an AI2 und winkelsensor an AI0
    beide müssten auf der analogmasse liegen. hab ein wenig rumprobiert, weil ich über ne box an die sps geh, aber immer dasselbe ergebnis
    das PEW ist ja korrekt, lediglich das skalierte ist unsinnig. daher denk ich eigentlich das die masse nicht das problem sein kann, da der SCALE ja das richtige input signal bekommt

    an der hardware wüsste ich nicht was ich umstellen müsste, das sollte eigentlich so passen

    Zitat Zitat von Ralle Beitrag anzeigen
    Wird dein MD10 oder Teile daraus M10.0 etc. noch woanders im Programm verwendet? Setze mal testhalber etwas anderes ein, als MD10.
    nein wird noch nirgends anders verwendet.

    Zitat Zitat von Ralle Beitrag anzeigen
    Noch was anderes, was aber diesen Fehler nicht bewirkt. MW2 und MW3??? Die überlagern sich wirklich. Nimm MW2 und MW4.
    kanns leider heute nicht mehr testen da ich die sps nicht daheim hab, werd ich aber gleich morgen früh probieren, aber du schreibst das es nicht "diesen" fehler verursachen kann ?

  7. #7
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Ich denke RALLE meint, mw2 und mw3 haben mit deinem Ergebnis in MD10
    nix zu tun. Überschneiden sich aber trotzdem. MW2 (MB2+MB3) MW3 (MB3+MB4)

  8. #8
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Hallo,

    AI0= PEW752 +/- 10V
    AI1= PEW754 ?????
    AI2= PEW756 0- 10V

  9. #9
    mac_hawk ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.04.2009
    Beiträge
    23
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ok also muss es PEW 756 für den positionssensor sein...

    ich weiß nicht warum, aber auf 754 bekam ich ein signal welches von der stellung des positionssensor abhängig war


    aber das kann immernoch nicht die ursache für das problem mit dem SCALE sein oder doch?



    edit:
    ok ich versuch morgen früh erstmal die massen nochmal zu überprüfen, dann das neue PEW und ich nehme ein anderes MW

    könnt ihr mir vllt noch schnell mit dem umwandeln in rad/grad und irgendein längenmaß der messwerte helfen? natürlich unter der annahme das die werte erste richtig ins real format gewandelt wurden
    Geändert von mac_hawk (19.05.2009 um 15:39 Uhr)

  10. #10
    mac_hawk ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.04.2009
    Beiträge
    23
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hab nochmal ein wenig rumgegrübelt..

    für den positionssensor werde ich wohl werte aufnehmen und dann die funktion daraus ableiten und damit die jeweilige position aus dem sensor wert errechnen lassen. in nem sfc z.b. ...

    nur für den winkel sensor bin ich mir im moment noch unsicher, kann man dort etwas ähnliches machen? ich hab etwas weiter oben angegeben wie die spannungswerte bei den entsprechenden positionen sind.. bin mir nicht sicher ob ich das dort auch mit werte tabelle ableiten kann.

Ähnliche Themen

  1. Problem Skalierung
    Von Ulli_FHBRB im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 27.10.2010, 09:10
  2. Skalierung in AWL
    Von adi5 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 17.01.2010, 16:41
  3. Analogwert Skalierung
    Von der_poly im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 21.11.2008, 09:44
  4. Skalierung von Analogwert
    Von settelma im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 19.03.2008, 21:17
  5. Skalierung NTC S7/300
    Von Anonymous im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 08.06.2005, 15:09

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •