Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: S7 PN CPU Webserver Varablen Tabelle - wie ?

  1. #1
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.624
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo.

    Ich versuche vergens eine Varablen Tabelle auf ein PN CPU über der Webserver anzuzeigen.
    Ich habe der Webserver auf der CPU aktiviert.
    Ich habe eine Sprache aktiviert (aber kriege dann eine meldung das es gibt kein gerät das die Meldungen anzeigen kann.)
    Und ich habe das Webser in der VAT aktiviert.
    Ich habe der VAT den Family=VATtoWEB spezifiziert, weill so wurde es empfohlen in der online Hilfe.
    Alles unter HW Konfig kompiliert und dann auf der CPU geladen.

    Auf der CPU ist der Webserver aktiv, aber unter Variabel Tabellen ist es leer.

    Ich finde keine gute Anleitung wie man VAT's auf der Webserver anzeigt.
    Hat jemand Erfahrungen damit ?
    Jesper M. Pedersen
    Zitieren Zitieren S7 PN CPU Webserver Varablen Tabelle - wie ?  

  2. #2
    Registriert seit
    28.07.2008
    Beiträge
    68
    Danke
    1
    Erhielt 33 Danke für 19 Beiträge

    Standard

    Hallo.
    Im Prinzip gibt es nur 2 Fehlermöglichkeiten.
    Die VAT muss markiert sein.
    Entweder in den Objekteigenschaften unter Familiy die Kennung "VATtoWEB" eingeben (Vorsicht casesensitiv!), oder besser die Checkbox Webserver aktivieren.(In Version 5.4 SP4 oder SP5)
    In der Hardwarekonfiguration der CPU den Webserver aktivieren, und genau in diesem Dialog auch eine Sprache anwählen!
    Nicht im Simatik Manager unter Anzeigesprache, etc!
    Konfiguration übersetzen und SDBs laden.
    Die gewählte Anzeigesprache muss bei der Generierung und im Webserver übereinstimmen!
    Also im Webserver die gleiche Anzeigesprache einstellen.
    Dann müsste es auch tun.

    mfg
    Linus
    Zitieren Zitieren Anzeige von VATs im Webserver  

  3. Folgende 2 Benutzer sagen Danke zu LinusAM4V für den nützlichen Beitrag:

    BTDA (15.01.2013),JesperMP (29.06.2009)

  4. #3
    Avatar von JesperMP
    JesperMP ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.624
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Genau wie Du es beschreibst habe ich es auch gemacht.
    Ist der Warnung das es keine Gerät der die Meldung anzeigen kann wichtig ? (ich werde ein screenshot posten).

    Ich denke das es hat vielleicht zu tun mit das der Speicherkarte zu klein ist. Und dann wurde der Konfiguration nie richtig geladen.
    Ich habe ein Hinweis gesehen das die Webserver VATs verschwenden viel Lade-Speicher.
    Wo kann man sehen wie viel Speicher für die VATs benötigt werden ?
    Jesper M. Pedersen

  5. #4
    Registriert seit
    28.07.2008
    Beiträge
    68
    Danke
    1
    Erhielt 33 Danke für 19 Beiträge

    Standard

    Hallo.
    Man kann die Größe der SDBs aus dem Systemdatenordner im Simatic Manager anzeigen. Dazu im SM auf den Bausteinordner gehen, und darin den Systemdatenordner doppelklicken. Im geöffneten Dialog sind die SDBs mit ihrer Größe zu sehen.
    Frage: Welche CPU hast du?
    Genaue Angabe mit MLFB und Firmwareversion!
    Nicht alle CPUs und deren Firmware können die VATs!

    mfg
    Linus
    Zitieren Zitieren Webserver  

  6. #5
    Avatar von JesperMP
    JesperMP ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.624
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Die SDBs habe ich auch beobachtet, aber der grösse von die verschiedene SDBs ändert sich nicht, egal ob ich VATs mit oder ohne Webserver kompiliert.

    Auch unter Blocks Ordner ändert sich der berechnete Speicherbedarf nicht.

    Es ist ein IM151-8 (6ES7 151-8AB00-0AB0 v2.7).
    Es ist alles nur ein test ob ich diese Webserver VATs verwenden kann.
    Leider wird es heute gepackt und gesendet. So keine weitere Versuche für Heute.
    Nächstens werde ich es mit ein 315-2PN/DP probieren.
    Jesper M. Pedersen

  7. #6
    Registriert seit
    28.07.2008
    Beiträge
    68
    Danke
    1
    Erhielt 33 Danke für 19 Beiträge

    Standard

    Hallo.
    Die IM151-8 sollte einen VAT fähigen Webserver enthalten.
    Daher sollte es eigentlich funktionieren.
    Wieviele VATs und mit welcher Größe sollen den in die SDBs gepackt werden?
    Welche SDBs mit welcher Nummer und welchem Typ existieren im Systemdatenordner?

    mfg
    Linus
    Zitieren Zitieren Webserver  

  8. #7
    Avatar von JesperMP
    JesperMP ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.624
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Es ist leider zu spät um deine Fragen zu beantworten. Der Steuerung is schon weck.
    So bald das ich ein 315-2PN/DP zu verfügung habe werden ich es nochmals probieren.
    Jesper M. Pedersen

Ähnliche Themen

  1. Webserver mit S7-300?
    Von c-teg74 im Forum Simatic
    Antworten: 30
    Letzter Beitrag: 24.11.2016, 14:31
  2. S7 1200 Webserver
    Von magus111 im Forum Simatic
    Antworten: 34
    Letzter Beitrag: 07.11.2012, 18:36
  3. Deltalogic Webserver und PHP
    Von Ernst im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 02.11.2010, 11:49
  4. CP6608 Webserver
    Von matthias_h im Forum CODESYS und IEC61131
    Antworten: 5
    Letzter Beitrag: 09.02.2010, 21:57
  5. Variablentabelle auf Webserver?
    Von vollmi im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 30.01.2009, 15:15

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •