Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: WinAC RTX Ethernet Kommunikation, aber wie???

  1. #1
    Registriert seit
    19.01.2007
    Ort
    Ruhrpott-West
    Beiträge
    383
    Danke
    97
    Erhielt 99 Danke für 74 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    ich stehe hier vor einem Problem, für das ich ums Verrecken keine Lösung finde.

    Ich einen Panel PC von Siemens (PC 477B) auf dem WinAC RTX 2008 läuft.
    Jetzt will ich über Ethernet mit einem ABB Roboter Daten austauschen. Der Roboter kann nur TCP/IP (kein UDP oder ISO-on-TCP).

    Alle versuche meinerseits eine Verbindung aufzubauen schlugen bisher fehl. Anpingen aller Netzteilnehmer funktioniert perfekt.

    Aber alle Versuche im SPS-Programm Daen zu senden oder zu empfangen scheitern schon an den genutzen Bausteinen. Ich habe TSEND-TRCV-TCON, AG_SEND-AG_RECV und READ-WRITE ausprobiert.
    Schon die Statusworte geben jedesmal Fehler aus (z.B. 80A7).

    Bei den meisten Komm-Bausteinen wird eine ID gefordert. Die habe ich aber gar nicht (s. Bild NetPro)

    Muß ich die Daten mittels OPC-Server 'aufbereiten' oder kann ich auch direkt aus dem SPS Daten schicken und empfangen.

    Habe mit WinAC leider noch keine Erfahrung, bei eine 317-2PN/DP klappt's problemlos (ohne OPC!)

    Hoffe Ihr könnt mir weiterhelfen.

    Gruß
    maweri
    Angehängte Grafiken Angehängte Grafiken
    Es ist schon alles gesagt worden - nur noch nicht von jedem!
    Zitieren Zitieren WinAC RTX Ethernet Kommunikation, aber wie???  

  2. #2
    Registriert seit
    10.02.2009
    Ort
    Karlsruhe
    Beiträge
    42
    Danke
    0
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Hallo maweri,

    ich kenne jetzt leider nicht die Möglichkeiten der ABB Robis, wenn die Kommunikation aber mit einer 317 PN/DP funktioniert, sollte es mit der WinRtx
    eigentlich auch gehen.
    Wie so immer bei Siemens ABER:
    es kommt wohl darauf an was für einen Ethernet CP dein PanelPC hat. Nicht jeder, vor allem On-Board 08/15 Ethernet Port ist für alles gleichermaßen geeignet.
    Ich weiß z.B. dass eine Profinet Verbindung nur ab einem bestimmten Service Pack und einem bestimmten CP funktioniert.

    Ob Du alternativ mit OPC besser weiterkommst kann ich nicht sagen, dann bräuchtest du ja auf der Gegenseite einen passenden Client.

    Gruss
    quax

  3. Folgender Benutzer sagt Danke zu quax für den nützlichen Beitrag:

    maweri (06.07.2009)

  4. #3
    Registriert seit
    01.03.2007
    Beiträge
    262
    Danke
    26
    Erhielt 33 Danke für 28 Beiträge

    Standard

    Das mit dem TCP/IP hatten wir vor Kurzen auch einmal. Die Lösung ist, dass du eine Netzwerkkarte von mit einem Chipsatz von Intel (welchen genau steht irgendwo im Handbuch (im Handbuch mal nach "Intel" suchen)) brauchst (ca. 30 €).
    Die Netzwerkkarte kannst du dann in einen IF-Slot parametrieren und damit dann mit dem Robi z.B. über die Bausteine TCON, TSEND, TREC komunizieren.

  5. Folgender Benutzer sagt Danke zu Human für den nützlichen Beitrag:

    maweri (06.07.2009)

  6. #4
    Avatar von maweri
    maweri ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.01.2007
    Ort
    Ruhrpott-West
    Beiträge
    383
    Danke
    97
    Erhielt 99 Danke für 74 Beiträge

    Standard

    Hallo Human,

    kannst Du mir sagen in welchem Handbuch ich nachschlagen muß?
    Ich habe in den letzten Tagen zig Handbücher zu CPs, Kommunikation usw. überflogen (komplett durchlesen ist ja kaum möglich), aber nix passendes gefunden.

    maweri
    Es ist schon alles gesagt worden - nur noch nicht von jedem!

  7. #5
    Registriert seit
    01.03.2007
    Beiträge
    262
    Danke
    26
    Erhielt 33 Danke für 28 Beiträge

    Standard

    Im ganz normalen WinAC RTX 2008-Handbuch (oberster Link in der Hanbuchliste bei Siemens):

    http://support.automation.siemens.co...subtype=133300

    Seite 36:

    Als WinLC RTX-Submodule konfigurierbare Kommunikationsschnittstellen
    ● CP 5613 V3 oder CP 5613 V6 oder höher
    ● CP 5613 A2
    ● CP 5611 A2
    ● CP 5621
    ● SIEMENS PC mit integrierter CP 5611 PROFIBUS-Schnittstelle: ASPC2 STEP E2 oder
    ASPC2 STEP R ASIC
    ● CP 1616 Hardwareversion 8 oder höher
    ● CP 1604 Hardwareversion 7 oder höher
    ● S7-mEC CP1616/ERTEC400_EC integrierte Schnittstelle
    ● SIMATIC PC 427B/477B integrierte CP 1616-Schnittstelle
    ● SIMATIC PC 627B/677B integrierte CP 1616-Schnittstelle
    ● SIMATIC Microbox PC 427B / Panel PC 477B integrierte Intel PRO/1000 PL-Schnittstelle
    ● SIMATIC Box PC 627B / Panel PC 677B integrierte Intel PRO/1000 PL-Schnittstelle
    ● SIMATIC Rack PC 847B integrierte Intel PRO/1000 PL-Schnittstelle
    ● Intel PRO/1000 GT (PCI), Intel 82541PI Chipset

    ● Intel PRO/1000 PL (integriert), Intel 82573L Chipset
    „Software wird schneller langsamer als Hardware schneller wird.“ - Niklaus Wirth (1995)

  8. #6
    Avatar von maweri
    maweri ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.01.2007
    Ort
    Ruhrpott-West
    Beiträge
    383
    Danke
    97
    Erhielt 99 Danke für 74 Beiträge

    Standard

    Hallo Human,

    Danke für den Hinweis. Habe ich in dem Handbuch auch schon gelesen, nur habe ich Absatz wohl nicht ernst genommen.

    Da wir ein Panel PC 477B, habe ich es mal mit folgender Schnittstelle versucht:
    - SIMATIC PC 427B/477B integrierte CP 1616-Schnittstelle
    klappte auch nicht.

    Habe heute zusätzlich den Siemens-Support aktiviert. Bis auf die Standard-Antwortmail ist noch nix passiert. Wahrscheinlich rufen die mich gleich zurück, wenn ich auf dem Heimweg. (Wäre nicht das erste Mal).

    Ich vermute, daß mein Problem bei der Auswahl der richtigen Sende-/Empfangsbausteine und der Konfiguration der Verbindung liegt.
    Anstelle des Robbis, versuche ich jetzt erst mal an einem PC mitttels HyperTerminal Daten zu schicken. Aber auch das klappt nicht.

    Schönen Feierabend
    maweri
    Es ist schon alles gesagt worden - nur noch nicht von jedem!

  9. #7
    Registriert seit
    01.03.2007
    Beiträge
    262
    Danke
    26
    Erhielt 33 Danke für 28 Beiträge

    Standard

    Hast du die CP auch im Komponenten-Konfigurator in der WinAC in einen der IF-Steckplätze gesteckt bzw. das auch bei der HW-Konfig gemacht?
    „Software wird schneller langsamer als Hardware schneller wird.“ - Niklaus Wirth (1995)

  10. #8
    Avatar von maweri
    maweri ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.01.2007
    Ort
    Ruhrpott-West
    Beiträge
    383
    Danke
    97
    Erhielt 99 Danke für 74 Beiträge

    Standard

    Der CP liegt auf Platz 3 (seperat als IE General). Auf IF1 steckt ein CPxxxx (Nr. weiß ich gerade nicht auswendig) für Profibus-Anbindung. Der funktioniert.

    Das Panel war vorinstalliert. Ich habe das in der HW-Konfig nur nachgebaut.
    Den CP1616 aus Deiner Liste habe ich auf IF2 'gesteckt'.

    Aber bei den ganzen Komponenten, die ich heute auf verschiedenen Steckplätzen ausprobiert habe, kann ich mich nicht mehr genau erinnern
    Bei einigen Kombinationen meckerte sofort die HW-Konfig. So nach dem Motto: "Geht nicht, wenn XY gesteckt" oder "Nur auf Steckplatz X".

    Grundsätzlich achte ich aber schon drauf, daß HW-Konfig und Komponeten-Konfigurator gleich sind.
    Es ist schon alles gesagt worden - nur noch nicht von jedem!

  11. #9
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.235
    Danke
    640
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Ich meine mich zu erinnern, dass bei der WinAC der Name in der Hardwarekonfig exakt mit dem Rechnernamen übereinstimmen muss, damit die Kommunikation funktioniert. Ist dies der Fall?
    Auch die Wahl der Kommunikatiosnbausteine könnte sein. WinAC MP verwendet z.B. die Kommunikationsbausteine der 400er, obwohl sie einer 300er entspricht. Meldet aber natürlich bei der Verwendung der falschen Bausteine keine Fehler ('s god halt ned). Dies ist aber im WinAC Handbuch vermerkt.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  12. #10
    Avatar von maweri
    maweri ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    19.01.2007
    Ort
    Ruhrpott-West
    Beiträge
    383
    Danke
    97
    Erhielt 99 Danke für 74 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die Namen sind identisch.

    Bei der Auswahl Komm-Bausteine habe ich so meine Probleme. Die Fälle, die in den Handbüchern (WinAC, CP Komunikation usw.) genannt sind, passen irgendwie nicht auf meine Situation.

    Mir fällt gerade noch was ein. Werde das mal ausprobieren, wenn ich gleich auffe Arbeit bin.
    Es ist schon alles gesagt worden - nur noch nicht von jedem!

Ähnliche Themen

  1. WinAC MP 2007 Ethernet Kommunikation
    Von Phil86 im Forum HMI
    Antworten: 0
    Letzter Beitrag: 03.11.2010, 08:22
  2. Antworten: 0
    Letzter Beitrag: 10.08.2010, 09:58
  3. Kommunikation Step 7 und WinAC RTX
    Von Nockenwelle im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 23.03.2010, 12:01
  4. Offene Kommunikation mit WinAC RTX
    Von berty78 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 15.09.2009, 14:01
  5. ProTool RT über Ethernet an WINAC
    Von Rayk im Forum HMI
    Antworten: 11
    Letzter Beitrag: 08.07.2008, 22:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •