Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 21

Thema: Eprom s5

  1. #11
    Registriert seit
    07.07.2004
    Beiträge
    3.285
    Danke
    38
    Erhielt 584 Danke für 382 Beiträge

    Idee


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Zitat Zitat von jabba
    Hab so etwas ähnliches schon gehabt, und da war definitiv keiner an der Anlage der so etwas hätte machen können. Die Anlage war mehrere Jahre in Betrieb , wäre der Fehler direkt ins Eprom geschossen worden hätte die Anlage nie gelaufen.
    Deine Erfahrungen kann ich nur bestätigen, auch ich habe schon EPROMs in den Fingern gehabt die ich vor Jahren einmal selbst geschossen habe und deren Inhalt sich an einigen Speicherstellen verändert hat. Aber wer kann schon garantieren, dass eine Diodenstrecke sich aufgrund eines Defektes niemals verändert ???

    Und habe seitdem ein gesundes Mißtrauen gegenüber EPROMs entwickelt.
    Meine Erfahrung aus der ganzen Geschichte : Offensichtlich werden von den SPS Steuerungen RAM-Speicherinhalte über Quersummenprüfung gecheckt, bei den EPROMs hat man sich diesen Aufwand wohl erspart (Wohl in der irrtümlichen Annahme, das ein EPROM ja niemals defekt wird ).

    Gruß

    Question_mark
    ''Ich habe wirklich keine Vorurteile.
    Meine Meinung ist nur die Summe der Erfahrungen" ... (Question_mark)
    Zitieren Zitieren Doch, auch ein EPROM kann defekt werden  

  2. #12
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Aber das Bitmuster von 3.6 zu 30.6 passt nicht zusammen (siehe MC5). 3 = 00011, 30 = 11110. D.h. es müssten Bits gesetzt und gelöscht werden. Wenn ich die Technik noch richtig im Kopf habe, dann werden die Bits durch UV auf 1 gesetzt und mittels Programmierung auf 0. Somit kann sicher ein Bit kippen, normalerweise zurück in den Ausgangszustand.
    Was passiert eigentlich, wenn das Programm im EPROM vorhanden ist aber der Baustein mit Änderungen neu runtergeladen wird? Gilt dann dieser bis zum nächsten Ausschalten? Was ist wenn eine Batterie in der CPU ist? Wie lange gilt er dann? Bis zum Löschen?
    Ich könnte mir vorstellen, dass die letzten Änderungen von irgendwelchen Aktionen nicht ins EPROM gebrannt wurden. Und das hat sich jetzt gerächt.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  3. #13
    Registriert seit
    23.03.2006
    Ort
    Thüringen
    Beiträge
    2.005
    Danke
    162
    Erhielt 278 Danke für 199 Beiträge

    Standard

    Hallo,
    @Rainer, woher wollen wir wissen, ob der Befehl davor überhaupt stimmt, ich kenne MC5 zwar nicht, aber so kann aus einem Mehrbytebefehl auch ein oder zwei kürzere Mehrbytebefehle werden..... Es gibt da für mich tausende entstehende Varianten über die es sich für mich nicht nachzudenken lohnt.
    Und garantierte Datensicherheit sind nur 10 Jahre bei eingehaltenen Brennparametern.
    Wenn die PGs nur Pulse brennen wie sonst auch üblich weiß man nicht einmal das.

    Gruß
    Mario

  4. #14
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Weil der Threadersteller geschrieben hat, dass nach Abgleich mit dem Listing (handgeschrieben) genau drei Unterschiede existieren. Und wenn der Befehl davor ok ist, dann greift wieder meine Theorie und die Fakten zu EPROMs.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  5. #15
    Registriert seit
    08.12.2008
    Beiträge
    159
    Danke
    1
    Erhielt 19 Danke für 18 Beiträge

    Standard

    Ich denke auch dass der Stand aufm EPROM ein alter Stand ist.
    Der Fehler (E30) ist bestimmt auf EPROM gebrannt. Danach wurde die Änderung (E3) nur auf die SPS gespielt und das EPROM nicht neu gebrannt.
    So ist es zumindest logisch für mich!
    Egal was passiert: Nur nicht den Sand in den Kopf stecken!

  6. Folgender Benutzer sagt Danke zu o_prang für den nützlichen Beitrag:

    Rainer Hönle (23.07.2009)

  7. #16
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von o_prang Beitrag anzeigen
    Ich denke auch dass der Stand aufm EPROM ein alter Stand ist.
    Der Fehler (E30) ist bestimmt auf EPROM gebrannt. Danach wurde die Änderung (E3) nur auf die SPS gespielt und das EPROM nicht neu gebrannt.
    So ist es zumindest logisch für mich!
    Für mich nicht !
    Zitat Zitat von Tom08 Beitrag anzeigen
    Also da ist eine S5 95U drin mit einem EPROM ohne Batterie also nach jedem Spannungsausfall ladet die CPU das Programm vom EPROM.
    Oder hat man die Anlage nie wieder ausgeschaltet?
    Wie willst das Programm in die CPU bringen wenn keine Batterie drin ist und ein EPROM steckt?
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  8. #17
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von Paule Beitrag anzeigen
    Oder hat man die Anlage nie wieder ausgeschaltet?
    Wie willst das Programm in die CPU bringen wenn keine Batterie drin ist und ein EPROM steckt?
    Wie gab es Spannungausfall? War danach der Elektriker mit dem PG da? Oder ist es wahrscheinlicher dass bei einem EPROM die Bits in beide Richtungen umfallen?
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  9. #18
    Registriert seit
    28.10.2005
    Ort
    Ottweiler, Saar
    Beiträge
    940
    Danke
    259
    Erhielt 124 Danke für 109 Beiträge

    Standard

    Ich schließe mich mal der Meinung von o_prang an. Wahrscheinlich hat das AG nach der Programmänderung noch keinen Spannungsausfall gehabt.

    Eprom geschossen, danach Tippfehler bemerkt, online korrigiert und es läuft.
    Nur schade dass das Löschgerät nicht greifbar ist. Und auch keine Batterie zur Hand.

    @Rainer: Eprom-Bits kippen IMHO in der Regel von 0 nach 1. Den Kippvorgang kann man durch Abkleben des Löschfensters um einiges hinausschieben, aber wem erzähl ich das...

  10. #19
    Registriert seit
    27.10.2005
    Ort
    Schwäbisch Gmünd
    Beiträge
    5.224
    Danke
    630
    Erhielt 955 Danke für 769 Beiträge

    Standard

    Zitat Zitat von argv_user Beitrag anzeigen
    Ich schließe mich mal der Meinung von o_prang an. Wahrscheinlich hat das AG nach der Programmänderung noch keinen Spannungsausfall gehabt.

    Eprom geschossen, danach Tippfehler bemerkt, online korrigiert und es läuft.
    Nur schade dass das Löschgerät nicht greifbar ist. Und auch keine Batterie zur Hand.

    @Rainer: Eprom-Bits kippen IMHO in der Regel von 0 nach 1. Den Kippvorgang kann man durch Abkleben des Löschfensters um einiges hinausschieben, aber wem erzähl ich das...
    So ist auch mein Kenntnisstand. Deshalb hat mich das Umfallen der Bits in beide Richtungen stutzig gemacht. Von 1 nach 0 nur mit Gewalt, von 0 nach 1 mit Licht und Zeit. Dabei spielt auch noch eine Rolle, wie gut gebrannt wurde. Wie oft wurde nach erstmaligem Erkennen der 0 noch wie lange nachgebrannt etc.
    Rainer Hönle
    DELTA LOGIC GmbH

    Ein Computer kann das menschliche Gehirn nicht ersetzen. Engstirnigkeit kann unmöglich simuliert werden. (Gerd W. Heyse)

  11. #20
    Registriert seit
    09.06.2009
    Beiträge
    66
    Danke
    10
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von mariob Beitrag anzeigen
    Und die Leute hier aus der ehemaligen Zone kennen doch bestimmt auch noch die guten blauen DDR Dinger (2716, die 555 gingen), die schon häufig nach dem ersten Brennen im Eimer waren. War ein geiles Zeug.
    Kann ich nicht bestätigen. Die U2716C und auch die U555C ( = 2708 ) haben bei mir noch nie Probleme bereitet, egal wie alt. Schlimmer sind da die russ. K573RF1 ( = 2708 ) bzw. K573RF2/KS573RF2 ( = 2716 ), wenngleich die nur mehr Strom brauchen.

    Xaar.

    PS: Die DDR-EPROMs gabs neben der Violetten Gehäuse-Variante auch in Weiß.

Ähnliche Themen

  1. Eprom/cp524
    Von Elmi im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 31.10.2010, 12:16
  2. S5 eprom
    Von klauserl im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 18.10.2010, 16:20
  3. S5 eprom
    Von William700 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 11.08.2009, 19:51
  4. EPROM für S5 CPU 103
    Von Rudi im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 28.08.2007, 19:41
  5. S5 & Eprom
    Von Anonymous im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.01.2005, 16:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •