Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 4 von 4

Thema: Daten aus S7-300 lesen ohne Programmänderung

  1. #1
    Registriert seit
    15.12.2007
    Beiträge
    712
    Danke
    84
    Erhielt 105 Danke für 94 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!

    Ich hätte da mal eine Frage ... aber erstmal der Hardwareaufbau:

    1. Station:
    S7-400 mit CP443-1

    2. und 3. Station:
    S7-300 mit CP343-1

    Ich möchte nun mit der S7-400 Daten aus den beiden S7-300 Stationen auslesen. Mit SEND/RECEIVE und ISO-on-TCP Verbindungen habe ich das jetzt auch in einem Testaufbau soweit hinbekommen.

    Mein Problem ist nur das an der reellen Anlage (den beiden S7-300) keine bzw. so wenig Programmänderungen wie möglich vorgenommen werden sollen.
    Am liebsten wäre mir das auslesen von Datenbausteinen ohne irgendwelche Bausteine in die Programme der S7-300 einfügen zu müssen.

    Ist das mit dieser HW-Konfig möglich?
    Oder ist das nur per OPC-Server möglich?
    Ich habe etwas von FETCH/WRITE gelesen, aber nicht hinbekommen es zu konfigurieren. Hier ist das Handbuch von Siemens etwas dünn.
    Hört sich aber nach dem an was ich suche.
    Hat das jemand schonmal erfolgreich getestet?

    Gruß Ingo
    Zitieren Zitieren Daten aus S7-300 lesen ohne Programmänderung  

  2. #2
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

  3. Folgender Benutzer sagt Danke zu borromeus für den nützlichen Beitrag:

    Astralavista (04.08.2009)

  4. #3
    Astralavista ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    15.12.2007
    Beiträge
    712
    Danke
    84
    Erhielt 105 Danke für 94 Beiträge

    Standard

    Das is schonmal genau das wonach ich gesucht habe!
    Danke erstmal.

    Das einzige was mir jetzt dabei aufgefallen ist, ist das die Kommunikation mit dieser Methode etwas "stottert". Ich habe dort eine relativ lange Zeit (ca. 300 - 400 ms) keine Aktualisierung der Datenbereiche die ich mir aus der 300er Steuerung hole. Und jetzt zum testen sind das gerade mal 4 Byte. Ich hoffe das wird mit einer größeren Datenmenge nicht schlimmer.

    Ist das normal das es mit der aktualisierung so hakt?
    Mit SEND/RECEIVE war das nicht so.
    Wenn nein, was könnte ich falsch gmacht haben?

    CPU 417-4
    und 2x CPU 315-2 DP

    Im Programm ist nichts anderes drin außer die Kommunikation ... sollte also ausreichend Rechenleistung vorhanden sein

  5. #4
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich denke- habe das aber erst ein paar mal so gemacht- dass die Zeiten nicht mehr in die Höhe gehen. Die Nutzdaten gehen recht flott, der Telegrammablauf selber braucht aber ein paar Zyklen- was da CPU seitig passiert weiss ich nicht.

    Probiers mal mit 1000Byte, wird nicht viel länger dauern.

    lG
    Karl

Ähnliche Themen

  1. Antworten: 3
    Letzter Beitrag: 15.04.2011, 21:41
  2. Werte aus TP lesen ohne *.pdz
    Von bloodymichael im Forum HMI
    Antworten: 5
    Letzter Beitrag: 23.12.2010, 14:41
  3. Daten mit S7-300 aus S7 1200 lesen
    Von golfsiew im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 23.04.2010, 22:31
  4. Daten lesen
    Von tomatensaft im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 11.10.2007, 16:33
  5. Antworten: 10
    Letzter Beitrag: 04.08.2006, 19:28

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •