Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: FM357-2 Referenzfahrt ändern

  1. #1
    Registriert seit
    14.08.2008
    Beiträge
    9
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!
    Ich möchte an einer Positioniereinheit FM357-2 die Referenzfahrt von minus ins plus ändern. Aber allein mit dem "anklicken" plus beim parametrieren in der Sparte referenzieren (Maschinendaten) ist es nicht getan! Kann mir jemand weiterhelfen und vorab "Vielen Dank"
    Zitieren Zitieren FM357-2 Referenzfahrt ändern  

  2. #2
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Bin mir gerade nicht 100% sicher, da ich die SW nicht zur Hand habe, aber du musst meines Wissens die Parameter in der FM umstellen, und die FM Erkennt dann nur wenn du Tippen plus ausführst, und Referanzfahrt angewählt hast, das es sich dann um eine REFA handelt.

    Oder willst du die Refa über die Oberfläche der FM machen??
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  3. #3
    Registriert seit
    12.02.2008
    Ort
    Westfalen (Dort wo's Schwarzbrot gibt)
    Beiträge
    417
    Danke
    8
    Erhielt 87 Danke für 72 Beiträge

    Standard

    mitchih hat schon recht. Um die Richtung der Referenzfahrt einzustellen, muss das im Parametriertool und im Programm vorgegeben werden. Wenn Du im Parametriertool Plus eingestellt hast, musst Du im Programm auch mit Tippen-Plus die Referenzfahrt starten und umgekehrt.

  4. #4
    disdata ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.08.2008
    Beiträge
    9
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke für Eure Hilfe! Bin soweit das die Referenzfahrtrichtung funktioniert, jetzt habe ich allerdings noch das Problem, das die Fahrt auf dem Referenzpunkt-Nocken gestoppt wird und NICHT die Richtung ändert und bis VOR den Nocken fährt! (Richtungsänderung bis vor den Nocken funktioniert nicht!). Habt ihr noch ne Idee? >>> Vielen Dank<<<

  5. #5
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Hallo,

    wie gesagt, habe das Parametriertool nicht vorliegen, ich meine, das man die Art der REFA einstellen kann. Das würde der Typ Referenzieren auf Nullimpuls sein, wenn ich mich nicht Irre.
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!
    Zitieren Zitieren Nullsignal  

  6. #6
    disdata ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.08.2008
    Beiträge
    9
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also, Richtung "Referenzpunktfahrt" war minus beim Parametriertool und die Referenzfahrt im Programm ebenfalls!
    Die Parametriereinstellungen waren:
    Referenzpunktfahrt: notwendig
    Richtung Referenzpunktfahrt:minus
    Achse mit Referenzpunktschalter: ja
    Nullmarke: vor Referenzpunktschalter
    Die Referenzfahrt funktionierte, indem bei "Referenzstart" der Tisch ins minus fährt, den Referenzschalterkontakt drückt und dann die Referenzfahrt entgegengesetzt ins plus langsam fortsetzt bis zur Nullmarke!

    Ich habe jetzt
    Referenzpunktfahrt: notwendig
    Richtung Referenzpunktfahrt:plus
    Achse mit Referenzpunktschalter: ja
    Nullmarke: vor Referenzpunktschalter
    eingegeben und im Programm die Referenzfahrt ebenfalls ins plus!
    Funktioniert wie oben, aber sobald der Referenzpunktschalter gedrückt wird fährt sie nicht langsam entgegengesetzt sondern die FM geht in Störung (Referenzpunktfahrt wurde abgebrochen, Meldung 20005)!!!
    Muss noch irgendwo ein Fahrbefehl plus/minus getauscht werden?
    >>>Besten Dank<<<

  7. #7
    Registriert seit
    09.11.2006
    Beiträge
    690
    Danke
    36
    Erhielt 31 Danke für 29 Beiträge

    Standard

    Zitat Zitat von disdata Beitrag anzeigen
    Also, Richtung "Referenzpunktfahrt" war minus beim Parametriertool und die Referenzfahrt im Programm ebenfalls!
    Die Parametriereinstellungen waren:
    Referenzpunktfahrt: notwendig
    Richtung Referenzpunktfahrt:minus
    Achse mit Referenzpunktschalter: ja
    Nullmarke: vor Referenzpunktschalter
    Die Referenzfahrt funktionierte, indem bei "Referenzstart" der Tisch ins minus fährt, den Referenzschalterkontakt drückt und dann die Referenzfahrt entgegengesetzt ins plus langsam fortsetzt bis zur Nullmarke!

    Ich habe jetzt
    Referenzpunktfahrt: notwendig
    Richtung Referenzpunktfahrt:plus
    Achse mit Referenzpunktschalter: ja
    Nullmarke: vor Referenzpunktschalter ??? (muss hier evtl. auf nach umgestellt werden????

    eingegeben und im Programm die Referenzfahrt ebenfalls ins plus!
    Funktioniert wie oben, aber sobald der Referenzpunktschalter gedrückt wird fährt sie nicht langsam entgegengesetzt sondern die FM geht in Störung (Referenzpunktfahrt wurde abgebrochen, Meldung 20005)!!!
    Muss noch irgendwo ein Fahrbefehl plus/minus getauscht werden?
    >>>Besten Dank<<<
    Andersherum gefragt, was hast du durch die Umstellung der Richtung bewirkt??? Es wurde ja offensichtlich was geändert, z.B. Referenzschalter versetzt oder ähnliches. Klär uns mal auf, vielleicht ist das ganze dann einfacher zu verstehen.

    Oder nimmst du evtl. den fahrbefehl zu früh weg???

    Aus dem Handbuch

    20 005 Achse %2 Referenzpunktfahrt wurde abgebrochen
    Ursache %2 = Achsname
    Das Referieren konnte für die angegebene Achse nicht abgeschlossen werden
    (z. B.: Wegnahme des Fahrbefehls u. a.).
    Wirkung 􀀀 NC-Startsperre
    􀀀 NC-Stop
    Behebung Abbruchursache kontrollieren:
    Quittierung Mit “NC-Reset” Fehler löschen.
    Zeige nie deine Verblüffung, wenn dir etwas auf Anhieb gelingt.

    Praxis: Es funktioniert aber keiner weiß warum!

  8. #8
    disdata ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    14.08.2008
    Beiträge
    9
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    So ,die ganze Sache funktioniert jetzt mit entgegengesetzter Referenzfahrt! Es war wie vermutet die Wegnahme des Fahrbefehls! In einem Baustein ist die Fahrtrichtung mit Referenzieren verknuepft (auch hier musste die Fahrtrichtung geaendert werden) und beim Signalwechsel Eingang Referenznocke wird die Klemmung geschlossen und die Freigabe fuer FM weggenommen! Vielen Dank fuer Eure Hilfe
    Zitieren Zitieren Richtungsaenderung funktioniert jetzt!!!  

Ähnliche Themen

  1. Referenzfahrt Incrementalgeber
    Von Wila im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 01.09.2011, 22:06
  2. Referenzfahrt mit SEW-FU funktioniert nur halb
    Von sk1rie im Forum SEW-EURODRIVE
    Antworten: 42
    Letzter Beitrag: 19.06.2011, 21:00
  3. Referenzfahrt mit der KL2541
    Von maximb im Forum CODESYS und IEC61131
    Antworten: 7
    Letzter Beitrag: 14.12.2009, 21:56
  4. Referenzfahrt bei Sinamics S120 mit CU320
    Von PeterEF im Forum Antriebstechnik
    Antworten: 7
    Letzter Beitrag: 18.03.2008, 08:13
  5. Referenzfahrt bei EM253 stoppen (S7-200)
    Von Daimonion im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 15.02.2008, 09:11

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •