Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: S7 Variablentabelle funktioniert falsch

  1. #1
    Registriert seit
    07.08.2009
    Beiträge
    109
    Danke
    86
    Erhielt 0 Danke für 0 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich hab im Moment ein ziemlich komisches problem.

    und zwar, hab ich im FC1 eine Funktion(1eingang und 1 ausgang) , die mir einen rohwert skaliert (mit FC105).

    im OB1 hab ich dem FC1 den eingang mit dem ersten analogeingang meiner sps PEW272 und den ausgang mit einem merkerwor MD 101 belegt.

    so funzt alls einwandfrei und ich bekomme richtige temperaturwerte.

    jetzt hab ich wieder den selben FC1 genommen, und den selben eingang PEW272 draufgegeben, aber diesmal ein anderes merkerwort als ausgang, nämlich MD102.

    normalerweise müsste md101 und md102 dasselbe sein.

    wenn ich die beiden FC1s im OB1 beobachte seh ich für md101 und md 102 auch den selben wert 27.

    wenn ich diese in der variablentabelle beobachte steht im md101 der wert 12 und im md102 der wert 27.

    ich finde das etwas verwirrend, weiß aber nicht warum das so ist.
    Zitieren Zitieren S7 Variablentabelle funktioniert falsch  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    MD101 und MD102 überschneiden sich. Nimm doch MD100 und MD104

  3. Folgender Benutzer sagt Danke zu marlob für den nützlichen Beitrag:

    win98 (17.08.2009)

  4. #3
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.222
    Danke
    533
    Erhielt 2.697 Danke für 1.949 Beiträge

    Standard

    MD 101 und 102 überlappen sich ausßerdem sind das Doppelworte und keine Worte!

    Nimm MD100 und MD 104
    oder
    MW 100 und MW 102

    Am besten immer einen geraden Wert. MD 101 funktioniert zwar auch ist aber unüblich!

    PS: Wenn du das Online im FC beobachtest geht das, da zuerst MD101 geschrieben wird, dann MD102, du siehst also die Ergebnisse nacheinander. Wenn MD102 geschrieben wurde, ist das erste Ergebnis in MD101 natürlich zerstört und somit wird in der Var-Tabelle nicht das von dir erwartete Ergebnis auftauchen.
    Geändert von Ralle (17.08.2009 um 13:06 Uhr)
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  5. Folgender Benutzer sagt Danke zu Ralle für den nützlichen Beitrag:

    win98 (17.08.2009)

  6. #4
    win98 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.08.2009
    Beiträge
    109
    Danke
    86
    Erhielt 0 Danke für 0 Beiträge

    Blinzeln

    ha!
    man darauf wär ich nie gekommen, es klappt

    vielen dank

    wieso ist das denn so?

  7. #5
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von win98 Beitrag anzeigen
    wieso ist das denn so?
    Weil Siemens seine Zahlen aufs Byte bzw. Anfangsbyte bezieht:

    MD100 = MW100 / MW102 = MB100,101,102,103 = M100.0 - M103.7 ...

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  8. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    win98 (17.08.2009)

Ähnliche Themen

  1. Variablentabelle
    Von Andy_Scheck im Forum Simatic
    Antworten: 17
    Letzter Beitrag: 24.02.2010, 13:33
  2. Variablentabelle Ersatzwert?
    Von Hans.S im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 13.10.2009, 21:51
  3. Steureung in Variablentabelle
    Von manas im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 03.10.2007, 14:40
  4. Variablentabelle
    Von Pimsti im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 16.06.2006, 08:55
  5. Variablentabelle lügt ??
    Von Anonymous im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 10.08.2005, 17:13

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •