Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 17 von 17

Thema: AI => DI in mehreren Umbauphasen

  1. #11
    Registriert seit
    04.06.2008
    Beiträge
    118
    Danke
    7
    Erhielt 8 Danke für 7 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Mal ne bescheidene Frage.

    Ist die AI Karte nicht konfigurierbar ?

    Mach doch einfach aus dem Stromeingang einen 10V Spannungseingang.
    Einen Vorwiderstand und das Stromproblem ist gelöst.

    Dann hast Du doch einen fast Digitaleingang.....
    Zwei Dinge in dieser Welt sind unendlich !
    Das Universum und die menschliche Dummheit.

    Beim Universum bin ich mir allerdings noch nicht sicher......

    A.Einstein

  2. #12
    mega_ohm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard

    Zitat Zitat von erzteufele Beitrag anzeigen
    zu deiner frage Natürlich ist es möglich! *grins*
    ich würde aber darauf achten das ich im mittleren bereich liege d.h.

    +24V vom sensor + wiederstand "2.400Ohm" = 10mA
    und jetzt den Analogeingang einfach ... 8 bis 12 ist i.O. also "1" drunter und drüber ist "0" drüber sollte normal nicht vorkommen.
    Ok... ob ich mich nun auf 2,4 KOhm für 10 mA oder 1,3 KOhm für 18 mA
    oder 1,2 KOhm für 20 mA festlege.... ich denke, daß ist Geschmacksache.

    Oder warum sollte man im mittleren Bereich liegen ?

    Den dig. Sensor kann ich "anlernen" (den Schaltpunkt am Gerät festlegen ).
    Und ich kann mir nicht vorstellen das du ein 40A Netzteil hast das Spannungsstabilisiert ist das würde ja ein haufen asche kosten aber ist relative egal solang du nicht da voll am anschlag (20mA bzw. höherem) bereich bist.
    Ich "protze" nur ungern (ich hab's ja nicht bezahlen müssen / können)... aber bei einer Anlage, die 21 Mio.€ gekostet hat, waren 6 solcher Netzteile gerade noch möglich.
    Natürlich haben auch diese Teile keine Asche sondern € gekostet

    und Solange du in deinem Messbereich der Analogeingänge bleibst geht die aber nicht kaputt d.h. du bekommst keine neue "witz" muss ja nix mutwillig zerstören.

    Grüßel erzi
    Deine Worte in Gottes Ohr....

    Wenn diese Teile nicht kaputt gehen... ( und ich diese Woche nicht 3 Stk. hätte wechseln müssen ) habe ich natürlich überhaupt kein Problem mit analogen Gebern. ... es muß nur funktionieren.

    Mfg

  3. #13
    mega_ohm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard

    Zitat Zitat von Solaris Beitrag anzeigen
    @mega_ohm: Ich würde kein Poti einsetzen, einfach nur zwei Widerstände und einen davon brücken oder wegschalten, wie es am sichersten ist für die Anlage, so das man zwei eindeutige Werte erhält. Am besten gleich Widerstände mit kleinem Toleranzbereich (0,1%), die geben auch immer schön den richtigen Wert ab.
    2 Widerstände... 1 davon brücken....
    Dem kann ich nicht ganz folgen.

    Warum benötige ich 2 Widerstände, wenn ich einen davon brücke oder wegschalte ?
    Dann bleibt nach meinem Verständnis doch nur ein aktiver Widerstand... oder habe ich etwas übersehen ?

    Was spricht gegen einen Poti ? ( z.b. in der Ausführung, ihn auf eine kleine Platine zu löten )

    Mfg

  4. #14
    mega_ohm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard

    Zitat Zitat von Mispe Beitrag anzeigen
    sofern dein Controller-Fuzzi eine Digitale Eingangskarte spendiert, würde ich diese an der SPS einfach anhängen.
    Der Controller- Fuzzi will einfach nur eine 24h rund um die Woche funktionierende Anlage, die KEINE Instandhaltungskosten erzeugt... mehr nicht.

    Meine Frage:
    Warum sollte ich denn mit der Eingangskarte den Umbau beginnen ?
    Die AI ist noch ok... die Sensoren haben gesponnen.

    3.) eine Erkennung einbauen, ob das Analog-Signal ansteht (was bei einem 4..20 mA-Geber ja kein Problem ist) und damit automatisch eine Umschaltung auf dem Digitalen Eingang realisieren, wo dann der neue Geber angeschlossen ist.

    Damit kann ohne weitere Programmänderung einen anderen Geber einbauen.

    Ansonsten läßt sich sicher das Analog-Signal mit hilfe eines Festwiderstand simulieren.
    Das verstehe ich gar nicht... ( ich bin in der Elt.-Instandhaltung, manche Sachen muß man mir einfach nur erklären ! )

    Wenn ich als 1. eine dig. Eingangskarte einbaue, muß ich schonmal die HW- Config ändern.
    Ob dann ein PEW 720 ( Analog- Eingang ) immer noch ein PEW 720 (dig.) ist, weiß ich nicht. ( noch nicht )

  5. #15
    Registriert seit
    19.10.2007
    Ort
    far far away
    Beiträge
    478
    Danke
    114
    Erhielt 136 Danke für 95 Beiträge

    Standard

    Zitat Zitat von mega_ohm Beitrag anzeigen
    2 Widerstände... 1 davon brücken....
    Dem kann ich nicht ganz folgen.

    Warum benötige ich 2 Widerstände, wenn ich einen davon brücke oder wegschalte ?
    Du hast doch einen Stromeingang mit Mindestwert 4mA, das wäre doch schon mal einer, und der andere Wert wäre der zweite Zustand, ich gehe mal davon aus das Deine Baugruppe unter 4mA einen Drahtbruch bringt. Zwei Stromwerte erfordern zwei Widerstände. Und die beiden Grenzwerte solltest Du meiden weil die Gefahr eines Überschreitens hoch ist und die Eingangsbaugruppe Störungswerte (z.B. Drahtbruch) ausgibt.

  6. #16
    Registriert seit
    12.12.2006
    Ort
    Wehringen
    Beiträge
    1.471
    Danke
    248
    Erhielt 190 Danke für 155 Beiträge

    Standard

    Hallo,

    du willst uns jetzt aber nicht erzählen, daß du in den Instandhaltungskosten für eine 21000000€-Anlage keine 150€ für eine DI-Karte unterbringst?



    MfG

  7. #17
    mega_ohm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Sockenralf Beitrag anzeigen
    Hallo,

    du willst uns jetzt aber nicht erzählen, daß du in den Instandhaltungskosten für eine 21000000€-Anlage keine 150€ für eine DI-Karte unterbringst?



    MfG
    Doch !!! Genau das ist z.Zt. die Situation.
    Ich will jetzt erzählen, daß die Instandhaltungskosten für eine 21.000.000€-Anlage mit 150€ für eine DI-Karte z.Zt. nur schwer in der Controlling- Abteilung zu erklären sind.




    ________________________________________________________________

    Diese Anlage steht ja schon seit fast 2 Jahren und ist bezahlt... aber diese Anlage ist eine italienische "bella macina"... eine Diva.
    Sie wurde in 11/ 2007 aufgebaut... Probelauf: Ende 01/ 2008

    Dieses Sch**ßteil ist noch nie richtig gelaufen, trotz Fernwartung etc.
    ____________________________________________________________
    Diese Anlage ist eine Fotokopie einer Anlage einer deutschen Masch.Bau- Firma ( zukünftig als D-Firma bezeichnet ).
    Diese Anlage könnte von der D-Firma stammen, nur die Farbe stimmt nicht !
    Ganz heimlich habe ich schonmal darüber nachgedacht, daß Progi der D- Firma auf die Anlage der It- Firma drauf zu spielen und nur die E/A- Adressen anzupassen.

    Aber das ist geistiger Diebstahl ! << Sowas unterstütze ich nicht !
    Ich schreibe selbst Programme, habe früher in TP/BP,TASM, TC++ programmiert, habe mich mit viel Mühe in s5 reingefitzt, einige s7-Programme für firmeninterne Sachen geschrieben.

    Außerdem kenne ich die Programmierer der D- Firma auch persönlich... weiß, wieviel Hirnschmalz in deren Programmen steckt.

    In meinem stillen Kämmerlein zu Hause werde ich das aber mal durchexerzieren.. und ich würde mich arg wundern, wenn es nicht funktioniert, rein vom Masch. Ablauf.
    ( Anpassungen in der Visu wären nötig, Lauer PCS900 <=> TP270 )
    Wie geschrieben >> baulich ist die Anlage der It- Firma ein Klon von der Anlage der D- Firma... nur die Farbe ist anders !

    Die Anlage der D-Firma ist bedeutend komfortabler zu bedienen.... und diese Firma sieht selbst bei heute neuen Anlage keinen Grund für Fernwartung per Modem ! Deren Anlage läuft... und läuft... nun schon fast seit 8 Jahren nach der Inbetriebnahme sorgenfrei, abgesehen von Verschleißteilen ( die eben nur ersetzt werden müssen ). :respekt
    Geändert von mega_ohm (23.08.2009 um 01:55 Uhr)

Ähnliche Themen

  1. TCP- Verbindung mit mehreren Teilnehmern
    Von Sporty im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 31.05.2016, 08:13
  2. Kommunikation von mehreren 750-881
    Von 4Josh im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 22.03.2011, 09:58
  3. Datenaustausch mit mehreren CPU's
    Von seppi82 im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 12.09.2010, 12:02
  4. Antworten: 1
    Letzter Beitrag: 16.11.2007, 18:41
  5. Antworten: 9
    Letzter Beitrag: 20.11.2006, 16:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •