Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 23

Thema: Frage zur Regelung

  1. #11
    Registriert seit
    22.08.2009
    Beiträge
    60
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Also ich kann mich ja irren!
    Aber ist das nicht so, dass man bei einem Fu die Nennspannung und Strom des Motors einstellt?
    Anlaufphase: Beim erhöhen der Frequenz am FU ist die Läuferfrequenz niedriger als die der Ständerfrequenz.
    Somit wird eine Spannung in den Läufer Induziert. (Last wird bei ausreichend angelegter Frequenz überwunden). (Nur wenn natürlich die Kennlinie passt)-
    Bei dem Fu solltest Du eine Anlauf und Bremsrampe eventuell einstellen!
    Ach ja um deinen FU in der SPS sprich die 10 Volt vernünftig verarbeiten zu können müsstest Du Analogwerte verarbeiten können. Kannst Du das?
    Wie kann ich dir noch weiterhelfen?
    Geändert von rabit (24.08.2009 um 20:48 Uhr)

  2. #12
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    @ETim
    Das überhaupt nichts passiert liegt definitiv daran weil Man_On High ist, solange das der Fall ist wird
    der Eingang "MAN" permanent auf den Ausgang "LMN" geschoben, und der Rest vom Regler ist deaktiviert.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  3. #13
    ETim ist offline Benutzer
    Themenstarter
    Registriert seit
    03.04.2009
    Beiträge
    55
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von rabit Beitrag anzeigen
    Also ich kann mich ja irren!
    Aber ist das nicht so, dass man bei einem Fu die Nennspannung und Strom des Motors einstellt?
    Anlaufphase: Beim erhöhen der Frequenz am FU ist die Läuferfrequenz niedriger als die der Ständerfrequenz.
    Somit wird eine Spannung in den Läufer Induziert. (Last wird bei ausreichend angelegter Frequenz überwunden). (Nur wenn natürlich die Kennlinie passt)-
    Bei dem Fu solltest Du eine Anlauf und Bremsrampe eventuell einstellen!
    Ach ja um deinen FU in der SPS sprich die 10 Volt vernünftig verarbeiten zu können müsstest Du Analogwerte verarbeiten können. Kannst Du das?
    Wie kann ich dir noch weiterhelfen?

    Ja ich habe 2 Analogbauruppen an der SPS. Kein Problem.

    Beim Umrichter wird die Ausgangsfrequeunz und damit die Drehzahl des angeschlossenen Motors verändert.

    Vielleicht kam das bisher nicht richtig rüber: Es handelt sich um einen Motorprüfstand. 2 Motoren sind gekoppelt. Der Prüfling wird am starren Netz betrieben. Die Belastungsmaschine hängt am Umrichter. Durch veränderung der Ausgangsfrequenz dieses Umrichters verändert man die Drehzahl der Belastungsmaschine. Dadurch bremst man den Prüfling. Sowohl Prüflingsstrom wie auch der Strom der Belastungsmschine steigen an.

    Der Aufbau funktioniert so. Ohne Regelung (direkte Ansteuerung des Umrichters per PC) klappt alles. Ich möchte den ganzen Aufbau aber über ein Potentiometer regeln können. Leider funktioniert mein sich im Anhang befindlicher Entwurf noch nicht. Und ich frage mich warum nicht? Morgen kann ich weiter testen und evtl. noch mehr Hinweise posten.

  4. #14
    ETim ist offline Benutzer
    Themenstarter
    Registriert seit
    03.04.2009
    Beiträge
    55
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von MSB Beitrag anzeigen
    @ETim
    Das überhaupt nichts passiert liegt definitiv daran weil Man_On High ist, solange das der Fall ist wird
    der Eingang "MAN" permanent auf den Ausgang "LMN" geschoben, und der Rest vom Regler ist deaktiviert.

    Mfg
    Manuel
    Jo danke... ich werds morgen mal ändern und dann wieder posten. Vielen Dank für eure Mühe...

  5. #15
    ETim ist offline Benutzer
    Themenstarter
    Registriert seit
    03.04.2009
    Beiträge
    55
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Guten Morgen,

    ich habe nun MAN_ON ausgeschaltet. Weiterhin habe ich den Istwert auf Intern gestellt. Die Spannungen habe ich jetzt auf 0 - 10 V skaliert, damit ich nicht ständig umrechnen muss. Leider funktioniert die Regelung noch nicht. Ich habe zwar alle Werte (Ist- und Sollwert) aber er regelt einfach nichts. Bzw. auch bei Veränderung des Sollwerts passiert hinten am Ausgang (Stellwert) garnichts. Mal abgesehen davon das es ein exotischer Aufbau ist... grundsätzlich muss sich doch der Stellwert verändern, wenn Soll und Istwert am eingang unterschiedlich sind oder sehe ich da was falsch?

    Eine Frage mal zwischendurch. Ich habe die Werte skaliert. Wenn ich aber den FC41 beobachte, sind die Werte nicht im Format 0 - 10 V. Das heißt irgendwie bringt mir das skalieren dann nicht so viel. Kann man das noch umstellen?

    Ich setze mal das Programm in den Anhang. Ich kann mir nicht erklären warum der Regler rein garnichts tut...
    Angehängte Dateien Angehängte Dateien

  6. #16
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Also zum einen wird das MD10 (dein Sollwerteingang) am Regler nicht beschrieben,
    statt dessen verwendest du MD12 am Skalierungsbaustein im NW1.

    Ansonsten tut der Regler grundsätzlich bei mir ohne weitere Änderungen.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  7. #17
    Registriert seit
    19.01.2009
    Ort
    Hamm
    Beiträge
    83
    Danke
    24
    Erhielt 9 Danke für 8 Beiträge

    Standard

    Hey. Erstmal für mein Verständnis. Du möchtest einen DASM am starren Netz betreiben und diesen über einen weiteren mechanisch gekoppelten DASM belasten.
    Regelung hin und her ist ja alles schön. Kannst du deinem Frequenzumrichter dazu bringen in den Momentengesteuerten Betrieb zu wechseln? Somit währe ja nicht mehr deine Drehzahl bzw. Ausgangsfrequenz deine Größe mit dem du den starr am Netz betriebenen DASM belastest, sondern ein definiertes Drehmoment. Der FU regelt dann selbstständig Frequenz, Spannung und Strom für deinen DASM. Für nicht hochpräzise Ergebnisse würde da eine Betriebsart ohne Drehzahlrückführung auf den FU reichen, für bessere Ergebnisse ist dieser allerdings notwendig.
    Schreibt mal zurück was ihr von dieser Idee haltet.

    Bis dann, Sascha

  8. #18
    ETim ist offline Benutzer
    Themenstarter
    Registriert seit
    03.04.2009
    Beiträge
    55
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @ MSB

    Ich habe das MD geändert. Jetzt läuft es bei mir . Danke für die Hilfe.
    Die Regelung läuft leider noch etwas ruckelig, da der eingelesene Drehzahlwert stark schwankt und somit durch die Weiterverarbeitung der Stellwert ebenfalls schwankt.

    Jetzt meine Frage: Gibt es Filterbausteine bei Step 7? Oder gibt es die möglichkeit die Eingangswerte einzulesenen und online einen Mittelwert zu bilden? Ich muss das schwanken noch wegbekommen.

  9. #19
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Bevor du dir über eine Dämpfung Gedanken machst, die vermutlich nicht das mittel der Wahl ist in dem Fall,
    da das ganze wahrscheinlich doch ziemlich dynamisch(schnell) ist.

    Hast du die Regelparameter schon optimiert, allen voran P,I,D also Gain, TI, TD?

    Ansonsten versuche mal die Aufrufzeit des OB35 evtl. zu verlängern, so auf 200ms-300ms (Cycle am FB41 nicht vergessen anzupassen).
    Schneller dürften die Analogeingänge auch nicht sein, wobei das von der exakten Baugruppe abhängt.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  10. #20
    ETim ist offline Benutzer
    Themenstarter
    Registriert seit
    03.04.2009
    Beiträge
    55
    Danke
    6
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von MSB Beitrag anzeigen
    Bevor du dir über eine Dämpfung Gedanken machst, die vermutlich nicht das mittel der Wahl ist in dem Fall,
    da das ganze wahrscheinlich doch ziemlich dynamisch(schnell) ist.

    Hast du die Regelparameter schon optimiert, allen voran P,I,D also Gain, TI, TD?

    Ansonsten versuche mal die Aufrufzeit des OB35 evtl. zu verlängern, so auf 200ms-300ms (Cycle am FB41 nicht vergessen anzupassen).
    Schneller dürften die Analogeingänge auch nicht sein, wobei das von der exakten Baugruppe abhängt.

    Mfg
    Manuel
    Das Problem mit der Drehzahl ist, das es den Stellwert erst hinter dem Regler beeinflusst. Die Drehzahl läuft garnicht mit über den Regler. Der Regler an sich schwankt sehr wenig. Ich habe die Parameter angepasst und die Cycle Time auf 200ms gesetzt. Das klappt gut. Allerdings wird der Stellwert danach noch mit dem Drehzahlsignal subtrahiert. Und wenn das schwankt ist halt auch der Stellwert murx...

Ähnliche Themen

  1. Frage zur Regelung mittels FB 41
    Von ETim im Forum Simatic
    Antworten: 42
    Letzter Beitrag: 31.07.2009, 22:17
  2. Antworten: 15
    Letzter Beitrag: 09.04.2009, 20:57
  3. Regelung im OB1 ?
    Von kiestumpe im Forum Programmierstrategien
    Antworten: 10
    Letzter Beitrag: 27.02.2007, 22:12
  4. Frage zu PID regelung (FB58)
    Von Waelder im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 02.08.2005, 09:34
  5. Antworten: 4
    Letzter Beitrag: 18.05.2005, 18:49

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •