Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: SFC15 meldet falsche Laddr???

  1. #1
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,
    ich habe den SPC15 mit folg. Parametern beschaltet:

    Code:
          CALL  "DPWR_DAT"
           LADDR  :=W#16#112
           RECORD :=P#DB1.DBX0.0 BYTE 2
           RET_VAL:=MW34
    112 steht für PAW274

    Im RET_VAL bekomme ich:
    8093 Für die unter LADDR angegebene logische Adresse existiert keine DP-Baugruppe/kein PROFINET IO-Device, auf die/das Sie konsistente Daten schreiben können.

    Was kann das sein?

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.
    Zitieren Zitieren SFC15 meldet falsche Laddr???  

  2. #2
    Registriert seit
    29.01.2004
    Beiträge
    322
    Danke
    10
    Erhielt 22 Danke für 22 Beiträge

    Standard

    Hallo Tippser!
    Ich würde die Hardwarekonfig überprüfen, ob da die Adressen richtig eingestellt sind. Dann würde ich prüfen ob der Profibus generell läuft. Als nächstes würde ich die zwei Byte mal direkt zum Slave übertragen
    L db1.dbw0
    T paw274

    Gruß

    Andreas

  3. #3
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.218
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Ja, bei 2 Byte kannst du auch den SFC15 weglassen.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  4. #4
    plc_tippser ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard

    Hi
    ich habe die Daten zuerst direkt übertragen, aus der Var-Tabelle.
    Das ging.

    Anschließend habe ich das gleiche mit den SFC´s probiert, ohne Erfolg. Es werden mehr als 2 oder 4 Byte. Das ist nur ein Versuch, um ein Gateway zu testen.

    Die Hardwareadressen habe ich schon x-mal kontrolliert und der DP läuft.
    Wenn ich es wieder direkt mit lade+transfer. dann gehts.

    pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

  5. #5
    Registriert seit
    29.01.2004
    Beiträge
    322
    Danke
    10
    Erhielt 22 Danke für 22 Beiträge

    Standard

    Hallo Tippser
    Hier ein Auszug aus der Beschreibung zum SFC:

    Der Quellbereich muß dieselbe Länge aufweisen, die Sie für die selektierte Baugruppe mit STEP 7 projektiert haben.

    Ich verstehe das so, das der Quellbereich (also dein Record) so groß sein muß wie der in der HW-Konfig projektierte Bereich.

    Gruß

    Andreas

  6. #6
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 23 Danke für 20 Beiträge

    Standard

    Bischen schwer zu sagen, aber könnte es sein, das es vielleicht irgendwie hiermit zu tun hat?

    Aus dem Help-File:

    Der Quellbereich muß dieselbe Länge aufweisen, die Sie für die selektierte Baugruppe mit STEP 7 projektiert haben.

  7. #7
    plc_tippser ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    07.05.2004
    Ort
    Campbelltown
    Beiträge
    2.437
    Danke
    131
    Erhielt 276 Danke für 86 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Längen passten,

    aber, ich habe die Hardware auf 8Byte kons. geändert, den Pointer an den SFC´s angepasst und schau da guck, et geht.

    Danke für die Mühe, pt
    Gegen Schwachsinn, Schwachköpfe und armselige Trittbrettfahrer kann man nicht argumentieren.

    Gott sieht alles, auch Signaturen in Geheimschrift,,... aber er petzt nicht.

Ähnliche Themen

  1. OB35 und Sfc15
    Von simon.s im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 11.03.2011, 16:42
  2. Probleme mit SFC15
    Von breno im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 25.05.2009, 19:29
  3. Sfc15
    Von blume_mercan im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 17.01.2008, 14:28
  4. SfC14 / SfC15
    Von Mujo im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 14.08.2007, 14:20
  5. SFC15 Probleme
    Von tomatensaft im Forum Feldbusse
    Antworten: 0
    Letzter Beitrag: 19.05.2007, 18:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •