Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: Wie lange dauert es, bis ein Profibus- Fehler an der CPU angezeigt wird ?

  1. #1
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    Hardware ( alles DP )
    - s7-4xx ( Haupt- CPU )
    - mehrere s7-3xx
    - DP / DP- Buskoppler
    - mehrere ET200

    Folgendes Problem:
    - Die Busleitung in einer Energieführungskette muß eine Klatsche gehabt haben. Seitdem ich diese ausgetauscht habe läuft alles wieder so, wie man es kennt.

    Vorher wurde von einer s7-3xx ( die unter anderem eine Festo- Ventil-Insel ansteuert) kein Busfehler "angemeckert", aber sporadisch auftretend wurde die Ventil- Insel nicht mehr angesteuert... für einen Bruchteil einer Sekunde fuhren die (selbstrückstellenden) Pneumatikzylinder in ihre Ausgangslage... verloren das zu transportierende Material.
    Eingänge, die Kollisions- Bereiche zwischen verschiedenen Transporteuren überwachen, verloren kurz ihr Signal... => daraufhin schalteten Positionier-Regler in den "Handbetrieb" ( Positionier- Prg.nr. 5 ) , um kurz danach ins Automatik- Programm ( Nr. 8 für Auto- Heben, Nr. 9 für Auto- Senken ) von selbst zurück zu finden.

    Es wurde an keiner CPU ein BF angezeigt, auf die Bildschirme kam sowieso keine Meldung ( das hatte ich auch nicht erwartet )
    Aber der kurzzeitige Ausfall der Busleitung hat gereicht, das die Festo- Insel nicht mehr angesteuert wurde... für eine Fehlermeldung hat es nicht gereicht.

    Meine Fragen sind also...
    - Wie ist dieses Verhalten erklärbar ?
    ( Mir geht es nur um Fehler- Analyse, mit dem Tausch der Bus- Leitung ist das Problem seit jetzt 14 Tagen gelöst )
    - Wie lange muß ein Busfehler "anstehen", bis irgendeine CPU das erkennt ?

    Die Anlage ist über 100m lang.... die Wege sind also weit , genau dafür gibt es ja den (Profi-)Bus.

    Mfg
    Zitieren Zitieren Wie lange dauert es, bis ein Profibus- Fehler an der CPU angezeigt wird ?  

  2. #2
    Registriert seit
    28.01.2009
    Ort
    Hamburg
    Beiträge
    199
    Danke
    52
    Erhielt 54 Danke für 34 Beiträge

    Standard

    Mal abgesehen von der LED BF. Wie sah es den in den Diagnosepuffern der CPU`s aus.Mit welcher Visu arbeitest du.
    Zitieren Zitieren Wie lange dauert es, bis ein Profibus- Fehler an der CPU angezeigt wird ?  

  3. #3
    Registriert seit
    09.11.2007
    Ort
    Rhein Main (Darmstadt)
    Beiträge
    663
    Danke
    61
    Erhielt 112 Danke für 80 Beiträge

    Daumen runter

    In unsereren Projekten (Visualisierung, BDE, etc) erfassen wir jeden Fehler und schreiben ihn in ein Log File. Die Oberfläche bleibt erst einmal bis auf die StatusZeile aussen vor.

    Im Fehlerfall machen wir einige automatische Retrys (Anzahl einstellbar), wenn das nicht klappt wird eine Pause gemacht (ebenfalls einstellbar), der Bus, soweit es in unserer Hand liegt, neu initialisiert, die Kommunikation erneut versucht (und protokolliert) und dann so weiter, bis es jemand merkt, weil er auf den Bildschirm schaut, oder ein Wunder geschieht und alles wieder läuft.

    Die Siemens Seite ist hier recht träge, wenn ein Fehler auftritt, vermuten wir, kann es Minuten dauern ehe die SPS etwas registriert.
    Als Freelancer immer auf der Suche nach interessanten Projekten.
    Zitieren Zitieren Implementation und Konfiguration  

  4. #4
    Registriert seit
    29.03.2004
    Beiträge
    5.793
    Danke
    144
    Erhielt 1.706 Danke für 1.238 Beiträge

    Standard

    Überprüf doch mal die Profibus-Parameter beim der Master-SPS.
    Wenn dort das benutzerdefinierte Profil aktiviert ist, kann man die Werte alle einstellen. Macht man aber eigentlich nur bei größeren Profibus-Netzen mit LWL-Strecken / Ringnetze / OLM / Repeatern.

    Zitat Zitat von RobiHerb Beitrag anzeigen
    Im Fehlerfall machen wir einige automatische Retrys (Anzahl einstellbar), wenn das nicht klappt wird eine Pause gemacht (ebenfalls einstellbar), der Bus, soweit es in unserer Hand liegt, neu initialisiert, die Kommunikation erneut versucht (und protokolliert) und dann so weiter, bis es jemand merkt, weil er auf den Bildschirm schaut, oder ein Wunder geschieht und alles wieder läuft.

    Die Siemens Seite ist hier recht träge, wenn ein Fehler auftritt, vermuten wir, kann es Minuten dauern ehe die SPS etwas registriert.
    Die Anzahl der Retrys sind bei den Siemens CPUs/CPs auch einstellbar. Was nutzt ihr denn für Profibuskarten die besser sind? Sicher dass diesen Karten nicht auch der Siemens ASIC innewohnt?

  5. #5
    mega_ohm ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    02.11.2006
    Beiträge
    496
    Danke
    217
    Erhielt 25 Danke für 6 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von Bernard Beitrag anzeigen
    Mal abgesehen von der LED BF. Wie sah es den in den Diagnosepuffern der CPU`s aus.Mit welcher Visu arbeitest du.
    Diagnosepuffer der CPU:
    Dazu kann ich nix schreiben... weil ich mit dem PG an der Anlage bei diesem Fehler überhaupt nicht dranne war !

    Ich hatte die "üblichen Verdächtigen" im Blick...
    - Die Spannungsversorgung ( für die Ein- bzw. Ausgänge sind 2 verschiedene Zuleitungen in der Energieführungskette ) => das 2 Zuleitungen gleichzeitig "spinnen" => das kommt eher selten vor, wenn die Efk nicht mechanisch beschädigt ist.

    Die Visu: Ein Industrie- PC mit Win95 ( Die Visu- Software ist in C++ ) Die Anlage ist Bj. 2001.
    Trotzdem finde ich die Visu mega-gut... es gibt noch mehr als 100 freie Schnittstellen für Programmänderungen zwecks Betriebs-, Störmeldungen.
    Das Progi kann man nachträglich (in Step7 ) erweitern, Meldungen auf einen "freien" Merker schreiben. Dann schreibt man nur noch die Textdatei für die Fehlermeldung und einen Index für die Hilfe... und natürlich den Hilfetext => mit einem x-beliebigen Texteditor.
    In 10 min. hat man mehrere neue Klartext- Meldungen mit Hilfe- Funktion in die Anlage "eingespielt".
    Die Visu hat, betrieben von dem Uralt- Industrie- PC, höchstens einen Pentium4- Prozessor...
    Geändert von mega_ohm (09.10.2009 um 15:19 Uhr)

Ähnliche Themen

  1. Generierung dauert extrem lange
    Von Bensen83 im Forum HMI
    Antworten: 4
    Letzter Beitrag: 25.03.2011, 09:55
  2. Netzwerk wird nur in AWL angezeigt
    Von troedler77 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 16.03.2010, 11:58
  3. SFC14/SFC15, wie lange dauert das?
    Von Gecht im Forum Feldbusse
    Antworten: 3
    Letzter Beitrag: 11.11.2007, 16:19
  4. Antworten: 0
    Letzter Beitrag: 12.10.2007, 09:47
  5. Antworten: 3
    Letzter Beitrag: 17.02.2005, 12:23

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •