Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: DCF 77 von SIPLUS

  1. #1
    Registriert seit
    21.02.2006
    Beiträge
    18
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Ausrufezeichen


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    ich will bei einem Kunden einen DCF Empfänger von SIPLUS einbauen. Zuerst gab es enorme Schwierigkeiten einen Platz zu finden. Nun hab ich den Platz, da geht's trotzdem nicht.
    Ich hab ne CPU 412/2 und den originalen Baustein von Siemens. Die DCF sek LED blinkt fast genau im sek Takt und die DATA LED leuchtet auch mit (mal länger, mal kürzer). Hab alles beschaltet. Aber das war es dann auch schon. Der Rest regt sich nicht. Da ändert sich nix. Kann mir da jemand helfen?

    Bis jetzt ist es zum

    Hilfe Forge_01
    Wenn etwas scheinbar nicht schiefgegangen ist, dann ist es vermutlich doch schiefgegangen. Es sieht nur richtig aus.
    Zitieren Zitieren DCF 77 von SIPLUS  

  2. #2
    Registriert seit
    04.01.2006
    Ort
    Wuppertal
    Beiträge
    664
    Danke
    122
    Erhielt 105 Danke für 91 Beiträge

    Standard

    Hab mich auch lange mit dem Ding rumgeärgert.
    Schon der FB ist ein Unding (BCD Wandlungsfehler) - oder gibts da mittlerweile was Neues?
    Theoretisch müsste meiner funktionieren (habe den FB überarbeitet), aber die Erkennung, ob 60sec. verstrichen sind klappt anscheinend nicht
    Habe nichtmehr die Motivation, mich damit auseinanderzusetzen.

    Was besser funktionieren soll ist der Oscat Baustein mit dem DCF Empfänger von Conrad (nicht Reichelt oder Pollin) (kein Scherz!)
    Habe ich aber persönlich noch nicht getestet, ist aber für eine Produktivumgebung aber auch Bastelei.
    Die meisten Menschen sind zu gut erzogen, um mit vollem Mund zu sprechen, aber sie haben keine Bedenken, dies mit leerem Kopf zu tun.
    Wenn ich sage: Ich mache das, dann mache ich das - da braucht man mich auch nicht jedes halbe Jahr daran zu erinnern!

  3. #3
    Avatar von Forge_01
    Forge_01 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    21.02.2006
    Beiträge
    18
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Würde die Sache gern umgehen aber der Kunde besteht auf die "Atomzeit" aus dem Hause Siemens.
    Es ging alles so gut, bis er das Ding angebracht hatte. Nach dem Motto "Meine Lösung, Ihr Problem". Das komische ist nur das der Sek Takt taktet und scheinbar ein DATA Paket ankommt dass der CPU Takt noch dazu aber die andere Seite ignoriert mich und die Takte erfolgreich.

    Forge_01
    Wenn etwas scheinbar nicht schiefgegangen ist, dann ist es vermutlich doch schiefgegangen. Es sieht nur richtig aus.

  4. #4
    Registriert seit
    03.06.2009
    Ort
    Steinwurf zur Schweizer Grenze
    Beiträge
    51
    Danke
    2
    Erhielt 34 Danke für 10 Beiträge

    Standard

    Hallo zusammen,

    wir haben den Empfänger auch in einem Projekt eingesetzt. Leider funktioniert das Ganze noch nicht immer. Wir sind noch auf der Suche nach der Ursache. Vermutlich sind es EMV Einflüsse.

    Prinzipiell funktioniert der Empfänger und auch der FB liefert die richtige Uhrzeit.

    Wir mussten den Empfänger leider bereits nach 2 Jahren das erste Mal austauschen, da dieser nicht mehr funktionierte.

    Wichtig ist bei der Programmierung:
    - der FB muss in einem OB mit einer Zykluszeit <= 100 ms aufgerufen werden.
    - Die Digitaleingänge müssen auch in dieser Zeit abgetastet werden können, d.h. es ist nur auf einem Zentralrack möglich (nicht an einer ET200 über Profibus)

    Wo Euer Problem genau liegt, kann ich so nicht beantworten, aber vielleicht helfen Euch die beiden Aussagen etwas weiter.
    SPS: Step 5 und 7
    Visualisierung: Protool, WinCC flexible, WinCC, iFix, Cimplicity, Bartec, Stahl, Extec
    PLS: PCS7, DeltaV

  5. #5
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard

    Ich hab das Ding auch im Einsatz.
    Nach anfänglichen Problemen läuft das aber recht gut.
    Wenn man den Instanz-DB zu dem FB beobachtet
    kann man sehen ob überhaupt mal ein komplettes Telegramm empfangen wird.
    Wenn nicht dann würde ich das Ding mal woanders positionieren.
    Den FB von Siems kann man vergessen.
    Ich habe von Edison einen modifizierten FB bekommen (Danke nochmal )
    den ich noch etwas verändert habe.
    Diese ständigen BCD-Wandlungsfehler waren zum ...
    Wichtig ist auf jeden Fall ein guter Signalempfang - sonst geht gar nichts.
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

  6. #6
    Registriert seit
    04.01.2006
    Ort
    Wuppertal
    Beiträge
    664
    Danke
    122
    Erhielt 105 Danke für 91 Beiträge

    Standard

    Ich habe versucht das Modul an einer Speed 7 zu bertreiben, Zykluszeit liegt bei 1-2ms das reicht auf jeden Fall um die Impulse des DCF Moduls sicher zu erkennen.
    Wenn ich mich recht erinnere, dann soll der Takt alle 60sec. für eine Sekunde ausbleiben um ein vollständiges Telegramm / Telegrammbeginn zu erkennen.
    Mein DCF Modul macht dann aber einen sehr kurzen Takt statt gar keinem.
    Sicherlich wird dieser dann von der CPU erkannt und fälschlicherweise ausgewertet.

    @crash
    Was hast Du denn noch geändert / hast Du noch etwas gefunden?
    Die meisten Menschen sind zu gut erzogen, um mit vollem Mund zu sprechen, aber sie haben keine Bedenken, dies mit leerem Kopf zu tun.
    Wenn ich sage: Ich mache das, dann mache ich das - da braucht man mich auch nicht jedes halbe Jahr daran zu erinnern!

  7. #7
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard

    Das Ding hat gelegentlich eine total falsche Zeit empfangen - wie auch immer das Ding dass geschafft hat.
    Jedenfalls hatte ich plötzlich eine falsche Zeit auf der CPU.
    In einem Netzwerk war schon eine Abfrage ob die Differenz zwischen aktueller Zeit
    und alter Zeit größer als +1H1M300MS ist.
    Somit konnte keine Zeit übernommen werden die eine größere Abweichung hatte.
    Es fehlte jedoch eine Abfrage ob eine Differenz in die andere Richtung bestand (jüngeres Datum).
    Dieses habe ich noch ergänzt und seitdem funzt es.
    Wenn ich den Instanz-DB beobachte sehe ich dass der Vogel sehr oft fehlerhafte Telegramme empfängt.
    Das stört mich aber nicht weil es keine Auswirkungen mehr hat.
    Theoretisch würde es ja reichen wenn einmal am Tag die Zeit syncronisiert wird.
    Bei mir ist es viel öfter der Fall.
    Wenn ich die CPU-Zeit mit der Braunschweiger-Zeit vergleiche -> keine Abweichung.
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

  8. #8
    Avatar von Forge_01
    Forge_01 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    21.02.2006
    Beiträge
    18
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So.... Wieder ne Woche beim Kunden ohne das das DCF Ding läuft. Der Wahnsinn ergreift einen schon wenn nix geht. Es blinkt und leuchtet alles aber es kommt kein komplettes Telegramm an. Es war total egal wo ich mich befunden habe. Der Empfänger ist ok aber trotzdem ist das Ding komisch. Ich werd versuchen meinem Kunden was anderes vorzuschlagen. Im DB blinkt und läuft alles aber die Überwachung der Telegramme läuft auf 201 und bleibt da stehen. Werd's wohl jetzt aufgeben. Danke für die Hilfe!!
    Wenn etwas scheinbar nicht schiefgegangen ist, dann ist es vermutlich doch schiefgegangen. Es sieht nur richtig aus.

  9. #9
    Registriert seit
    13.02.2009
    Beiträge
    6
    Danke
    1
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Hallo,
    bin erst jetzt auf diesen Beitrag gestossen.
    Ich hatte bei mir auch Probleme mit dem Siplus, ich habe dann im Siemensforum folgenden Beitrag dazu gefunden:
    http://www.automation.siemens.com/WW...41&language=de

    Im vierten Post ist ein Dateianhang mit geänderten Bausteinen, seitdem ich den im Einsatz habe funktioniert der DCF Empfänger.

  10. #10
    Registriert seit
    17.04.2007
    Ort
    Kiel
    Beiträge
    496
    Danke
    162
    Erhielt 67 Danke für 63 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ganz dumpf kann ich mich erinnern, dass die Zykluszeit (OB1) nicht unter 10ms Sekunden sein darf. Aber ich habe das Teil auch vor Jahren eingesetzt, kann mittlerweile anders sein.
    So einfach wie möglich – so kompliziert wie nötig.

Ähnliche Themen

  1. Hilfe! S7 1200 SIPLUS keine Kommunikation
    Von slk230-power im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 21.01.2011, 21:24
  2. Wer hat Erfahrung mit SIPLUS DCF77 Modul und FB77 ?
    Von MarioDisketti im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 07.01.2006, 21:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •