Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 14

Thema: ET200S Poti an Analogeingang

  1. #1
    Registriert seit
    21.04.2009
    Beiträge
    90
    Danke
    2
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hi,

    kurze Frage. Es soll ein Poti über einen Analogeingang an ner ET200s augewertet werden. Gibt es eine Möglichkeit das Poti (müssten glaube ich 10kOhm sein) auzuwerten, ohne, dass ich extra mit den 10V in jede Untergruppe fehren muss? Die Potis sind in mehreren Untergruppen verteilt, die ich sonst alle noch zusätzlich mit 10V versorgen müsste. Hab bis jetzt leider keine andere möglichkeit gefunden.

    Die UNtergruppen werden mit diversen 24V Potentialen (Steuer, SPS, Last,...) in einer Leitung angefahren. Hättet ihr da gegebenenfalls Bauchschmerzen da die 10V auch noch mit rein zu packen? Oder sollte man die extra verlegen.

    Gruß
    the_elk
    Zitieren Zitieren ET200S Poti an Analogeingang  

  2. #2
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.337
    Danke
    448
    Erhielt 688 Danke für 513 Beiträge

    Standard

    Zitat Zitat von the_elk Beitrag anzeigen
    Hi,

    Die UNtergruppen werden mit diversen 24V Potentialen (Steuer, SPS, Last,...) in einer Leitung angefahren. Hättet ihr da gegebenenfalls Bauchschmerzen da die 10V auch noch mit rein zu packen? Oder sollte man die extra verlegen.

    the_elk
    Verlaufen in diesem Kabel auch anderer Signalleitungen? Außerdem was meinst du mit Last? Du meinst schon 24VDC-Last oder?

    Solange du mit 24V, 24VDC meinst hab ich keine bedenken die 10VDC noch mit in die selbe Leitung zu packen. 2 verschiedene Kleinspannungen in einem Kabel sehe ich nicht als Problem. Wichtiger ist eher das man diese Leitung von irgendwelchen 400VAC Leitungen fernhält (Seperate Kabeltasse...usw.)

    Wenn dir die Lösung nicht gefällt könntest du die nötigen 10VDC auch Vor-Ort erzeugen. Es gibt da zum Beispiel sehr kleine "Netzteile" (ist in wirklichkeit nur ein LM7810 mit Mindestbeschaltung drin) die sind billig, klein und werden von unserer Firme bei solchen Dingen öfters mal eingesetzt. Aber die Signalleitung muss dann am Ende ja doch wieder Retour.

    Und sonst musst du die 10VDC tatsächlich extra ziehen. Ob man jetzt nur ein Steuerkabel oder zusätzlich ein zweites zieht (solange es im selben Arbeitsgang passiert) ist doch auch nicht der Welt-Unterschied.
    Geändert von RONIN (21.10.2009 um 22:55 Uhr)

  3. #3
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.712
    Danke
    398
    Erhielt 2.398 Danke für 1.998 Beiträge

    Standard

    ... wie wäre es, wenn du zur Speisung des Poti's die 24V über einen Vorwiderstand hernimmst ? Bei einem 10k Poti könnte man da gut einen 15k Vorwiderstand nehmen und schon klappt es ...

    Gruß
    LL

  4. #4
    Registriert seit
    12.12.2006
    Ort
    Wehringen
    Beiträge
    1.471
    Danke
    248
    Erhielt 190 Danke für 155 Beiträge

    Standard

    Hallo,

    hat die ET200 auch AO´s?

    Quick-and-dirty: einen AO (mit 10V beschrieben) als Spanunngsversorgung für das Poti verwenden


    MfG

  5. #5
    Registriert seit
    26.03.2007
    Beiträge
    47
    Danke
    2
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    warum man hier eine Spannungsversorgung braucht verstehe ich nicht...
    Habe da ein ganz anderes Problem, wenn ich mein 10k Poti an den Analogeingang meiner ET200S (134-4NB51) Pin 1 M+ und Pin 2 M- anschließe funktioniert alles soweit ganz gut. Da ich in der Hardware-Config festlegen muss, was ich für einen Widerstandswert anschließen will, kommen meine Probleme, da nur 150, 300, 600 oder 3kohm zur verfügung stehen. Diese komischen Widerstandswerte gibt es normalerweise nicht standard...
    Wenn ich jetzt mein Poti auf ~0ohm drehe habe ich im PEW ~0 stehen, soweit alles gut. Drehe ich das Poti auf ~3kohm habe ich 32767 im PEW alles super, aber was mache ich jetzt mit dem "Restweg" 3k - 10k? Kann ich somit nur eine 1/4 Drehbewegung nutzen?
    Oder muss man hier einen Bauerntrick verwenden und ein Poti auswählen <3k also 2,2k wäre standard und komme dann im PEW maximal auf ~21844 und kann somit das Poti voll ausnutzen. Dann noch skalieren und fertig!
    Ist das Sinn der Sache, ist das so gewollt?

    Vielen Dank an die Checker

  6. #6
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.337
    Danke
    448
    Erhielt 688 Danke für 513 Beiträge

    Standard

    Duh... Also wenn ich das richtig verstehe willst du lediglich ein Poti über einen AI einlesen oder?

    Na gut.
    Obwohl der Ansatz mit der Wiederstandsmessung nicht ganz falsch ist bringt das die oben genannten Probleme mit sich... Deshalb macht das auch keiner so!!!

    In 99.9% nimmt man eine 10V - Spannungsquelle und hängt sie ans Poti (ergibt dann 0-10V am Schleifer).
    Dann stellt man seine Analogeingang in der Hardware-Config ebenfalls auf Spannung_0-10V.
    Viola man kann den ganzen Bereich des Potis ganz normal auswerten.

    Ich habs noch nie jemand anders machen sehn.
    Obwohl deine sogenannte "Bauernlösung" auch korrekt wäre....
    Geändert von RONIN (03.09.2013 um 15:40 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  7. #7
    Registriert seit
    06.10.2003
    Beiträge
    3.408
    Danke
    449
    Erhielt 503 Danke für 407 Beiträge

    Standard

    Zitat Zitat von S1MoN Beitrag anzeigen
    ..Ist das Sinn der Sache, ist das so gewollt?..
    Wie RONIN schon schrieb, es ist eine reine Widerstandsmessung. Was für dich ideal wäre, ist eine 750-464 von Wago. Dort kannst du ein Poti direkt als Spannungsteiler anschließen. Entgegen der Angaben im Handbuch funktioniert es auch mit höheren Widerstandswerten. Ich glaube, Potis mit 10kOhm hatte ich auch schon daran im Einsatz. Bei Siemens ET200S gibt es derzeit noch keine Klemme, die das kann.

    Gruß, Onkel
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  8. #8
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.337
    Danke
    448
    Erhielt 688 Danke für 513 Beiträge

    Standard

    Also in meinem Kopf sammeln sich immer mehr Fragezeichen....

    Das einfachste ist du vergisst das Modul (oder misst irgendwas anderes damit (z.b.: Temperatur)) und schnappst dir ein Spannungsmodul.
    z.B.: 6ES7134-4FB01-0AB0. Dort hängst du dann wie Dagobert sagte dein Poti als Spannungsteiler rein. Fertig

    Das Poti kann dann auch wer weiß wie viel kOhm haben!

    Das Modul ist eigentlich nicht zum auswerten von Potis gedacht....
    Sofern du also dein Poti nicht auf die angegeben +/- 0,01% vermessen willst, ist dieses Modul wohl übertrieben und auch zu teuer....
    Geändert von RONIN (03.09.2013 um 18:43 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

  9. #9
    Registriert seit
    06.10.2003
    Beiträge
    3.408
    Danke
    449
    Erhielt 503 Danke für 407 Beiträge

    Standard

    Zitat Zitat von RONIN Beitrag anzeigen
    .. 6ES7134-4FB01-0AB0. Dort hängst du dann wie Dagobert sagte dein Poti als Spannungsteiler rein. Fertig..
    Naja, von Basteleien habe ich zwar nichts gesagt, ginge aber auch irgendwie. Man darf halt das Poti nicht überlasten und man benötigt eine stabile Spannung.
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  10. #10
    Registriert seit
    23.07.2009
    Ort
    Österreich
    Beiträge
    2.337
    Danke
    448
    Erhielt 688 Danke für 513 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Bastelei??? Kann ich hier keine erkennen.
    Hab noch keinen in der Siemens-Welt das anders machen sehen.
    Aber vielleicht kann mich ja einer aufklären...

    Das mit Genauigkeit der Spannung ist nicht falsch, aber ich kann mir nicht vorstellen dass das verwendete Poti
    genauer als +/-1% ist. Wenn du einen Ohm-Wert misst müssten du theoretisch sogar jedes Poti von
    0-100% ^= 0Ohm bis 10kOhm+Toleranz kalibrieren....

    EDIT: Überlasten? Wir sprachen von +10VDC an den Enden des Potis... Der Spannungseingang ist hochohmig...
    was soll man da überlasten?
    Geändert von RONIN (03.09.2013 um 19:20 Uhr)
    If at first you don't succeed, you're not Van Damme!
    ... or maybe using TIA!

Ähnliche Themen

  1. Drehgeber als Poti ersatz 'Digital Poti'
    Von GFI im Forum Elektronik
    Antworten: 1
    Letzter Beitrag: 08.11.2008, 21:08
  2. SM 334 - ext. Spannung und Poti - wie?
    Von Grmpf im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 29.10.2008, 12:16
  3. poti an sm 331
    Von prinz1978 im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 26.06.2007, 18:09
  4. poti simulieren
    Von prinz1978 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 10.05.2007, 18:57
  5. Poti in SPS
    Von Willy im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 16.03.2007, 08:31

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •