Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: S7 300 an Moeller Easy-104-DP via Profibus

  1. #1
    Registriert seit
    23.05.2007
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,
    hat von euch schonmal jemand eine 300er S7 über Profibus an eine Moeller Easy 700er Steuerung mittels einem Easy 204-DP gekoppelt?
    Mein Problem ist das es nur für die 600er Reihe fertige Bausteine bei Moeller gibt.
    Die Profibusverbindung funktioniert.
    Ich schicke der Moeller die HEX-Werte (laut Moeller-Anleitung) zum Auslesen der Digitaleingänge inkl. toggle-bit, bekomme aber nichts ausgelesen.
    Hab auch schon im Moeller-Forum gesucht finde aber leider nichts passendes
    Geändert von Markus (17.04.2013 um 17:18 Uhr)
    Zitieren Zitieren S7 300 an Moeller Easy-204-DP via Profibus  

  2. #2
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    sieht es bei dir ungefähr wie im anhang aus?
    da haben doch die Eingänge schon Adressen, die kann man doch benutzen ... oder verstehe ich deinen Auftrag falsch?
    Angehängte Grafiken Angehängte Grafiken
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. #3
    Kaefermania ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.05.2007
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Nicht ganz,
    ich habe anstatt der 3 Eingänge bzw. Ausgänge das Modul mit 9Bytes gewählt (Moeller Prozessabbild lesen-schreiben).
    Das hat den Vorteil das nicht nur Ein- bzw Ausgänge gelesen und geschrieben werden können sondern auch alle Merker,Zeiten Analogeingänge usw.

    So wie du es projektiert hast hatte ich es auch am Anfang, hatte aber das Problem das ich nur die Ausgänge damit lesen kann, die Eingänge lassen sich meiner Meinung nach damit nur schreiben nicht lesen.
    Vorrausgesetzt ich verstehe die Moeller Anleitung richtig.

  4. #4
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Kaefermania Beitrag anzeigen
    Nicht ganz,
    ich habe anstatt der 3 Eingänge bzw. Ausgänge das Modul mit 9Bytes gewählt (Moeller Prozessabbild lesen-schreiben).
    Das hat den Vorteil das nicht nur Ein- bzw Ausgänge gelesen und geschrieben werden können sondern auch alle Merker,Zeiten Analogeingänge usw.

    So wie du es projektiert hast hatte ich es auch am Anfang, hatte aber das Problem das ich nur die Ausgänge damit lesen kann, die Eingänge lassen sich meiner Meinung nach damit nur schreiben nicht lesen.
    Vorrausgesetzt ich verstehe die Moeller Anleitung richtig.
    eingänge schreiben? ausgänge lesen? waaaaah ... verkehrte welt ...

    arbeitest du mit SFC14 und 15?? oder wie hast du die kommunikation aufgebaut?
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  5. #5
    Kaefermania ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.05.2007
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja, ich arbeite mit SFC14/15.
    Werde mich heute nochmals damit befassen, vielleicht klappts dann ja endlich...
    Hab bestimmt nur irgendwas übersehen.

  6. #6
    Kaefermania ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    23.05.2007
    Beiträge
    7
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ich habs hinbekommen.
    Hab den Baustein nochmal komplett gelöscht und neu geschrieben, war wohl irgendein Fehler drin.
    Tippe auf falsche Aressierung oder irgendein Steuerbefehl zur EASY verkehrt.

  7. #7
    Registriert seit
    01.02.2013
    Beiträge
    4
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hab auch ein problem mit so einer steuerung. Die werte von der easy schwanken extrem, also die 9 steuerbytes eingang und ausgang. mal sind sie da dann wieder weg. haben den dp koppler getauscht von der easy bringt nix. die ganzen bausteine sind doppelt für 2 anlagen eine geht die andere nicht. hab die bausteine überprüft sind alle identisch nur halt die eingangs und ausgangs werte sind unterschiedlich.

Ähnliche Themen

  1. PS4-341 und Easy 819-AC-RC von moeller zu verkaufen
    Von grizzlyco im Forum Suche - Biete
    Antworten: 1
    Letzter Beitrag: 21.02.2013, 21:09
  2. Moeller EASY 412 DC TC
    Von AlterEgo im Forum Sonstige Steuerungen
    Antworten: 5
    Letzter Beitrag: 13.08.2009, 23:04
  3. Moeller easy 412/512 mit AD Signal?
    Von uwe kraeusel im Forum CODESYS und IEC61131
    Antworten: 1
    Letzter Beitrag: 29.05.2009, 11:04
  4. Moeller Easy Kabel
    Von august123 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 13.05.2008, 22:03
  5. Moeller Easy Remanenz
    Von Robot-Sun im Forum Sonstige Steuerungen
    Antworten: 0
    Letzter Beitrag: 26.10.2007, 20:38

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •