Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 22

Thema: S7-1200 Analogwert Problem

  1. #11
    andy8883 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.12.2009
    Beiträge
    9
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Wenn ich 0V auf den Poti Eingang lege (also Drahtbrücke) habe ich die Schwankungen auch, da das daselbe ist wie Poti auf Linksanschlag (Poti auf Linksanschlag ist wie eine Drahtbrücke von 0V auf den Poti Eingang an der Karte).

  2. #12
    andy8883 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.12.2009
    Beiträge
    9
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @Crash

    Also heisst das für mich wenn ich den Wert weiterverarbeite und umrechne macht sich diese Schwankung nicht bemerkbar? Aber wie kommt der Wert von 65000 zustande? Rein rechnerisch dürften es mit Übersteuerungsbereich maximal -32000 bis +32000 sein.

    Gruß Andy

  3. #13
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard

    -------> normiere deinen Analogwert!
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

  4. #14
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard

    Zitat Zitat von andy8883 Beitrag anzeigen
    @Crash

    Also heisst das für mich wenn ich den Wert weiterverarbeite und umrechne macht sich diese Schwankung nicht bemerkbar? Aber wie kommt der Wert von 65000 zustande? Rein rechnerisch dürften es mit Übersteuerungsbereich maximal -32000 bis +32000 sein.

    Gruß Andy
    Das liegt wohl an der Darstellungsart
    mit VZ -> -32768 bis +32767
    ohne VZ -> 0 bis +65535
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

  5. Folgender Benutzer sagt Danke zu crash für den nützlichen Beitrag:

    andy8883 (12.12.2009)

  6. #15
    andy8883 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.12.2009
    Beiträge
    9
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    OK. Danke!

    Gruß Andy

  7. #16
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard

    Deine 65534 sind in Wirklichkeit -1.
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

  8. #17
    andy8883 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.12.2009
    Beiträge
    9
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo nochmal,
    habe jetzt den Analogwert normiert und scaliert:
    Analog Eingabe mit NORM_X auf 0-27648 und dann die Ausgabe mit SCALE_X auf 0-100. Der Fehler besteht aber trotzdem d.h. bei 0V am Eingang bekomme ich entweder einen scalierten Wert von 237 oder 0 (obwohl ich auf 0-100 scaliere). Der Wert wechselt ständig hin und her. Hat vielleicht noch jemand eine Idee an was das liegen könnte?

  9. #18
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.745
    Danke
    209
    Erhielt 420 Danke für 337 Beiträge

    Standard

    Speicher doch einfach den gemessenen wert in einem Merkerwort zwischen! Und wenn er größer 65000 ist schreibst du einfach 0 in das Merkerwort.

    Vieleicht kann der SkallierungsFC nicht mit neg. Zahlen umgehen?
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten
    Zitieren Zitieren man...  

  10. #19
    andy8883 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    12.12.2009
    Beiträge
    9
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das mit dem Merkerwort ist eine Möglichkeit. Mich würde aber dennoch interessieren ob das normal ist oder die Karte eventuell einen Fehler aufweist.

    Gruß Andy

  11. #20
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ein analoger Wert wird immer etwas schwanken, das ist normal.
    Wenn du also einen Wert von 0 hast und der dann etwas schwankt
    dann kann da schon mal eine -1 kommen.
    Mach es doch so wie Jochen es vorgeschlagen hat.
    Den Wert auf kleiner 0 prüfen und wenn er kleiner ist eine 0 rein und fertig.
    Ich kenne jetzt nicht den Skalierbaustein der 1200er aber der sollte das
    eigentlich auch mit negativen Werten packen wenn er richtig parametriert ist.
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

Ähnliche Themen

  1. S7-1200 Analogwert Verarbeitung E/A
    Von Steve38 im Forum Simatic
    Antworten: 16
    Letzter Beitrag: 11.10.2012, 18:24
  2. Problem mit Analogwert
    Von Paul86 im Forum Simatic
    Antworten: 22
    Letzter Beitrag: 08.06.2011, 21:48
  3. S7 1200 Analogwert
    Von golfsiew im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 01.06.2011, 21:28
  4. Problem: Aus Analogwert Taktfrequenz erzeugen.
    Von schenser im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 22.10.2008, 20:09
  5. Analogwert Problem
    Von MatMer im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 02.03.2006, 10:36

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •