Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 28

Thema: Analogausgang ansteuern

  1. #1
    Registriert seit
    16.11.2009
    Beiträge
    65
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,
    folgende Sache: ich habe ein Analog-I/O-Modul für eine S7-300 vor mir liegen, und um mit dem Gerät etwas vertraut zu werden, würde ich gern als erstes einen Ausgang ansteuern, beziehungsweise mit nem Schieberegler in WinCCflex die Spannung von 0 bis 10V einstellen können.
    Ich habe bereits das Forum hier durchforstet nach ähnlichen Themen, aber so richtig schlau bin ich da als Erstanwender nicht geworden.
    Kennt da jemand ne gute Hilfe / Tutorial wie man so etwas grundlegend angeht? Wie bekommt man grundlegend so einen Ausgang angesteuert bzw. wie variiert man danach die Spannung?
    Zitieren Zitieren Analogausgang ansteuern  

  2. #2
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    am einfachsten mit FC106 und als eingang ein MD, welches du in der visu mit einem schieber beeinflußen kannst ...

    an den ausgang des 106ers hängt du das AW welches in der hardwarekonfig bestimmt wird ...
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. Folgender Benutzer sagt Danke zu vierlagig für den nützlichen Beitrag:

    00schneider (16.12.2009)

  4. #3
    Registriert seit
    13.04.2008
    Ort
    Großraum KA
    Beiträge
    963
    Danke
    52
    Erhielt 128 Danke für 112 Beiträge

    Standard

    Die Hilfe die beim FC106 hinterlegt ist (F1) benutzen und vielleicht genau das Beispiel das da beschrieben wird probieren.

    peter(R)

    Nachtrag: Solltest Du E0.0 , E2.0 und A0.0 nicht haben, dann einfach durch M0.0, M1.0 und M2.0 ersetzen.
    Geändert von peter(R) (16.12.2009 um 12:49 Uhr) Grund: Nachtrag

  5. #4
    Registriert seit
    16.11.2009
    Beiträge
    65
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Wenn ich ein Merkerdoppelwort, meinetwegen MD10 auf IN setze, funktioniert das soweit. Wenn ich dem MD10 in der Symboltabelle einen Namen gebe wird MD10 rot mit dem Hinweis: "Datentyp von IN passt nicht zum Symboltabelleneintrag der Aktualseite" Wasn da los? Ich brauch ja den Symboleintrag damit ich das MD auch in WinCCflex finde...

    Was der 106er so grob macht habe ich verstanden, er skaliert eine Real-Zahl in eine Ganzzahl. Was aber wär in meinem Fall ratsam als Hi und Low-Grenze zu setzen?

  6. #5
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    das MD muß in der symboltabelle als REAL deklariert sein
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  7. #6
    Registriert seit
    28.02.2006
    Ort
    Ostsee 5 min zum Strand
    Beiträge
    780
    Danke
    92
    Erhielt 110 Danke für 98 Beiträge

    Standard

    Zitat Zitat von 00schneider Beitrag anzeigen
    Was aber wär in meinem Fall ratsam als Hi und Low-Grenze zu setzen?
    Wie wäre es von 0.0 - 100.0 ? als % gedacht
    Gruß von der Ostsee

    Nordischerjung
    _____________________

    Wenn man seinem Paßbild ähnlich zu sehen beginnt, sollte man schleunigst Urlaub machen. (Vico Torriani, schw. Entertainer)

    Ich habe eine Diät gemacht und fettem Essen und Alkohol abgeschworen - in zwei Wochen verlor ich 14 Tage. (Joe E. Lewis)

  8. #7
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Nordischerjung Beitrag anzeigen
    Wie wäre es von 0.0 - 100.0 ? als % gedacht
    oder 0.00 bis 10.00 in Volt gedacht? ... 4..20 in Strom gedacht ... 16...32 in birnen gedacht...
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  9. #8
    Registriert seit
    16.11.2009
    Beiträge
    65
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ah danke, ganz übersehen. Ok, ich habe nun den 106er vollständig "beschriftet", und den OUT auf meinen Ausgang gesetzt (PAW).
    Hi-Limit ist 10.0, Low-Limit 0.0, also adäquat zu meinen Spannungswerten die mal rauskommen sollen.
    Ich bekomm es nun leider nicht ins CCflex implementiert, was muss ich beim Schiebregler alles einstellen bzw. wo kommt das Merkerdoppelwort ins Spiel?

  10. #9
    Registriert seit
    03.11.2006
    Ort
    Niedersachsen
    Beiträge
    1.126
    Danke
    170
    Erhielt 303 Danke für 259 Beiträge

    Standard

    Minimalen und maximalen Wert entsprechend einstellen.
    Bei 0 bis 10 Volt also min=0 und max=10.
    Und bei Prozess wo der rote Pfeil drauf zeigt dein Variable eintragen/auswählen.
    Hast du dein flex in Step7 integriert?
    Wenn nicht musst du die Variable von Hand anlegen unter Kommunikation/Variablen.
    Die Kommunikation hast du aber schon eingerichtet und die funktioniert!?
    Gruß
    crash

    Ich bin nicht bekloppt,
    ich bin verhaltensoriginell!

  11. #10
    Registriert seit
    16.11.2009
    Beiträge
    65
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Die Kommunikation funktioniert bereits und das flex ist im Step7 integriert. Ich habe ja nun ein MD auf den IN des 106ers gelegt, das MD ist jedoch REAL und will deshalb nicht in das Feld neben dem roten Pfeil am Schieberegler...wie umgehe ich das Problem?

Ähnliche Themen

  1. Analogausgang ansteuern mit 2 Tastern
    Von Detto im Forum Simatic
    Antworten: 30
    Letzter Beitrag: 16.11.2011, 13:27
  2. Analogausgang mit Rampe ansteuern (S7-200)
    Von sukram1711 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 04.03.2010, 17:08
  3. analogausgang
    Von markus277 im Forum Elektronik
    Antworten: 9
    Letzter Beitrag: 13.11.2009, 15:57
  4. S7-200 Analogausgang EM 232
    Von duese im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 30.08.2006, 08:09
  5. Antworten: 1
    Letzter Beitrag: 12.06.2006, 07:25

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •