Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 13

Thema: Ethernet zwischen 319-F 3PN/DP und 317F-2 PN/DP

  1. #1
    Registriert seit
    16.12.2009
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    ich versuche gerade eine Ethernet Kommunikation zwischen zwei CPU's herzustellen. Habe mir das Beispiel von Siemens heruntergeladen und verändert, aber bekomme es nicht zum laufen. Auch die pdf's von Siemens lassen mich keine Lösung finden ebenso wie das Forum (bisher jedenfalls).

    Also

    1x 319F-3PN/DP
    1X 317F-2PN/DP

    Habe den UDT angepasst und dort folgende Parameter eingetragen bzw in dem Baustein parameteriert:

    IP-Adressen habe ich natürlich die jeweilige des Remote angegeben.

    Meine TSAP sind
    TCP-1 bei beiden und entsprechend in jeder CPU ist loc_rack_slot B#16#02 und bei REm_Rack_SLOT B#16#0



    317F 319F
    id W#16#0001 W#16#0001
    connection type B#16#12 B#16#12
    active_est true false
    local_device_id B#16#02 B#16#03
    local_tsap_id_len B#16#00 B#16#02
    rem_staddr_len B#16#04 B#16#04
    rem_tsap_id_len B#16#02 B#16#00


    Es kommt aber keine Verbindung zustande, Status der 317 am TCONN Baustein ist die Meldung 7002 die selbe Meldung ist bei der 319 am TCONN Baustein. Kann mir jemand einen Tipp geben?
    Zitieren Zitieren Ethernet zwischen 319-F 3PN/DP und 317F-2 PN/DP  

  2. #2
    Registriert seit
    12.02.2008
    Ort
    Westfalen (Dort wo's Schwarzbrot gibt)
    Beiträge
    417
    Danke
    8
    Erhielt 87 Danke für 72 Beiträge

    Standard

    Sind beide REQ-Eingänge an TCON True?

  3. #3
    bene1983 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.12.2009
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja, beide TRUE

  4. #4
    Registriert seit
    12.02.2008
    Ort
    Westfalen (Dort wo's Schwarzbrot gibt)
    Beiträge
    417
    Danke
    8
    Erhielt 87 Danke für 72 Beiträge

    Standard

    Ist REQ fest auf True? In der Doku steht noch was davon, das die Bausteine eine positive Flanke an REQ brauchen. Also vielleicht zum Testen mal durch einen Merker ersetzen, den mal auf false und dann auf True.

    Ist aber auch nur ein Schuss ins Blaue....

  5. #5
    bene1983 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.12.2009
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Habe es mit dem Merker versucht, leider ohne Erfolg. Die positive Flanke verstehe ich so, dass der REQ Eingang 1 ist und das wird dann zurückgesetzt wenn die Verbindung hergestellt wird.

  6. #6
    Registriert seit
    25.11.2008
    Ort
    Westpfalz
    Beiträge
    1.550
    Danke
    187
    Erhielt 212 Danke für 186 Beiträge

    Standard

    Im Siemens Beispiel bei mir (weis nicht ob es das gleiche ist) ist ein Taktmerker M10.6 (der den Request setzend anstößt) verwendet. Ist der bei dir gleich mit dem in deiner projektierten CPU?
    and we all support the team (S.King - Die Arena)

  7. #7
    Registriert seit
    07.06.2006
    Ort
    Bayern
    Beiträge
    624
    Danke
    27
    Erhielt 156 Danke für 139 Beiträge

    Standard

    anstelle der TCP/IP Kommunikation mittels T-Bausteinen kannst du auch eine projektierte S7-Verbindung verwenden und dann mittels Put/Get (FB15,14) Daten zwischen den beiden CPU´s austauschen Link . Im Beispiel wurde zwar eine normale PN verwendet - es sollte aber bei einer F-Steuerung genauso funktionieren.

    Für die Erstellung des UDT´s bei der Kommunikation mittels T-Bausteinen gibt es den "Open Communication Wizard" Link (damit macht man weniger Fehler). Ausserdem sollte man daran denken bei Änderung des UDT´s auch den Datenbaustein der den UDT verwendet neu zu initialisieren, sonst stehen da nämlich noch die alten Werte drin !

  8. #8
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.639
    Danke
    377
    Erhielt 803 Danke für 644 Beiträge

    Standard

    TCP-1 bei beiden und entsprechend in jeder CPU ist loc_rack_slot B#16#02 und bei REm_Rack_SLOT B#16#0
    Vielleicht soll Rack/Slot = 0/2 sein für local und remote.
    Jesper M. Pedersen

  9. #9
    bene1983 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.12.2009
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Guten Morgen,

    @Mäuseklavier
    den Merker M10.6 ist für das Senden der Daten verantwortlich, hier habe ich einen extra Merker dafür, da ich nicht Zyklisch senden möchte.

    @uncle_tom
    Sollte es keine ander Möglichkeit geben werde ich wohl darauf zurückgreifen müssen, allerdings möchte ich das vermeiden mit einer S7-Verbindung.

    Den Wizard habe ich auch versucht und da hatte ich keinen Erfolg.

    @JesperMP
    Das habe ich direkt aus dem Beispiel von Siemens so übernommen und die sagen das muss so sein weil man für den Lokalen ein E0.02 davor setzten muss und für den Remoten nicht. (kommt von hier http://support.automation.siemens.com/WW/llisapi.dll?func=cslib.csinfo〈=de&objid=29737976&caller=view )

    Werde mal nochmal den UDT mit dem Wizard erstellen und dann vergleichen, die Initialisierung hatte ich natürlich gemacht. Dachte eigentlich nicht, dass es so schwer ist eine Verbindung herzustellen. Mal weiter suchen...

  10. #10
    Registriert seit
    12.02.2008
    Ort
    Westfalen (Dort wo's Schwarzbrot gibt)
    Beiträge
    417
    Danke
    8
    Erhielt 87 Danke für 72 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Beide SPSen im gleichen Netz?

Ähnliche Themen

  1. Antworten: 5
    Letzter Beitrag: 13.07.2011, 22:15
  2. Antworten: 5
    Letzter Beitrag: 20.04.2010, 21:09
  3. 317F mit Ethernet-Schnittstelle
    Von kai86 im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 11.03.2010, 14:11
  4. Antworten: 3
    Letzter Beitrag: 01.12.2009, 23:20
  5. Antworten: 10
    Letzter Beitrag: 21.01.2008, 09:01

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •