Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 14 von 14

Thema: Einschaltmerker für 1. Zyklus

  1. #11
    Registriert seit
    18.10.2009
    Beiträge
    220
    Danke
    71
    Erhielt 17 Danke für 16 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ich versteh dein Problem nicht ganz, der einfachste Weg ist:

    Im OB100

    S Mx.x

    =======

    Im OB1

    call FC"Neuanlauf" // ich mag im OB1 nur Bausteinaufrufe, keinen sonstigen Code

    ==========

    Im FC"Neuanlauf"

    UN Mx.x
    BEA

    // hier dein Code

    R Mx.x

    =====================

    Ist einfach und mit überschaubarer Struktur

    Gruß Bär

  2. #12
    Registriert seit
    24.12.2009
    Beiträge
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Welchen 1. Zyklus meinst du denn überhaupt:

    a) den 1. Zyklus nach Urlöschen und Laden des Programms in die CPU
    b) den 1. Zyklus immer wenn Stop->Run
    c) den 1. Zyklus bei automatischem Wiederanlauf (in RUN, nach Spannungsausfall)
    Geändert von uhrzeiger (24.12.2009 um 14:55 Uhr)
    Zitieren Zitieren 1. Zyklus  

  3. #13
    Registriert seit
    27.10.2005
    Beiträge
    47
    Danke
    1
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Code:
    Netwerk 1
    
      L     #OB1_SCAN_1
      L     B#16#3
      <>I   
      =     M      0.2
    
    Netzwerk 2
    
      U     M      0.2
      S     A      3.1
    @Jiss funktionieren tut das schon mit PLCSIM
    der A3.1 wird bei Anlauf gesetzt und lässt sich
    dann jederzeit zurücksetzen.

  4. #14
    Registriert seit
    27.06.2009
    Ort
    am Nordharz
    Beiträge
    3.738
    Danke
    444
    Erhielt 924 Danke für 744 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ... funktionieren tut das schon mit PLCSIM
    der A3.1 wird bei Anlauf gesetzt und lässt sich
    dann jederzeit zurücksetzen.
    Bei mir zeigt PLCSIM komischerweise den gesetzten Merker nicht an, auch wenn ich nur einen Zyklus durchlaufen lasse.
    Im Beobachten-Modus des Baustein-Editors wird der Eins-Zustand dagegen angezeigt. - Seltsam

Ähnliche Themen

  1. Impulsbildung für ein Zyklus
    Von MatzeG im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 13.04.2011, 18:27
  2. Zyklus-Verständnisproblem in SCL
    Von anne im Forum Simatic
    Antworten: 23
    Letzter Beitrag: 02.02.2011, 16:25
  3. Zyklus TP177B
    Von Phase im Forum HMI
    Antworten: 2
    Letzter Beitrag: 25.02.2009, 01:59
  4. Profibus-DP-Zyklus mit OB1-Zyklus synchronisieren?
    Von Supervisor im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 08.06.2006, 13:09
  5. Bit auf 1 im Zyklus?
    Von apachler im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 18.11.2005, 16:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •