Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 21

Thema: Profibus Fehler?

  1. #1
    Registriert seit
    07.11.2009
    Beiträge
    98
    Danke
    67
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe Leute.


    Ich habe eine Anlage die in Automatik sowohl auch in manuellem Betrieb laufen soll. Es gibt dafür 2 SPS'en. Einmal für Automatik und einmal für Handbetrieb.

    Frag mich nicht warum????????????????

    Ich habe 2 SPS'en vom Typ CPU 315 2 DP die über Ethernet CP 342 - 5 mitweinander verbunden sind. Die daten werden über FB 12 BSEND / FC 1 BSEND und FB 13 BRCV / FC2 BRCV mit den DB's DB 10 und DB 11 übertragen.

    Wenn Automatik abgeschaltet wird kann die Anlage auch nicht manuell gefahren werden.

    Dem manuellen Betrieb fehlt wohl irgendwo ein Bit vom anderen SPS.

    Wie müßte ich vorgehen damit ich das fehlende Bit finden kann.

    Aber ich komme damit nicht klar.
    Ich weiß das es schwierig ist eine Ferndiagnose zu machen aber es hat vielleicht einer so viel Erfahrung der mir helfen kann.



    Gruß Hbedir
    Zitieren Zitieren Profibus Fehler?  

  2. #2
    Registriert seit
    15.10.2007
    Ort
    St.Pölten
    Beiträge
    875
    Danke
    98
    Erhielt 200 Danke für 188 Beiträge

    Standard

    schau mal in der sps wo "manuell" ist,welches bit dir fehlt,oder welches bit in einem der beiden DB´s für manuell zuständig ist und ob es auf "1" gesetzt wird wenn du "automatik" ausschaltest.

    PS: Hat der Handbetrieb schon mal funktioniert??
    Beginne jeden Tag mit einem lächeln,es kann dir nämlich während des Tages sehr schnell vergehen.

  3. Folgender Benutzer sagt Danke zu Gerhard K für den nützlichen Beitrag:

    hbedir (04.01.2010)

  4. #3
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Es muss ja ein Bit aus DB10 oder DB11 sein.
    Mal vorrausgesetzt es bestehen keine weiteren Kommunikationswege.
    Haben diese DBs eine Symbolik? Wie werden sie in der "Manual"-SPS weiter
    verarbeitet? Wird der DB dort auf einen Merkerbereich gemappt?
    Beobachte doch mal, welche Bits sich ändern, wenn Automatik ausgeschaltet wird.

  5. Folgender Benutzer sagt Danke zu marlob für den nützlichen Beitrag:

    hbedir (04.01.2010)

  6. #4
    hbedir ist offline Benutzer
    Themenstarter
    Registriert seit
    07.11.2009
    Beiträge
    98
    Danke
    67
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Ich habe leider nur das programm hier und die Anlage ist 600 km weit weg.
    Für manuell Betrieb ist die eine SPS zuständig und für automatik die andere. Ich habe schon inden DB's reingeschaut aber da ist kein Bit für AUTO oder HAND deklariert. Ich müsste normalerweise vor ort die Anlage abschalten und gucken welches Bit für manuellbetrieb fehlt.

    Das wäre meine Idee.

  7. #5
    Registriert seit
    15.10.2007
    Ort
    St.Pölten
    Beiträge
    875
    Danke
    98
    Erhielt 200 Danke für 188 Beiträge

    Standard

    ist niemand vorort mit dem du das machen könntest??
    wenn da eine symbolik vorhanden ist müßtest du ja auch mit dem
    programm alleine schon sehen was in dem Programm in der Handbetrieb SPS notwendig ist um in handbetrieb zu starten.
    Beginne jeden Tag mit einem lächeln,es kann dir nämlich während des Tages sehr schnell vergehen.

  8. #6
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Gucke doch mal in die Symbolik deines Programms. Gibt es dort ein Bit Manual von Automatik SPS oder so ähnlich? Wie werden die Bits aus den DBs weiterverarbeitet?

  9. #7
    Registriert seit
    18.05.2004
    Beiträge
    88
    Danke
    2
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Sorry aber im ersten Moment hört sich das nach einem schlechten Scherz an.

    Ich würde nie auf so eine Idee kommen.

    Wenn ich mehrere CPUs verwende dann Funktionsgruppenbezogen und nicht Betriebsartenbezogen....

    Aber wie gesagt bitte prüfe, ob es sich nicht um einen Scherz handelt...

  10. #8
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Zitat Zitat von Oliver Beitrag anzeigen
    ...

    Aber wie gesagt bitte prüfe, ob es sich nicht um einen Scherz handelt...
    Damit muss man hier im Forum immer rechnen

  11. #9
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    Schon komisch.... auch passt irgendwie die Threadüberschrift nicht....

    Egal... wie auch immer. Irgendwo im Programm muss doch im Handbetrieb ein Ausgang angesteuert werden. Da muss man doch erkennen können welches Bit dafür zuständig ist und dann in der anderen SPS nachschauen wo es herkommt.

    Ich vermute das die Kommunikation zwischen den CPUs nicht fluppt.
    Früher gab es Peitschen .... heute Terminkalender

  12. #10
    Registriert seit
    13.10.2007
    Beiträge
    12.031
    Danke
    2.787
    Erhielt 3.268 Danke für 2.156 Beiträge

    Daumen runter


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Entschuldigung,
    aber wer denkt sich so was aus eine CPU für den Handbetrieb und eine für
    den Automatikbetrieb. Kann man den Projekteur noch ausfindig machen
    und auf den Scheiterhaufen verbrennen, ich fordere eine Art Inquisition für
    solche Projeteure.

    Gruß Großinquisitor
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.
    Zitieren Zitieren wie Krank ist das den?  

Ähnliche Themen

  1. Profibus Fehler
    Von Limette im Forum Feldbusse
    Antworten: 13
    Letzter Beitrag: 27.03.2011, 21:45
  2. Profibus-Fehler
    Von ATRÖ im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 17.02.2009, 07:35
  3. S7-400 Kommunikations-Fehler (Profibus)
    Von ugums im Forum Simatic
    Antworten: 16
    Letzter Beitrag: 21.10.2008, 09:17
  4. Erkennung Profibus Fehler
    Von zwerg77 im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.04.2008, 14:55
  5. Profibus Fehler
    Von Rose im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 03.08.2006, 07:28

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •