Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: S7-1200 HMI Visualisierung

  1. #1
    Registriert seit
    02.02.2010
    Beiträge
    35
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Habe ein kleines Problem mit meiner neuen S7-1200.

    Versuche schon seid längerem ein touchpanal mit der Step 7 Software
    zu visualisieren, doch leider klappt es nicht.

    1. Ist es überhaupt möglich, ein Touchpanel zu visualisieren, damit an der angeschlossenen SPS z.B. ein Ausgang gesetzt wird?

    2. Wenn ja, wie???

    Danke schonmal für die Antworten.....
    Zitieren Zitieren S7-1200 HMI Visualisierung  

  2. #2
    Registriert seit
    14.01.2010
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,
    ich habe seit ein paar Tagen auch ein "Starterpaket" mit einer S7 1212C und einem KTP600 PN Touchpanel.

    Die zugehoerige Software ist die S7 Basic 10.5.
    Diese Software enthaelt WinCC Basic und Step 7 Basic.
    Mit Win CC Basic programmierst du das Touchpanel und mit Step 7 die
    Steuerung.

    Wenn ich mich noch etwas weiter eingearbeitet habe, kann ich dir mehr sagen, da ich jetzt erst mit dieser Software anfange.

    LG Tom
    Wer das hier lesen kann, kann lesen!

  3. #3
    Registriert seit
    14.01.2010
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    So, hab mir das ganze mal angeschaut, ist eigentlich recht einfach.

    Voraussetzung ist eine korrekte Hardwarekonfiguration deines HMI-Panels und deiner Steuerung.

    Beispielsweise kannst du in einem Bild deines Panels eine Schaltflaeche einfuegen, dort kannst du unter >> Eigenschaften > Ereignisse die Funktion
    auswaehlen (Klicken, Druecken, loslassen usw.), dann oeffnet sich rechts eine Spalte in der du eine Funktion hinzufuegen kannst. (ich hab mal "Setze Bit"ausgewaehlt), dann musst du nur noch das Bit aus deinen PLC Variablen raussuchen.


    Da ich meine Hardware noch nicht aufgebaut habe, habe ich ueber >>Online >> Runtime simulieren >> Runtime, ausprobiert, was ich programmiert habe.


    Frueher habe ich Bilder mit Protool programmiert, daher ist WinCC auch neu fuer mich, aber auch nicht so schwer, nur die ganzen Funktionen befinden sich halt woanders.

    LG Tom
    Wer das hier lesen kann, kann lesen!

  4. #4
    Registriert seit
    02.02.2010
    Beiträge
    35
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Damit ich das richtig verstehe:

    Ich habe die SPS mit dem LAN Kabel am Rechner angeschlossen und das HMI Panel Visualisiere ich ausschliesslich über dir RUNTIME.

    Habe das alles schon 100te mal ausprobiert. Auch wie Du es schreibst....
    Mist, dann muß irgendwo noch ein kleiner Fehler sein. Eventuell bei den Variablen.

  5. #5
    Registriert seit
    14.01.2010
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich verstehe dich nicht ganz.

    Was heisst "das HMI Panel visualisiere ich ueber die Runtime"?
    Unter "Runtime" versteht man die ablauffaehige Datei, die auf deinem HMI Panel alles anzeigt und die Funktionen ausfuehrt.

    Diese wird generiert, wenn du das Projekt auf deinen Panel laedst.

    Frage: Hast du eine Online-Verbindung zum HMI Panel und zur Steuerung?

    Beide muessen ueber Netzwerkkabel mit deinem Projektierungsrechner verbunden sein.

    Wie ich das sehe, wird ueber den Button "Laden" in der oberen Reihe dein HMI Panel und deine Steuerung dein Programm eingespielt.

    Check mal bitte als erstes, ob du zu beiden Geraeten eine Online Verbindung aufbauen kannst.

    Uebrigens musst du innerhalb der Projektierung das HMI Panel mit der Steuerung verbinden.
    Schau mal, ob du das hast, ansonsten kann dein Panel nicht auf die Daten der Steuerung zugreifen.
    Wer das hier lesen kann, kann lesen!

  6. #6
    Registriert seit
    02.02.2010
    Beiträge
    35
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo tomtom,

    ich habe noch kein Touchpanel, lediglich die SPS.
    Wollte es erstmal probieren, ob ich damit überhaupt klar komme, bevor ich mir eins kaufe. Sind ja nicht gerade günstig die Teile.

    Also kann ich über die Runtime die SPS nicht direkt ansprechen.

  7. #7
    Registriert seit
    14.01.2010
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Was du in deiner Software aktivieren kannst, ist ein Runtime Simulator.
    Klar, sollten alle Funktionen, die du dort auf dem "virtuellen" Panel aktivierst
    auch richtig ausgefuehrt werden.

    Wenn du darueber eine Variable in der Steuerung ansprichst, sollte diese auch geschrieben/gesetzt werden.

    Vielleicht kannst du dein Problem mal etwas genauer beschreiben, dann kann ich es bei mir mal testen. (zumindest in der Simulation, hab die Hardware noch nicht angeschlossen)
    Wer das hier lesen kann, kann lesen!

  8. #8
    Registriert seit
    02.02.2010
    Beiträge
    35
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also ich möchte im Grunde erstmal über einen Button auf meinem Virtuellen
    Touchpanel einen x-belibigen Ausgang an der SPS ansteuern. Mehr im Grunde nicht. D.h. auf der Runtime Visualisierung.

    Visualisierung --> effektiv angeschlossene SPS

  9. #9
    Registriert seit
    14.01.2010
    Beiträge
    14
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das sollte eigentlich kein Problem sein.

    Check bitte mal noch folgendes:
    -Ist die Hardwarekonfiguration der SPS korrekt?
    -Befindet sich die CPU im Modus "Run"?
    -Laeuft ein Programm auf der SPS?
    -Sind HMI Panel und SPS in der Konfiguration miteinander verbunden?

    Ansonsten noch ein Vorschlag: Schreibe mal nen kleinen FC indem du einen Merker auf den Ausgang schaltest, den du ansteuern moechtest.
    Versuch dann den Merker anstatt des Ausgangs anzusteuern.
    Besser noch ist es, wenn du den Merker als SR Flipflop programmierst, dann bleibt er angesteuert.

    Ich denke, dass der Ausgang nach dem naechsten CPU Zyklus wieder zurueckgesetzt wir, je nach Zykluszeit <30 ms bekommst du gar nicht mit, das er angesteuert war.
    Wer das hier lesen kann, kann lesen!

  10. #10
    Registriert seit
    12.02.2010
    Beiträge
    1
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo SPS-Freunde!

    Bitte nicht zu viel auf Schreibfehler achten! Wie mein Name andeutet, bin ich Ausländer...!

    Ich habe ein ähnliches Problem wie Baschan, und zwar mit folgenden Details:

    * Zwei Stück CPU 1212 C kommunizieren mit einander. Funktioniert.
    * Habe in TIA ein 4 Zoll Panel eingerichtet, KT 400 Mono PN.
    * Das Gerät befindet sich auf dem gleichen Netz wie die andere Teilnehmer.
    * Das Gerät möchte ich softwaremäßig ausprobieren (= Runtime).
    * Verschiedene Bilder habe ich eingerichtet.
    * Auf dem Startbild befinden sich ein Balken und ein Ausgabefeld.
    * In der SPS habe ich ein MW für diesen Zweck eingerichtet, wo manuell geschrieben kann.
    * Es gibt eine Verbindung zwischen dieses MW und dem "Tag" des Balkens im Panel-Bild.
    * Es klappt nicht.
    * In einem Forum habe ich gelesen, dass die PG/PC-Schnittstelle ansprechend eingerichtet werden muss, weil die Simulierung sonst nicht funktionieren wird. Getan! Mehr darüber kan man hier lesen:
    http://support.automation.siemens.com/WW/llisapi.dll?func=cslib.csinfo&lang=en&objid=38717202&caller=view. Die Seite gibt es wahrscheinlich auch in Deutscher Sprache. Die Lösung hat das Problem für jemanden gelöscht, nur nicht für mich.
    * Unter Online \ Runtime simulieren \ Mit Variablen-Simulator lässt sich die ganze Visualisierung ganz gut ausführen. D.h., ich habe also Verbindung über dieser Art von Simulierung, nur nicht über den Runtime.
    * Woran kann es liegen?
    * Hat jemand eine gute Antwort?

    Im Fall ich mich nicht deutlich ausgedrückt habe, dann bitte um mehr Info fragen.

    Ich danke im Voraus für Eure Mühe.

    PS - Zusätzliche Information:

    Drei Ausgänge lassen sich vom Panel hinaus steuern.
    Eine "Lampe" auf dem Panel, die mit einem Merker von der SPS angezeigt werden sollte, zeigt nichts.
    Der Balken zeigt noch nichts. Bei der Übersetzung wird gemeldet: Tag ABC55: PLC address error.
    Am Schreiben in einem Eingabefeld meldet das Software-Display: Tag XYZ: Value could not be written to the PLC.
    Alle Verbindungen zwischen Variablen in der SPS under in der HMI sind mehrmals kontrolliert worden. Keine Fehler gefundern.

    Meine Version ist 10.5, mit SP2. Kann es sein, dass irgendwelche der Funktionen im Panel mit dieser Version nicht möglich sind? Also, das man in späteren Ausgaben eine Berichtigung durchgeführt hat?

    INFORMATION: DAS PROBLEM HAT SICH GELÖSCHT!

    Meine Internetverbindung zur Umwelt habe ich zuerst entfernt, damit die Subnetzmaske für alle Teilnehmer auf jeden beliebigen Wert eingestellt werden könnte (= 255.255.255.0). Das waren die einzige Änderungen, die ausgeführt wurden. Danach hat alles geklappt!

    Als zweiter Schritt habe ich die Subnetzmaske für alle Teilnehmer auf die ursprünglichen Werte zurückgestellt (= 255.255.248.0). Das waren die einzige Änderungen, die ausgeführt wurden. Danach hat es noch funktioniert! Alle Werte könnten ausgetauscht werden!

    Die genaue Ursache kenne ich leider nicht, und habe auch keine Ideen warum.


    Die Adressierungsform, „Classless Interdomain Routing“ wird bei Siemens TIA-Portal nicht akzeptiert, und deswegen wurden die obigen Änderungen temporär durchgeführt. Außer Warnungen darüber wird der Benutzer zusätzlich gewahrt, weil der Balken der IP-Adresse gelb wird. Mit einer Subnetzmaske von 255.255.255.0 wird der Balken wieder weiß. Trotzdem funktioniert es ganz gut, wie oben erklärt.
    Geändert von Der Däne (23.02.2010 um 13:31 Uhr)
    Zitieren Zitieren S7-1200 HMI Visualisierung (Simulierung)  

Ähnliche Themen

  1. S7-1200 Web Visualisierung
    Von rwinnen im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 16.04.2013, 14:39
  2. Datenaustausch zwischen S7-1200 und S7-1200
    Von baschan im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 09.12.2011, 00:27
  3. WEB Visualisierung S7 1200
    Von ziede im Forum HMI
    Antworten: 0
    Letzter Beitrag: 09.07.2010, 18:57
  4. Visualisierung
    Von Waldi_März im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 30.10.2008, 14:20
  5. Web-Visualisierung
    Von winniepuh im Forum HMI
    Antworten: 1
    Letzter Beitrag: 22.02.2006, 16:13

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •