Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 24

Thema: Signal verstärken 5V --> 24V

  1. #11
    Registriert seit
    13.04.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen.
    Ich habe das gleiche Problem wie Squooshie. Daher wollte ich mal Fragen ob das mit dem 5V Relais was oben angegeben ist geklappt hat. Laut Datenblatt kann die Karte eigentlich nur einen Strom von 8,5mA ausgeben was nicht reichen würde um das Relais zu schalten.

    Gruß TicTac

  2. #12
    Registriert seit
    25.11.2008
    Beiträge
    99
    Danke
    0
    Erhielt 8 Danke für 8 Beiträge

    Standard

    Was sprich dagegen das Relais mit einen Transistor anzusteuern?

  3. #13
    Registriert seit
    13.04.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich bin relativ neu in dem Gebiet und versuche mich gerade ein wenig da einzuarbeiten. Von daher wäre ein einfaches dazwischenschalten durch ein Relais für mich am einfachsten und meine erste Idee.
    Bin aber gerne bereit für andere Ideen. Wie würde eine solche Transistorschaltung aussehen? Mein Ziel ist es mit Hilfe der Karte fünf 5/3 Wegeventile anzusteuern. Dazu benötige ich auch die 24V. Wäre super wenn du mir helfen könntest. .

  4. #14
    Registriert seit
    03.04.2008
    Beiträge
    6.200
    Danke
    237
    Erhielt 815 Danke für 689 Beiträge

    Standard

    Also eine Schaltung selber bauen würde ich nicht.
    Wenn der Ausgangsstrom reicht würde ich Optokoppler nehmen.
    Dann hast du auch eine galvanische Trennung zwischen Ausgang und Aktor


    bike

  5. #15
    Registriert seit
    13.04.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das heißt in der Praxis ich müste nur den richtigen Optokopler zwischen die beiden Quellen setzen und mit dem Ventil verbinden.
    Wie bekomme ich den raus welchen Schaltstrom der Optokopler braucht? Gibt es da eine Formel??

  6. #16
    Registriert seit
    25.11.2008
    Beiträge
    99
    Danke
    0
    Erhielt 8 Danke für 8 Beiträge

    Standard

    Bei den zweiten Beitrag, der von diabolo, ist ein Link dabei. das ist ein Optokopler der ohne Leiterkartenbastellei in einen Schaltschrank eingegebaut werden kann. Da stehrt was von 7 bis 10mA eingangsstrom bei 5V. Musste eigentlich reichen mit deinen 8,5mA.
    Oder ist selber Bauen bei dir eine Alternative?

  7. #17
    Registriert seit
    13.04.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Oh das habe ich übersehen. Dann müsste das ja eigentlich reichen. und ist die schnellste alternative. Selber bauen wäre vom Lerneffekt mit Sicherheit besser allerdings wahsscheinlich auch sehr zeitaufwendig und somit momentan ungünstig. Vielen Dank schonmal für eure Hilfe.

  8. #18
    Registriert seit
    13.04.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo zusammen...
    Das ist ja alles schön und gut mit dem oben genannten Optokoppler der Firma Wago, aber funktioniert leider nicht. Der Optokoppler benötigt zum schalten der LED eine Strom, von 9,7mA. Nur leider gibt die Box nur 8,5mA her.
    Daher an dieser Stelle nochmal die Frage nach eine Schaltung zum selber bauen. Jemand eine Idee?

    Gruß TicTac

  9. #19
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.181
    Danke
    923
    Erhielt 3.289 Danke für 2.658 Beiträge

    Standard

    Zitat Zitat von TicTac Beitrag anzeigen
    Das ist ja alles schön und gut mit dem oben genannten Optokoppler der Firma Wago, aber funktioniert leider nicht. Der Optokoppler benötigt zum schalten der LED eine Strom, von 9,7mA. Nur leider gibt die Box nur 8,5mA her.
    Dann schalte doch einfach einen Widerstand 120 Ohm (1/8W reicht) als Vorwiderstand zwischen Deine Box
    und den Optokoppler. Damit bringst Du den Strom auf knapp unter 8,0mA.
    Ich denke mal, daß der Optokoppler auch noch mit 8,0mA bei 4,0V funktioniert.
    Am besten mal in einer Testschaltung ausprobieren und ggf. den Widerstand etwas variieren.

    Ideal wäre es, wenn Du die Schaltspannung der Box-Ausgänge getrennt anschließen könntest.
    Oder sind das OpenCollector-Ausgänge?
    Dann bräuchtest Du nur ein Netzteil mit 4VDC für die Schaltspannung Box-zu-Optokoppler.

    Gruß
    Harald
    Zitieren Zitieren Vorwiderstand und Optokoppler  

  10. #20
    Registriert seit
    13.04.2010
    Beiträge
    6
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hey...
    Habe es mit den Widerständen probiert und es klappt leider immer noch nicht. Habe 100 / 120 / 150 Ohm Widerstände verwendet und kein bei keinem hat der Optokoppler irgendwelche anstalten gemacht um durch zu schalten. Die Spannung ist immer wieder beim versuch des schaltens abgefallen.

Ähnliche Themen

  1. Frequenzumrichter & 0-10V Signal
    Von Stanzman im Forum Antriebstechnik
    Antworten: 6
    Letzter Beitrag: 25.05.2011, 11:00
  2. PT 100 Signal abgreifen
    Von L.T. im Forum Elektronik
    Antworten: 10
    Letzter Beitrag: 06.11.2009, 09:21
  3. Signal vom PC an SPS senden
    Von Growe im Forum PC- und Netzwerktechnik
    Antworten: 1
    Letzter Beitrag: 04.12.2008, 15:26
  4. 0-10V Signal zu ungenau
    Von TimoK im Forum Elektronik
    Antworten: 10
    Letzter Beitrag: 08.04.2008, 16:55
  5. HTL Signal?
    Von Markus_Sch im Forum Elektronik
    Antworten: 0
    Letzter Beitrag: 27.01.2006, 11:43

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •