Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 5 von 8 ErsteErste ... 34567 ... LetzteLetzte
Ergebnis 41 bis 50 von 72

Thema: Probleme mit SFC 14 / SFC 15 in FB

  1. #41
    smartie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.07.2005
    Beiträge
    298
    Danke
    27
    Erhielt 18 Danke für 15 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja genau,

    die ersten beiden Steckplätze müssen frei bleiben.

    Der dritte Steckplatz ist für die Steuerung der Applikation in der MOVI PLC
    gedacht, die folgenden Steckplätze sind für jeweils eine Achse.

  2. #42
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Also auf S7 seite kann ich jetzt nichts erkennen du hast ja wirklich
    fast alles getrennt angelegt. Schon komisch.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  3. #43
    smartie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.07.2005
    Beiträge
    298
    Danke
    27
    Erhielt 18 Danke für 15 Beiträge

    Standard

    Das Programm im MoviAxis ist von SEW und wir haben da am Freitag schon ziemlich lange über Fernwartung in der Steuerung gesucht,
    sind aber letztlich zum Entschluss gekommen das es aus der S7 kommen muss.

    Hast du dir auch nochmal das SPS-Programm angeschaut?

    Ich werd jetzt auf jeden Fall noch mal bei SEW anrufen.

    Das ich die SFC14 / SFC15 mehrmals für den gleichen Teilnehmer aufgerufen habe und das das falsch war ist ja ganz logisch (so im Nachhinein betrachtet).

    Aber wo der Fehler jetzt liegt ??? - Keine Ahnung.

  4. #44
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    aber was mir aufgefallen ist, der FC1 und FC2 sind doch gleich?
    Dann kannst du die doch auch den gleichen Baustein mehrmals
    aufrufen, nur mit unterschiedlicher beschaltung von ausssen.

    Dann hast du doch schon deine Daten für die Achsen mit den
    FB1 Instanz DB erzeugt, das sollte doch reichen, auf diese
    Daten kannst du doch zurückgreifen.

    Es wirkt für mich jetzt ersteinmal ziemlich unübersichtlich.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  5. #45
    smartie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.07.2005
    Beiträge
    298
    Danke
    27
    Erhielt 18 Danke für 15 Beiträge

    Standard

    Ja das mit FC1 und FC2 ist schon klar, aber eigentlich sollte das so doch auch funktionieren.

    Das es etwas unübersichtlich ist liegt natürlich daran das das jetzt das Testprogramm in dem ich schon zig Änderungen durchgeführt habe.

    Im Anhang lade ich mal die Variablentabelle ONLINE hoch:
    Angehängte Grafiken Angehängte Grafiken
    Geändert von smartie (15.02.2010 um 11:27 Uhr)

  6. #46
    Registriert seit
    13.10.2007
    Beiträge
    12.033
    Danke
    2.788
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Eigentlich kann da nichts falsch sein wenn du den SFC 14/15 für
    den gleichen Teilnehmer mehrmal aufrufst, das funktioniert auch
    bei SEW mach ich das mit den Standard Gatway doch auch und
    es hängen mehrere Umrichter an diesen Gateway.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  7. #47
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.718
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard

    Zitat Zitat von smartie Beitrag anzeigen
    Die Adressierung müsste meine Meinung nach passen:

    Wenn ich nur die Kommunikation mit Achse 1 aufrufe kommen alle Signale korrekt an.

    Wenn ich nur die Kommunikation mit Achse 2 aufrufe kommen alle Signale korrekt an.

    Wenn ich aber beide gleichzeitig aufrufe dann gibts Probleme.
    Ich hänge mich mal an diesen Beitrag ...
    Hast du dir mal angesehen, wohin deine Pointer in Wirklichkeit adressieren ?
    Kann es sein, dass es beim 2. Aufruf einen Unterschied zu dem Wunschziel gibt ?

    Gruß
    LL

  8. #48
    smartie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.07.2005
    Beiträge
    298
    Danke
    27
    Erhielt 18 Danke für 15 Beiträge

    Standard

    Hallo Larry,

    Hast du dir mal angesehen, wohin deine Pointer in Wirklichkeit adressieren ?
    Status beobachten in AWL ist für mich wie Böhmische Dörfer. Wie kann ich mir das ansehen?

  9. #49
    Registriert seit
    22.03.2007
    Ort
    Detmold (im Lipperland)
    Beiträge
    11.718
    Danke
    398
    Erhielt 2.399 Danke für 1.999 Beiträge

    Standard

    ... der Pointer (also das, was du ins AR1 lädst) ist der Bitwert deiner Ziel-Adresse (also Adresse * 8 ) wenn du das höchstwertigste Byte des DWORD mal außen vor läßt ...
    Du weißt doch wohin du jeweils willst. Nun mußt du "nur" nachsehen, ob diese Position auch wirklich adressiert wird ...

  10. #50
    smartie ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    14.07.2005
    Beiträge
    298
    Danke
    27
    Erhielt 18 Danke für 15 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Muss ganz ehrlich sagen das ich nicht ganz verstehe was du mir sagen willst.

Ähnliche Themen

  1. Bus Probleme
    Von KR-TKD im Forum Feldbusse
    Antworten: 7
    Letzter Beitrag: 15.06.2011, 16:37
  2. CPU 315 F 2PN/DP DI Probleme
    Von Joke im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 12.05.2009, 21:10
  3. Probleme über Probleme!
    Von tom_2802 im Forum Simatic
    Antworten: 25
    Letzter Beitrag: 12.06.2008, 22:19
  4. Probleme mit ALM
    Von Larry Laffer im Forum PC- und Netzwerktechnik
    Antworten: 4
    Letzter Beitrag: 08.03.2008, 18:13
  5. Probleme mit OPC
    Von ILW im Forum Hochsprachen - OPC
    Antworten: 1
    Letzter Beitrag: 01.11.2007, 12:37

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •