Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 12

Thema: Einbindungh Leuze Scanner

  1. #1
    Registriert seit
    29.08.2009
    Beiträge
    776
    Danke
    25
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute ich möchte gerne einen Leuze 3800g Handscanner an einem M41 DP-K Profibuskopper in mein Step 7 Projekt aufnehmen. Leider empfange ich von den EIngangsdaten nur 0en. Ich habe schon mit Leuze telefoniert, jedoch meinten die nur, dass ich wenn ich das Ausgangsbit 0.7 (Bei mir Adresse 256.7 ) setze, s´dann sollte der Scanner auch statusbits zurückliefern.

    Hat da jemand Erfahungen mit?
    Zitieren Zitieren Einbindungh Leuze Scanner  

  2. #2
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von Bensen83 Beitrag anzeigen
    Leider empfange ich von den EIngangsdaten nur 0en. Ich habe schon mit Leuze telefoniert, jedoch meinten die nur, dass ich wenn ich das Ausgangsbit 0.7 (Bei mir Adresse 256.7 ) setze, s´dann sollte der Scanner auch statusbits zurückliefern.
    Hast Du das Steuerwort denn in deiner Hardware angelegt?
    Aber das wird dich ja hoffentlich die Firma Leuze schon gefragt haben.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  3. #3
    Bensen83 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.08.2009
    Beiträge
    776
    Danke
    25
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Ich habe in meiner Hardwareconfig 10 Worte eingang und 4 worte ausgang. die erste ausgangsadresse ist 256.

    Ich abe jetzt einfach in der Variablenliste E256.7 auf TRUE gesetzt.

    Müsste doch gehen, oder?
    Zitieren Zitieren Steuerwort  

  4. #4
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von Bensen83 Beitrag anzeigen
    Ich habe in meiner Hardwareconfig 10 Worte eingang und 4 worte ausgang. die erste ausgangsadresse ist 256.

    Ich abe jetzt einfach in der Variablenliste E256.7 auf TRUE gesetzt.

    Müsste doch gehen, oder?
    Eigentlich schon, wenn Du nicht den Eingang sondern den Ausgang setzt.
    Ist aber wahrscheinlich ein Tippfehler.
    Hast Du schon mal das Bit A257.7 probiert > zwecks Bytedreher?
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  5. #5
    Bensen83 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.08.2009
    Beiträge
    776
    Danke
    25
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Ja meinte auch den Ausgang.

    Nein das mit dem Bytedreher habe ich noch nicht versucht. muss ich morgen mal versuchen. wollte morgen mal die zwei steuerworte auf Hex FFFF setzen. dann müsste ja in dem Bit auf jeden Fall ne 1 stehen.
    Zitieren Zitieren Ok  

  6. #6
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von Bensen83 Beitrag anzeigen
    wollte morgen mal die zwei steuerworte auf Hex FFFF setzen. dann müsste ja in dem Bit auf jeden Fall ne 1 stehen.
    Nicht sicher, ich glaube ein Steuerbit bewirkt den Leseabbruch!
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  7. #7
    Bensen83 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.08.2009
    Beiträge
    776
    Danke
    25
    Erhielt 3 Danke für 3 Beiträge

    Standard

    OK danke. dann werd ich erst mal das mit dem Dreher von Low und Highbyte versuchen. Bis dann
    Zitieren Zitieren Danke  

  8. #8
    Bensen83 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.08.2009
    Beiträge
    776
    Danke
    25
    Erhielt 3 Danke für 3 Beiträge

    Standard

    das funktioniert leider auch nicht. keine Kommunikation
    Zitieren Zitieren Funktioniert nicht  

  9. #9
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Zitat Zitat von Bensen83 Beitrag anzeigen
    das funktioniert leider auch nicht. keine Kommunikation
    Habe gerade bei mir geschaut.
    Ich habe zwar einen anderen Scanner, aber ich nehme immer das Aktivierungsmodul (M10) in die Hardware.
    Das ist ein Byte groß und für den Lesevorgang aktiviere ich das Bit 0.
    Die Daten kommen dann im Modul (M24) Decodierergebnis an.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  10. #10
    Bensen83 ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    29.08.2009
    Beiträge
    776
    Danke
    25
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jetzt funktioniert es bei mir, wenn ich mit dem sfc14 und sfc15 gearbeitet habe, kam en keine daten an, habe jetzt einfach Lade und transferiere in das jeweilige PAB gemacht. und so gehts.
    Zitieren Zitieren Geht  

Ähnliche Themen

  1. Barcodescanner mit Leuze electronic
    Von voggia im Forum Programmierstrategien
    Antworten: 5
    Letzter Beitrag: 13.09.2011, 14:35
  2. [B]Leuze RK85/4-800 usw
    Von Lars123 im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 11.09.2011, 12:26
  3. Suche Leuze AMS
    Von neuling12 im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 30.09.2010, 21:06
  4. Suche Leuze MA 42 DP-k
    Von anfield24 im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 01.08.2010, 13:39
  5. BCL34 von Leuze im Nassbereich
    Von Morpheus_2007 im Forum Elektronik
    Antworten: 3
    Letzter Beitrag: 20.02.2009, 11:53

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •