Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Steuerung Magnetventil (5/2 Wege)

  1. #1
    Registriert seit
    01.12.2009
    Beiträge
    43
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Leute,

    komm mit meinem Anfängerwissen bei folgender problematik einfach nicht weiter. Also ich habe ein 5/2-Wege Magnetventil an einSM323 DI16/DO16 x24 V/90,5 a wie folgt angeschlossen.

    Eun Kabel an die Spannungsversorgung und das andere auf den Ausgang 21.0. Wenn ich die SPS einschalte leuchtet auch die grüne Lampe auf. Müsste doch heißen korrekt angeschlossen oder?

    Jetzt wollte ich das ganze natürlich auch schalten aber habe keinen Plan wie das ganze funktionieren soll. Mein Ziel ist es einen Schieber zu öffnen und dann wieder zu schließen. Steuern wollte ich das ganze aus WIN CC über zwei Button der eiune für "auf" und der andere für "zu".

    Eigentlich müssste dass doch funktionieren in dem ich den Ausgang entweder "high" oder "Low" setze oder.

    Bin für jeden Tip sehr dankbar

    MfG outbreak
    Zitieren Zitieren Steuerung Magnetventil (5/2 Wege)  

  2. #2
    Registriert seit
    17.01.2010
    Beiträge
    197
    Danke
    81
    Erhielt 21 Danke für 20 Beiträge

    Standard

    Ja!



    .

  3. #3
    Registriert seit
    05.09.2007
    Ort
    Bielefeld NRW
    Beiträge
    46
    Danke
    0
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Hallo,

    Hat die E/A Baugruppe SM323 denn Spannung. Das Ventil muss dann
    an "Minus" und den Ausgang.
    Die SM323 hat 3x +24V, und 3x "Masse".

    Gruß
    Andreas
    Gruß
    Andreas

    ------------------------------------------------

    Was sind die letzten Worte eines Elektrikers : Was´n das für´n Kabel........

  4. #4
    Registriert seit
    01.12.2009
    Beiträge
    43
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Danke schon mal.

    Wenn der Ausgang low ist leuchtet dann die Lampe immer noch oder sollte Sie erlöschen?

    Wenn ich folgendes programmiere

    U DB2.DBX0.0
    = A21.0

    und in WIN CC eine neue Variable anlege welche die Adresse DB2.DBX0.0 trägt kann ich dann den Ausgang steuern (high, low) und wenn ja wie kann ich dem Button so eine entsprechende Funktion zuweisen?

  5. #5
    Registriert seit
    01.12.2009
    Beiträge
    43
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Alo ich habe es lt. Prinipschaltbild auf der 31 und der 32 angeschlossen. Wobei 31 das Minus für die letzten 8 Ausgänge sein solllte und 32 der eigentliche Ausgang.

  6. #6
    Registriert seit
    05.09.2007
    Ort
    Bielefeld NRW
    Beiträge
    46
    Danke
    0
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Hallo outbreak7,

    Wenn der Ausgang low ist, sollte die LED nicht leuchten.
    Bei WinnCC musst du eine Schaltfäche nehmen, und dann beim
    Drücken das Bit setzen, und beim Loslassen rücksetzen.
    Was genau für eine Baugruppe "6ES7..." hast du denn?

    Gruß
    Andreas
    Gruß
    Andreas

    ------------------------------------------------

    Was sind die letzten Worte eines Elektrikers : Was´n das für´n Kabel........

  7. #7
    Registriert seit
    01.12.2009
    Beiträge
    43
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hmmm das is komisch. Ich habe mal den Aktualwert des Ausgangs von False auf True geändert und die Lampe leuchtet immer grün.
    Es handelt sich umeine &ES7323-1BL00-0AA0

  8. #8
    Registriert seit
    17.07.2009
    Ort
    Am Rande der Ostalb
    Beiträge
    5.534
    Danke
    1.152
    Erhielt 1.253 Danke für 982 Beiträge

    Standard

    Zitat Zitat von outbreak7 Beitrag anzeigen
    Alo ich habe es lt. Prinipschaltbild auf der 31 und der 32 angeschlossen. Wobei 31 das Minus für die letzten 8 Ausgänge sein solllte und 32 der eigentliche Ausgang.
    Hast du deine Karte überhaupt mit Plus und Minus versorgt?

  9. #9
    Registriert seit
    05.09.2007
    Ort
    Bielefeld NRW
    Beiträge
    46
    Danke
    0
    Erhielt 6 Danke für 6 Beiträge

    Standard

    Hallo outbreak7,

    Also auf 1, 21 und 31 L+ 24V, und auf 20, 30 und 40 "Masse.
    Hast Du das so.

    Gruß
    Andreas
    Gruß
    Andreas

    ------------------------------------------------

    Was sind die letzten Worte eines Elektrikers : Was´n das für´n Kabel........

  10. #10
    Registriert seit
    01.12.2009
    Beiträge
    43
    Danke
    7
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hatte nen fehler im anschluss. jetzt klappts erstmal mit der eklektrik. jetzt hab ich nur noch folgendes Problem. Wenn ich meine SPS in den Run Schalte fährt mein Schieber auf da ich den Startwert für das Bit 0.0 im DB2 auf "TRUE" gestzt habe. Die Programmierung im FC ist dann folgende:
    U DB2.DBX0.0
    = A21.0

    Jetzt habe ich mir im WINCC eine Variable vom Typ "Binär" angelegt welcher ich die Adressierung DB2 Bit 0gegeben habe. Wenn ich jetzt im WINCC über den Dynamik Wizzard versuche die Option Bit setzten auf den Button zu legen kann ich mir bei der Auswahl der Variablen keine Binäre nehmen. Die wird gar nicht angezeigt. Ich habe mal noch zum probieren eine andere vom Typ "vorzeichenlose Gleitpunktzahl 16 BIT(oder so ähnlich) " angelegt und die kann ich dann ohne Probleme anwählen. Wie kann ich denn mein einzelnes BIT nun steuern so dass ich mittels WINCC das Bit setze und rücksetze und sich somit der Wert im DB2 zw. "True" und "False" ändert?

    Vielen dank jetzt schon für die Rettung vorm Verzweifeln!

Ähnliche Themen

  1. Magnetventil Ansteuerung SPS
    Von micha89 im Forum Elektronik
    Antworten: 8
    Letzter Beitrag: 15.05.2010, 15:55
  2. 4 Wege Magnatventil
    Von Tiger30 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 20.04.2010, 15:00
  3. SPS Steuerung analog ? (Terrarium Steuerung)
    Von KlauZ im Forum Schaltschrankbau
    Antworten: 19
    Letzter Beitrag: 25.03.2009, 23:21
  4. Magnetventil und Zeitsteuerung
    Von christian_p im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 26.11.2008, 14:35
  5. Antworten: 3
    Letzter Beitrag: 16.09.2007, 09:00

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •