Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 19 von 19

Thema: S7-300 CPU 315 Analog-Ausgabe mit SM332

  1. #11
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.261
    Danke
    537
    Erhielt 2.707 Danke für 1.956 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Was steht in RET_Val?
    Welche CPU verwendest du?
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  2. #12
    Registriert seit
    14.01.2004
    Ort
    Hattorf
    Beiträge
    3.201
    Danke
    297
    Erhielt 311 Danke für 266 Beiträge

    Standard

    Hallo,
    oben in deiner AUFGABENSTELLUNG hieß es +/- 10V und nicht 0-10V Ausgang, da liegt der Hase begraben, denn dann heißt meine Lösung so:

    L MW 0 //dein Eingangswort vom OP
    ITD // integer in doppelt integer
    DTR //doppelt integer in real
    L 2.000000e+003 //die Obergrenze laden
    /R
    L 2.764800e+004
    *R
    RND
    T PAW 256 //Dein Ausgangswort

    Mit falscher Aufgabenstellung rennen die Leute natürlich in die Irre
    Und hier nochmal gesagt für diese Lösung brauchst du kein FC.


    mfg

    dietmar

  3. Folgender Benutzer sagt Danke zu lorenz2512 für den nützlichen Beitrag:


  4. #13
    Anonymous Gast

    Standard

    Hallo Ralle + Lorenz,

    danke für eure schnellen Geistesblitze.

    Ralle: Im Ret_Val MW200 steht der Wert 0

    Lorenz: Klar meine erste Frage war Eingabewert +-10V, hat sich auf
    Kundenwunsch geändert auf 0-10 Volt, daher im Hardwarekonf.
    auf 0-10 V geändert und im FC106 auf Bipolar:FALSE O.K.
    Bekomme leider am Ausgang PAW 256 noch keine Spannung.
    Werde heute eure Vorschläge noch testen. Danke.

    Wozu wird der FC 108 benutzt heisst auch ANALOG Ausgabe????

    Bis dann

    Martin L.
    Zitieren Zitieren Analog Ausgabe SM 332  

  5. #14
    Registriert seit
    14.01.2004
    Ort
    Hattorf
    Beiträge
    3.201
    Danke
    297
    Erhielt 311 Danke für 266 Beiträge

    Standard

    Hallo,
    warum meine Lösung fehlgeschlagen ist kann sich jeder ausrechnen.
    Bei Ralles Lösung schwant mir ein schrecklicher Verdacht: Du hast dir den FC 106 doch wohl nicht aus den S5-S7 Converting Blocks geholt??, weil Du schreibst was von FC 108, und den gibt es nicht im TI-S7 Converting Blocks, da ist bei FC 106 Schluß.

    mfg

    dietmar

  6. #15
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 24 Danke für 21 Beiträge

    Standard

    Ich vermute Martin meint der FC108 im Verzeichnis S5-S7 Converting Blocks, was, wie der Name sagt, hier nichts zu suchen hat.

    Was das eigentliche Problem angeht, wenn man alles mögliche probiert hat dann muss man bei den unmöglichen Sachen suchen.

    Bist Du ganz sicher, dass in den Eigenshaften - Ausgänge die Ausgabenart nicht irgendwie auf "deaktiviert" statt "U" gekommen ist?

    Ansonsten kann ich nur denken, dass am Ausgang ein Kurzschluss irgendwie daran ist, denn unter normalen Umständen müsste das oben geschriebene funktionieren!

  7. #16
    Anonymous Gast

    Standard

    Nochmal die Frage nach der CPU, die alte 315 und die 316 unterliegt Einschränkungen in den PAW. Nimm doch zum Testen mal PAW unter 255 also welche, die im normalen EA-Bereich liegen. Ich weiß nicht mehr, ob eine Fehlermeldung kommt, wenn die PAW außerhalb des erlaubten Bereiches liegen.

  8. #17
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.261
    Danke
    537
    Erhielt 2.707 Danke für 1.956 Beiträge

    Standard

    Ich liebe das AUTOLOGOUT
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  9. #18
    Anonymous Gast

    Standard

    Hallo RMA + Lorenz,

    so habe den FC 108 nicht benutzt, fand ihn bei anderen Projekten
    lässt sich auch aufrufen und man kann Ihn parametrieren!!
    CPU ist eine 315 er (ohne 2DP) im Hardwarekonfigurator ist
    auch U für Spannung 0-10V eingetragen und nicht deaktiviert, habe
    dann auch die neue Konfiguration zur CPU übertragen. An den Klemmen
    habe ich noch keine Leitung aufgelegt, kann also nicht defekt oder Kurz-
    schluß haben. Kommt aber immer noch keine Analoge-Spannung
    heraus. Werde jetzt mal den FC106 nicht mehr nutzen und mal zu
    Testzwecken den PAW256 direkt beschreiben.
    Meld mich dann. Danke nochmals.
    Bis dann

    Martin L.
    Zitieren Zitieren Analog Ausgabe SM 332  

  10. #19
    Registriert seit
    16.12.2004
    Ort
    Schleswig-Holstein
    Beiträge
    400
    Danke
    21
    Erhielt 24 Danke für 21 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guck mal im Diagnostik Puffer ob da ein I/O Fehler auftaucht wenn Du den AO ansprichst. Wenn die Adresse nicht stimmt, dann musste es eine Fehlermeldung da geben.

    Bist Du auch sicher, dass Du in der richtige Stelle misst? Die Spannung musstest Du finden zwischen Kontakte 4 & 5 oder 8 & 9, nicht 2 & 3 oder 4 & 5 wie beim 331 AIN.

Ähnliche Themen

  1. [v] S7 SM332 AO
    Von wirehead im Forum Suche - Biete
    Antworten: 0
    Letzter Beitrag: 21.09.2011, 21:54
  2. Analog Eingang / Analog Ausgang - Twin CAT System
    Von tech007 im Forum CODESYS und IEC61131
    Antworten: 0
    Letzter Beitrag: 23.05.2011, 18:22
  3. Analog Ausgabe
    Von Lex_78 im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 26.11.2008, 22:42
  4. Analogbaugruppe SM332
    Von votto im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 15.05.2006, 14:36
  5. Analog Ausgabe normiert
    Von raifisch im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 11.07.2005, 08:27

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •