Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Ethernet Verbindung PC zu OP

  1. #1
    Registriert seit
    14.03.2010
    Beiträge
    88
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    also ich hoffe, dass ich das jetzt richtig erklären kann:
    wir haben in der firma eine anlage, bei der die daten (zeiten, temperaturen,usw.)- via ethernet - auf einen pc übertragen werden und in diesem als excel dateien angelegt werden.

    OP= MP377

    folgendes problem haben wir :
    es wird keine fehlermeldung ausgegeben, wenn die verbindung unterbrochen wird, bzw. wenn keine daten übertragen werden. beim hochfahren des OP´s kommt eine meldung : verbindung besteht.
    wie kann ich eine fehlermeldung einrichten, bzw. eine systemmeldung anlegen " Verbindung getrennt" oder " Verbindung besteht", während dem laufenden betrieb(anlage läuft,pc an, OP an). das problem ist, dass wir immer mal wieder keine daten haben, völlig unwillkürlich...kein kabel gezogen, anlage ist auch nicht aus.....

    ich hoffe ihr könnt mir helfen...

    danke im vorraus

    gruß
    sps-q
    Zitieren Zitieren Ethernet Verbindung PC zu OP  

  2. #2
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.628
    Danke
    377
    Erhielt 801 Danke für 642 Beiträge

    Standard

    Bist Du sicher das es keine Systemmeldung kommt ?
    Ist eine Meldefenster für Systemmeldungen konfiguriert ? Wenn nicht verschwindet die Systemmeldungen nach eine kurze Zeit und man weiss nicht danach was passiert ist.

    Wenn es ein Systemmeldung kommt, kannst Du mittels den Ereignissnummer eine Aktion konfigurieren. Z.B. ein Tag wird im PLC geschrieben was dann eine Hupe auslöst.

    edit: Wenn das Problem ist den Verbindung zwisschen MP377 und SPS, dann gibt es die Ereignisse 140000 und 140001 (wenn ich das korrekt errinnere).
    Ich bin sicher das diese Meldungen kommt nicht nur beim ersten Verbindungsaufbau, aber auch bei eine spätere abbau bzw. aufbau.
    Wenn eine schreiben zu ein Netzerk Server fehlschlägt muss auch irgendeine Systemmeldung kommen.
    Geändert von JesperMP (23.04.2010 um 19:06 Uhr)
    Jesper M. Pedersen

  3. #3
    Registriert seit
    14.03.2010
    Beiträge
    88
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Wenn eine schreiben zu ein Netzerk Server fehlschlägt muss auch irgendeine Systemmeldung kommen
    in der theorie schon, aber in real leider nicht. wir wissen nicht woran es liegt, vielleicht weiss jemand ja, wie man eine solche betriebsmeldung einrichtet...?!?
    gruß
    sQ

  4. #4
    Registriert seit
    01.04.2010
    Beiträge
    306
    Danke
    18
    Erhielt 38 Danke für 37 Beiträge

    Standard

    Kurze Frage was für eine Runtime läuft auf dem OP!
    Die Frage ist eigentlich mehr was für den HMI Teil des Forums!

    In der Runtime müssen die Systemmeldungen freigegeben sein, ein Meldefenster für die Systemmeldungen muß Projektiert werden und zu guter letzt muß ein Meldarchiv (Archiv Datei) eingerichtet werden weil sonst nur temporär gespeichert wird und sich das Archiv nach einem neustart löscht!

    Gruß
    SKg

  5. #5
    Registriert seit
    14.03.2010
    Beiträge
    88
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Standard

    was für eine Runtime läuft auf dem OP
    verdammt gute frage...muss ich leider passen, kann es damit zusammenhängen????

  6. #6
    Registriert seit
    01.04.2010
    Beiträge
    306
    Danke
    18
    Erhielt 38 Danke für 37 Beiträge

    Standard

    Ich rede von dem Visualisierungsprogramm!
    Wie WinCC oder Protool

    Wenn ich das wüste könnte ich meine Antworten genauer ausführen

    Gruß
    SKg

  7. #7
    Registriert seit
    14.03.2010
    Beiträge
    88
    Danke
    13
    Erhielt 1 Danke für 1 Beitrag

    Cool

    achso, wincc....

  8. #8
    Registriert seit
    01.04.2010
    Beiträge
    306
    Danke
    18
    Erhielt 38 Danke für 37 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Im bereich Archive/Meldearchive Ein Meldearchiv anlegen (im Modus Daten).
    Dann unter Meldungen/Einstellungen/Meldeeinstellungen die Verbindung einfügen und drauf achten das ein Häkchen in HMI-Systemmeldungen steht, eventuell die Anzeigedauer erhöhen!
    Dann unter Meldungen/Einstellungen/Meldeklassen allen Meldeklassen ein Archiv zuweisen!
    Dann im Gewünschten Meldefenster den Punkt in Meldeereignisse setzen und bei Meldeklassen alle Häkchen reinsetzen!

    Wenn das Archiv angezeigt werden soll ist ein Weiteres Meldefenster von nöten wo dann der Punkt auf Meldearchiv gesetzt ist und das entsprechende Meldearchiv auswählen!
    Und zu guter letzt muß noch in dem Vorlagenbild ein Beldeindikator eingefügt werden und in dessen Eigenschaften müssen auchnoch alle Meldeklassen aktiviert werden!

    Dann sollte es eigentlich möglich sein die Systemmeldung zu bekommen!

    Gruß
    SKg

  9. Folgender Benutzer sagt Danke zu SKg für den nützlichen Beitrag:

    sps-questioner (30.04.2010)

Ähnliche Themen

  1. Verbindung PC-300 via Ethernet
    Von thomasgull im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 23.04.2010, 20:46
  2. 315-2 PN/DP verbindung Ethernet / MPI / DP...
    Von erzteufele im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 26.11.2008, 11:57
  3. s7 verbindung über ethernet
    Von delphie im Forum Feldbusse
    Antworten: 24
    Letzter Beitrag: 22.07.2007, 12:05
  4. HMI ueber Ethernet Verbindung
    Von JandeFun im Forum HMI
    Antworten: 4
    Letzter Beitrag: 04.05.2007, 23:45
  5. Ethernet Verbindung PC - S7 mit CP
    Von sali im Forum Simatic
    Antworten: 13
    Letzter Beitrag: 31.08.2005, 02:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •