Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: CP341 Inbetriebnahme

  1. #1
    Registriert seit
    16.11.2007
    Beiträge
    93
    Danke
    67
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    da ich nicht der größte S7-Programmierer bin stehe ich nun vor einem absoluten Rätsel. Ich soll eine S7 (S7-315 PN/DP) mit Modbus RS 485 (2-Draht) Schnittstelle in Betrieb nehmen. Dazu wird ein CP341 V2.1.1 (Slave) verwendet.

    In der HW-Konfig habe ich ds Modul bereits angelegt und übertragen.
    Die mitgelieferten Bausteine FC5, FC6, FB7, FB8 und FB13 wurden ins Projekt mit eingebunden.

    Nun möchte ich gerne meine Messwerte und digitalen Eingänge als Modbus-Slave an einen Partner schicken.

    Wie muss ich mein S7-Programm aufbauen!
    Für ein Programmierbeispiel wäre ich sehr dankbar...

    Ich muss auch nur die Daten wegschicken. Nix empfangen....
    Vielen DANK an alle!
    Zitieren Zitieren CP341 Inbetriebnahme  

  2. #2
    Registriert seit
    01.04.2010
    Beiträge
    306
    Danke
    18
    Erhielt 38 Danke für 37 Beiträge

    Standard

    Ich gehe mal davon aus das du deine Hardware und Software Komplett hast.

    Ladbare Treiber für Modbus
    Optzionspaket für Step 7
    Parametriersoftware für den CP

    Des weiteren möchte ich dir den Link ans Herz legen!
    http://support.automation.siemens.co...24&treeLang=de
    Kontrollier erstmal ob alle Vorraussetzungen stimmen!

    Gruß
    SKg

  3. Folgender Benutzer sagt Danke zu SKg für den nützlichen Beitrag:

    sascha-nrw (29.04.2010)

  4. #3
    Registriert seit
    16.11.2007
    Beiträge
    93
    Danke
    67
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    die Vorraussetzungen sind alle vorhanden.
    So wie ich das sehe muss ich doch eigentlich nur den FB8 in mein Programm einbinden. Oder?

  5. #4
    Registriert seit
    01.04.2010
    Beiträge
    306
    Danke
    18
    Erhielt 38 Danke für 37 Beiträge

    Standard

    Ich weiß nicht wie der FB8 aussieht aber im Download Link steht ne beschreibung wie der zuständige Baustein arbeitet muste unter Modbusprotokoll schauen!

    Gruß
    SKg
    Angehängte Dateien Angehängte Dateien

  6. Folgender Benutzer sagt Danke zu SKg für den nützlichen Beitrag:

    sascha-nrw (29.04.2010)

  7. #5
    Registriert seit
    16.11.2007
    Beiträge
    93
    Danke
    67
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ich werde mir das gleich mal anschauen und mich ggf. nochmal melden! Vielen DANK erstmal....

  8. #6
    Registriert seit
    16.11.2007
    Beiträge
    93
    Danke
    67
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also irgendwie komme ich nicht weiter.
    So wie ich das erkenne, muss ich doch für die Inbetriebnahme lediglich den FB8 "P_SND_RK" in Betrieb nehmen. Darin auf den DB1 mit meinen Daten verweisen. Ist das Richtig?

    Wie muss ich den FB8 denn füttern?

    - Please help!!!
    Angehängte Grafiken Angehängte Grafiken
    • Dateityp: bmp 1.bmp (104,5 KB, 45x aufgerufen)

  9. #7
    Registriert seit
    06.01.2005
    Ort
    im schönen Lipperland
    Beiträge
    4.472
    Danke
    498
    Erhielt 1.143 Danke für 736 Beiträge

    Standard

    schon mal auf F1 gedrückt ? Ist doch eigentlich alles beschrieben........
    Früher gab es Peitschen .... heute Terminkalender

  10. #8
    Registriert seit
    12.05.2010
    Beiträge
    32
    Danke
    0
    Erhielt 3 Danke für 3 Beiträge

    Standard

    Hallo Sascha,
    wenn der CP341 Slave ist, kann er nicht aktiv Daten schicken, sondern nur "zur Verfügung stellen". Der Master liest und so kommen die Daten von der S7 zum anderen Rechner.
    Ist das vielleicht der Knoten den du im Kopf hast?

    Gruß,
    Kaulquappe

  11. #9
    Registriert seit
    16.11.2007
    Beiträge
    93
    Danke
    67
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jup....

    Habe es jetzt endlich hinbekommen.
    Also: Ich brauchte lediglich den FB80 entsprechend belegen und schon funktioniert es. Eigentlich ganz einfach...... Wie immer

Ähnliche Themen

  1. Inbetriebnahme
    Von Mordor_FRI im Forum Stammtisch
    Antworten: 93
    Letzter Beitrag: 23.01.2013, 18:36
  2. Inbetriebnahme SEW Antriebsregler
    Von Umrichter im Forum SEW-EURODRIVE
    Antworten: 1
    Letzter Beitrag: 24.08.2010, 18:07
  3. Englisch für Inbetriebnahme
    Von Merten1982 im Forum Programmierstrategien
    Antworten: 6
    Letzter Beitrag: 17.09.2007, 19:44
  4. Hilfe zur Inbetriebnahme mit PG 635
    Von Burkhard Eins im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 15.03.2006, 19:21
  5. Inbetriebnahme
    Von MRT im Forum Stammtisch
    Antworten: 8
    Letzter Beitrag: 08.09.2005, 16:30

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •