Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: MPI Kommunikation S7/200

  1. #1
    Registriert seit
    03.11.2003
    Beiträge
    84
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo guten Tag,
    ich habe folgende Frage.
    Gegeben ist:
    2 Stück S7/226 verbunden mit Profibusstecker (mit Comport) und Kabel an Port 0.
    Nun möchte ich mit meinem Rechner Verbindung zu den Steuerungen über den COM PORT des Profibusteckers herstellen.
    Dieses geht aber nur wenn alle Steuerungen mittels DIP Schalter in stopp stehen.
    Ist das so normal oder kann man eine Einstellung wählen in der ich auch während des RUN Betriebs eine Verbindung aufbauen kann ?

    Software Step 7 Micro/Win V4.0.1.10
    Kabel USB/PPI Multi Master Cable
    Baudrate (alle) 187,5 kBit /s

    vielen dank für eure bemühungen.
    stephan nolte
    Zitieren Zitieren MPI Kommunikation S7/200  

  2. #2
    Registriert seit
    16.07.2004
    Beiträge
    42
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo
    in über 50% der Fälle hat es mit dem Phenomen der MultiMaster (Adv.PPI) Kommunikation zu tun. Diese wird durch SMB xxx (hab ich so nich im Kopp) im ersten Zyklus jeweiliger CPU gesetzt (oder auch vergessen ). Notwendig sobald die Befehle Netwrite// read oder getX PutX - (bei TCP send und receive) benutzt werden.
    Sich dareinzuloggen gibt es verschiedene Möglichkeiten, die einfachste ist Benutzung eines MPI-Adapters an geeigneter Programmierschnittstelle (bei Siemens Software auch evtl. CP 5xxx) - damit gehts.

    Mit den Siemens PPI Kabeln hauts meist nicht, bzw. sehr schlecht hin, kommt aber auch stark auf den BUsaufbau an - bei nur 2 CPUs gelingts hin und wieder dann doch noch dazwischenfunken zu können.

  3. #3
    Registriert seit
    03.11.2003
    Beiträge
    84
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hallo fritz,
    also ist das normal. es ist zwar ärgerlich aber wohl nicht zu ändern.
    danke.

  4. #4
    Anonymous Gast

    Standard

    versuchs mal mit folgender PG/PC Einstellung für PC/PPI Kabel.

    Timeout: 10sec
    Advance PPI: NEIN
    MultiMasterNetzwerk: JA

  5. #5
    Registriert seit
    03.11.2003
    Beiträge
    84
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hallo gast,
    habe direkt probiert. klappt aber leider auch nicht.
    ich muss min. die Steuerung an dessen Stecker in den Rechner stecke in Position TERM bringen.

  6. #6
    Registriert seit
    16.07.2004
    Beiträge
    42
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Im Siemens Support Board steht dazu irgendwo ein eine Ergänzung.
    Das probierte ich mal aus und mit der zugehörigen MicroWin Demo Version einem dem Download hinzugepakten Reg.File funktionierte das dann plötzlich wenn MicroWin aus dem Simatic Manager gestartet wurde. Über Erreichbare Teilnehmer. Dazu muss natürlich erstmal der Simatic Manager vorhasnden sein ?--?
    Lief auch dann nur mit das RS232 MM-Kabel - die Alternative der 'schnelleren' USB Strippe verstummte ganz.
    (den Hinweis fand ich als nach Anschluss eines TP genau an der Stelle kein Zugriff mehr per PC/PG möglich war)

  7. #7
    Anonymous Gast

    Standard

    Mit den genannten Einstellungen müsste es funktionieren.

    Es würde nicht gehen wenn auch eine grössere CPU (S7-300/400)
    über MPI (Xput) auf den selben Port zugreift.
    (Siehe auch S7-200 Systemhandbuch (Konfigurationsbeispiele).)

    Falls du Win2000 nutzt, versuch mal mit einem WinXP Rechner,
    da du Probleme mit den USB Treiber in Zusammenhang mit
    dem PPI Kabel haben könntest.
    Ansonsten würde ich das Kabel tauschen.

  8. #8
    Registriert seit
    03.11.2003
    Beiträge
    84
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hallo zusammen,
    mit dem RS 232 Kabel geht das fast immer.
    ich habe aber beide steuerungen auf 187,5kBits gestellt um eien schnelleren datentausch zu erzielen. Diese Rate kann aber nur das USB Kabel.
    Ich benutze WIN2000 und/oder XP Laptops. Bei beiden ist es der selbe Effekt.


    Danke für Tips.
    Stephan

  9. #9
    Registriert seit
    03.11.2003
    Beiträge
    84
    Danke
    12
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo zusammen,

    ich glaube ich habe die Lösung.
    Ich hatte iin den Systemdatenbausteinen eine kleinere höchste adresse eingestellt als die Rechner haben. Nachdem ich die Sytemdatenbausteine auf die höchstmögliche eingestellt habe, gingen beide rechner sofort online.

    Vielleicht hilft das ja jemandem.

Ähnliche Themen

  1. Kommunikation Xc 201 mit MFD 4-5
    Von berti74 im Forum CODESYS und IEC61131
    Antworten: 11
    Letzter Beitrag: 05.07.2011, 13:07
  2. Kommunikation S7 300 COM -> MPI , C#
    Von T3DDy im Forum Hochsprachen - OPC
    Antworten: 13
    Letzter Beitrag: 21.09.2010, 20:59
  3. Kommunikation CP -> PC
    Von d-harry im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 15.10.2008, 14:21
  4. MPI Kommunikation
    Von jas im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 10.04.2006, 09:50
  5. Mod Bus Kommunikation
    Von Anonymous im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 03.11.2005, 19:00

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •