Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 16 von 16

Thema: Wert in Schrittkette wird nicht gesetzt

  1. #11
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Du solltest nicht Gasventil durch AD1 ersetzen sondern mal
    MD12 := 2.0 schreiben und gucken ob der Wert in MD12 bestehen bleibt?

    Anhand deiner Variablentabelle kann man nicht sehen ob du deinen AD1 noch woanders benutzt. Das kannst du mit der Querverweisliste heraus finden

  2. Folgender Benutzer sagt Danke zu marlob für den nützlichen Beitrag:

    tymanis (18.05.2010)

  3. #12
    Registriert seit
    11.05.2005
    Ort
    Baden-Württemberg
    Beiträge
    669
    Danke
    113
    Erhielt 153 Danke für 124 Beiträge

    Standard

    hi,

    mal so prinzipiell:

    Man fängt nicht ein Doppelwort mit Adresse 1 an...
    Das zeugt nicht gerade von grosser Sachkenntnis.

    Leg das mal besser auf ne gerade Startadresse.
    Manche sind auch der Meinung, diese sollte durch 4 teilbar sein.

    Micha
    "arbeite klug, nicht hart" - deutsches Sprichwort

  4. Folgender Benutzer sagt Danke zu SPSKILLER für den nützlichen Beitrag:

    tymanis (18.05.2010)

  5. #13
    tymanis ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.03.2010
    Beiträge
    134
    Danke
    43
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Ich habe mal beides gemacht. Hab mit dem Wellenreuter gelernt und daher hab ich die WORD und DWORD bereiche immer platzsparend angelegt ^^

    @marlob
    Ich habe mal einen Merker genommen und den hat die Kette beschrieben!
    Nachdem mein "Gasventil" nun andere Bytes bekommen hab, habe ich es nochmal versucht, ohne Erfolg!

    Im nächsten Schritt, Schritt 5, soll dann wieder ein Ausgangsbit gesetzt werden. Auch dies Funktioniert nicht.

    Die Schrittkette schreibt also diese 2 Ausgänge partout nicht, obwohl ich die eine bereits anders deklariert habe.

  6. #14
    Registriert seit
    11.05.2005
    Ort
    Baden-Württemberg
    Beiträge
    669
    Danke
    113
    Erhielt 153 Danke für 124 Beiträge

    Standard

    kannst das programm mal reinstellen?
    "arbeite klug, nicht hart" - deutsches Sprichwort

  7. #15
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Hast du denn auch einen AD1 in deiner Hardware?
    Ansonsten
    Zitat Zitat von SPSKILLER Beitrag anzeigen
    kannst das programm mal reinstellen?

  8. #16
    tymanis ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    20.03.2010
    Beiträge
    134
    Danke
    43
    Erhielt 5 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich danke euch beiden für die Hilfe. Ich denke den Fehler gefunden zu haben. Ich bin noch ein blutiger Anfänger, daher lerne ich mit jedem Fahler dazu

    Ich hatte die Variable in einem anderen FB ebenfalls in Benutzung. Zwar war die Bedingung für die IF-Anweisung dort zu keiner Zeit gegeben, aber so konnte die Schrittkette diese 2 Ausgänge nicht ändern.

    Werde jetzt mal in den Büchern nach dem "Warum" suchen um es auch zu verstehen.

    Danke für die Mithilfe.

Ähnliche Themen

  1. Merker wird nicht gesetzt. Programm?
    Von maninthedark im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 25.07.2011, 22:11
  2. Merker der gesetzt wird wenn SPS in RUN ist
    Von Anaconda55 im Forum Simatic
    Antworten: 68
    Letzter Beitrag: 20.03.2010, 18:05
  3. Antworten: 5
    Letzter Beitrag: 05.03.2010, 11:45
  4. Ausgang wird mal gesetzt mal nicht!?
    Von Deyn im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 04.05.2009, 13:48
  5. SM4.3 wird gesetzt, wie Analysieren.
    Von SiO2 im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 10.06.2008, 12:40

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •