Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 5 von 5

Thema: probleme mit cpu313c-2dp und sfb47

  1. #1
    Registriert seit
    11.03.2010
    Beiträge
    13
    Danke
    3
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Gemeinde,
    ich habe das erste mal mit einem schnellen Zähler mit der s7 300 zu tun. ich möchte einfach nur die Anzahl der Umdrehungen einer Rolle zählen. Dazu habe ich einfach einen Näherungsschalter montiert, der 1 impuls pro Umdrehung abgibt. Ich habe den Inititor an e0.6 angeschlossen und er funktioniert auch einwandfrei. Ich habe den Zähler in der HW-konfig parametriert (siehe Bild Zähler) auf kanal 2 und den SFB47 im OB1 einfach parametriert (siehe Bild sfb47).
    Wenn ich mein SW_gate setzte soll der Zähler die impulse zählen und wenn das bit weggeht und dann wieder gesetzt wird soll er bei 0 wieder anfangen.
    Doch der Zähler zählt nicht, und gibt mir am count_val keinen aktuellen Zählwert aus.
    Was mache ich falsch??

    Mfg Turbo76
    Angehängte Grafiken Angehängte Grafiken
    Zitieren Zitieren probleme mit cpu313c-2dp und sfb47  

  2. #2
    Registriert seit
    21.12.2006
    Ort
    Wiener Neustadt
    Beiträge
    931
    Danke
    154
    Erhielt 169 Danke für 127 Beiträge

    Standard

    Der SFB schauf auf hex 300 und du hast deinen ini auf e0.6. das 300h ist also PEW 768 das kann so nicht. schau mal in das HB denn normal sind die e124.0-124.3.
    Wieviele Impulse kommen da auf dich zu? Brauchst du die schnellen Zähler?
    Geändert von Manfred Stangl (07.06.2010 um 10:09 Uhr) Grund: Ergänzt
    Gruß
    M

    Handbook not read error...
    Klare Frage - klare Antwort

  3. #3
    Registriert seit
    17.03.2008
    Beiträge
    103
    Danke
    4
    Erhielt 24 Danke für 23 Beiträge

    Standard

    @turbo76
    Hast Du schon mal versucht, statt Signalgebertyp "Drehgeber einfach" mal "Impuls/Richtung" zu verwenden. Normalerweise liefert ein Drehgeber ein zweites Signal an E0.7. Du hast aber nur einen einfachen Ini als Geber.

    @Manfred
    Die Adresseinstellung der Digitaleingänge spielt hier keine Rolle. Nur die Basisadresse für die Zählfunktion muss mit der Adresse am SFB übereinstimmen.

    Gruss HPE

  4. Folgender Benutzer sagt Danke zu HPE für den nützlichen Beitrag:

    turbo76 (07.06.2010)

  5. #4
    turbo76 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.03.2010
    Beiträge
    13
    Danke
    3
    Erhielt 3 Danke für 3 Beiträge

    Standard

    meine Zähleradresse in der HW steht auf 768-783 (Bild) und angeschlossen ist es laut Siemenshandbuch (anschluss).
    bei maximaldrehzahl bekomme ich ca. 35 imp pro sekunde und ich muss bis ca. 150000 impulse zählen bis er wieder neu startet.
    Vielen Dank für die schnelle Antwort.
    Angehängte Grafiken Angehängte Grafiken

  6. #5
    turbo76 ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    11.03.2010
    Beiträge
    13
    Danke
    3
    Erhielt 3 Danke für 3 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke HPE,
    jetzt funtioniert es so wie ich es möchte.
    kleiner fehler, große Wirkung.

    MfG turbo76

Ähnliche Themen

  1. CPU313C mit SFB47, alle 3 Zähler parallel?
    Von Jörg_24 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 03.06.2010, 11:06
  2. Probleme SFB47
    Von marcelh im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 15.05.2009, 09:11
  3. Sfb47...
    Von Mr. T im Forum Simatic
    Antworten: 8
    Letzter Beitrag: 04.05.2007, 12:21
  4. Sfb47 Count
    Von Kleissler im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 04.05.2006, 07:24
  5. Sfb47
    Von geggo im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 07.04.2006, 23:19

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •