Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: Fehler beim Übersetzen von AWL-Batch

  1. #1
    Registriert seit
    02.02.2009
    Ort
    Raum Stuttgart
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Forum,

    ich möchte gerne ein S5-Programm auslesen. Dafür benutze ich die AWL-Batch-Dateien.
    Nun bekomme ich bei meiner aktuellen Anlage bei einigen Bausteinen einen Fehler mit dem ich nichts anfangen kann.

    Der Fehlerlautet:
    * FB 218, rel. Adr. 0000H :
    FBD0.218 Falsches Endezeichen *

    Kennt vielleicht jemand die Bedeutung der Meldung?
    Für mich sehen die Bausteine gleich aufgebaut aus, wie die Bausteine die übersetzt werden können.

    Sollte jemand Erfahrungen haben, würde es mich sehr freuen.
    Zitieren Zitieren Fehler beim Übersetzen von AWL-Batch  

  2. #2
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    In der AWL Batch Datei werden die einzelnen Werte jeder Reihe durch Tabs getrennt. Kontrolliere doch mal ob du nicht irgendwo eins gelöscht hast.

  3. #3
    Zoomy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2009
    Ort
    Raum Stuttgart
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo marlob,
    danek für die Antwort.

    Ich möchte aus S5 eigentlich eine Batch-Dateien generieren.

    D.h. es muss ja an der Formatierung im S5-Programm liegen.
    Ich bin nun alles andere als ein S5-Experte, aber ist die Formatierung dort nicht vorgegeben?

  4. #4
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Kannst du denn den baustein öffnen und einsehen, nicht das es ein geschützter Baustein ist.

  5. #5
    Zoomy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2009
    Ort
    Raum Stuttgart
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Ja das kann ich beides. Ich kann in sogar unter Dokumentation drucken.
    Bloß halt nicht mit dem Compiler Übersetzen.

    Leider finde ich auch keine Dokumentation, wo eventuelle Fehlermeldungen beschrieben werden...

  6. #6
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Kannst du denn den Rest übersetzen?

    Was hast du beim CPU-Typ eingetragen?

  7. #7
    Zoomy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2009
    Ort
    Raum Stuttgart
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Also ist gibt 5 PBs und 50DBs die ich nicht übersetzen kann.
    Weitere 80 Bausteine kann ich übersetzen.

    Den AG-Typ habe ich noch gar nicht verändert. Das war ein guter Ansatz.
    Bei AG-Typ habe ich zum einen nichts zum anderen CP945 eingetragen (die ich laut der Zuli der eingestzten OBs habe).
    Beides führt aber leider nicht zum erfolg.

  8. #8
    Registriert seit
    18.09.2004
    Ort
    Münsterland/NRW
    Beiträge
    4.718
    Danke
    729
    Erhielt 1.158 Danke für 969 Beiträge

    Standard

    Hast du nach dem übersetzen mal in deine übersetzte Datei geguckt? Ist der fehlerhafte Baustein darin enthalten? Und wie sieht der aus? Kannst du ihn rückübersetzen?

  9. #9
    Zoomy ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.02.2009
    Ort
    Raum Stuttgart
    Beiträge
    25
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Jetzt hab ichs!!!

    Das war der entscheide Denkanstoss!

    Der normale Schritt bei der Erzeugung ist ja
    mc5 -> seq.
    Dabei erzeugt er dann als Zwischenschritt eine Zwischendatei.

    Mein Problem war nun, das bei der Erzeugung der Zwischendatei die Fehler aufgetreten sind und danach alle weiteren Schritte abgebrochen wurden.

    Nehme ich danch die Zwischendatei und übersetze diese danach direkt,
    dann funktioniert es und die Datei sieht so aus, wie ich es erwartet hätte.

Ähnliche Themen

  1. Fehler beim Übersetzen
    Von B4D_Dr1ft im Forum Simatic
    Antworten: 9
    Letzter Beitrag: 01.09.2011, 15:13
  2. Fehler beim Übersetzen(Parkhausschaltung)
    Von beyniii im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 15.01.2011, 18:46
  3. Fehlermeldungen beim Übersetzen
    Von kintaro im Forum CODESYS und IEC61131
    Antworten: 2
    Letzter Beitrag: 22.11.2009, 11:51
  4. Problem beim Übersetzen der HW-Konfig
    Von the_elk im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 07.05.2009, 20:22
  5. Fehler bei Speichern und übersetzen
    Von Peter Riedl im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 22.12.2006, 19:05

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •