Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: DP-Slave von einem auf ein anderes Netz umhängen

  1. #1
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    in Netpro oder HW-Config.

    Situation ist eine CPU mit zwei DP-Schnittstellen. Nun sollen die dran hängenden Slaves neu verteilt werden. Und ich komm auf keine Methode, die es mir erlaubt, einen Slave (z.B. Fraba-Geber oder FC302) ohne Verluste von dem einen Profibus auf den anderen umzuhängen.

    Beim Kopieren geht die PAE/PAA-Adresse verloren, weil S7 beim Einfügen einfach die nächst freie vergibt. Irgendein Verschieben finde ich nicht. Kopieren und löschen führt dazu, dass das Objekt auch in der Zwischenablage weg ist.

    Gibts da einen Trick, den ich noch nicht kenne?
    Zitieren Zitieren DP-Slave von einem auf ein anderes Netz umhängen  

  2. #2
    Registriert seit
    19.06.2008
    Ort
    Ostalbkreis
    Beiträge
    3.140
    Danke
    201
    Erhielt 553 Danke für 498 Beiträge

    Standard

    Hallo,


    Wenn Du unter Eigenschaften eines Slaves das Subnetz 2 (vorher 1) einträgst, müßte es doch klappen. Soweit die Adressen frei sind

    LG

  3. #3
    Avatar von Perfektionist
    Perfektionist ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard

    Geht bei CPUs, HMI, aber nicht bei einem Slave (hier eine IM151).
    Angehängte Grafiken Angehängte Grafiken

  4. #4
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Beispiel: 2 DP Netzt DP_netz_1 und DP_netz_2. Slave_4 muss von DP_netz_1 auf DP_netz_2 übertragen werden, und die konfigurierte E/A Adressen sollen behalten werden.

    1. Ganze STEP7 Projekt kopieren.
    2. In den neuen HW Konfig, Slave_4 von DP_netz_1 lösschen.
    3. In den alten HW Konfig, Slave_4 (noch auf DP_netz_1) markieren und kopieren.
    4. In den neuen HW Konfig, DP_netz_2 markieren, und dann einfügen. Slave_4 ist dann auf DP_netz_2 aufgehängt.
    Jesper M. Pedersen

  5. Folgender Benutzer sagt Danke zu JesperMP für den nützlichen Beitrag:

    Perfektionist (18.06.2010)

  6. #5
    Registriert seit
    21.07.2008
    Beiträge
    1.066
    Danke
    51
    Erhielt 140 Danke für 136 Beiträge

    Standard

    Ich mache das mit einem weiteren Projekt und zwei HW-Konfig Fenstern.

    Kopieren > im neuen Projekt einfügen > im alten die Station löschen > von dem neuen Projekt ins alte Kopieren.

  7. Folgender Benutzer sagt Danke zu Deltal für den nützlichen Beitrag:

    Perfektionist (18.06.2010)

  8. #6
    Avatar von Perfektionist
    Perfektionist ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard

    jawoll, so gehts! klar - so hab ich doch schon ganze Gruppen ohne Datenverlust von Projekt zu Projekt kopiert ...

    Also lautet der Trick schlicht: nimm ein weiteres Projekt als Zwischenablage (Deltal) oder dupliziere das Projekt, um dann von Projekt zu Projekt verschieben zu können (Jesper).

    vier hab ich noch - und für die lohnt es sich fast noch, es genauso zu tun ...

  9. #7
    Registriert seit
    21.07.2008
    Beiträge
    1.066
    Danke
    51
    Erhielt 140 Danke für 136 Beiträge

    Standard

    Siemens könnte ja auch einfach mal die Daten in der Zwischenablage lassen wenn man löscht.. stichwort cut&paste

  10. #8
    Avatar von Perfektionist
    Perfektionist ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard

    Zitat Zitat von Deltal Beitrag anzeigen
    Siemens könnte ja auch einfach mal die Daten in der Zwischenablage lassen wenn man löscht.. stichwort cut&paste
    geht vermutlich deswegen nicht, weil nicht eine Kopie des Objekts in der Zwischenablage abgelegt wird, sondern nur ein Verweis auf das Original. Was theoretisch zur Folge hat, dass, wenn das Original nach dem Kopiervorgang verändert wurde, eine Kopie des aktuellen Zustandes des Originals hergestellt wird, nicht eine Kopie des Zustandes bei Erstellung der Kopie. Derartiges habe ich schonmal bei Flexible irgendwo beobachtet. würde mich nicht wundern, wenn dem hier auch so ist.

  11. #9
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.622
    Danke
    377
    Erhielt 799 Danke für 642 Beiträge

    Standard

    Ist ja kein Problem.
    Nach so eine Änderung soll man ja eben eine neue Program-Version starten. Dann kopierst man von alten auf den neuen Program-Version.

    Oder arbeitest Du nur mit eine Program-Version ?
    Naja. Backups und Program-Versionieren sind für Weich-Eier.
    Darauf muss ich zustehen das auf diesen Punkt bin ich ein Weich-Eier.
    Jesper M. Pedersen

  12. #10
    Avatar von Perfektionist
    Perfektionist ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    01.10.2007
    Ort
    Waiblingen
    Beiträge
    3.317
    Danke
    767
    Erhielt 536 Danke für 419 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo Jesper,

    der alte Programmstand war/ist natürlich noch vorhanden. Und eine neue Versionsnummer hat das Ding auch bekommen.

    Ich bin irgendwie blöde gewesen. Ich hatte mich in die Idee verrannt, dass das Umhängen der Slaves innerhalb des Projekts möglich sein müsse. Und das hat mir den Blick darauf verstellt, dass ich ja einfach nur das alte Projekt als Kopierquelle nehmen müsste. Na, ich werd auch langsam alt und unbeweglich im Gehirn

Ähnliche Themen

  1. Antworten: 0
    Letzter Beitrag: 02.12.2010, 13:48
  2. Antworten: 8
    Letzter Beitrag: 14.09.2010, 12:06
  3. Antworten: 10
    Letzter Beitrag: 27.08.2009, 17:08
  4. AS Interface probleme mit einem Slave
    Von koikarl im Forum Sonstige Steuerungen
    Antworten: 11
    Letzter Beitrag: 20.06.2007, 06:27
  5. Synchronlauf mit einem Master und zwei Slave
    Von kerstin im Forum Antriebstechnik
    Antworten: 3
    Letzter Beitrag: 20.02.2006, 19:17

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •