Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 18

Thema: Motor auf verschiedenen Spannungsstufen laufen lassen

  1. #1
    Registriert seit
    21.07.2010
    Beiträge
    90
    Danke
    50
    Erhielt 4 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo

    Ich habe die Aufgabe, einen Motor für einen Prüfablauf auf verschiedenen Spannungsstufen laufen zu lassen.

    Der Ablauf:
    Die Prüfung wird gestartet->Spannung auf 2V->Stromaufnahme messen->Wertevergleich mit vorgegebenem Fenster->Spannung auf 4V... ->Spannung auf 6V... ->8V ->10V

    Vom Motor bekomm ich über die Steuerleitung ein PAW an meine SPS wieder. Aber so richtig hab ich keinen Ansatz, wie ich den da nun auf 2 V hochlaufen lasse und den dann dort halte, um den Strom messen zu können.

    Hoff ihr könnt mir da helfen
    Zitieren Zitieren Motor auf verschiedenen Spannungsstufen laufen lassen  

  2. #2
    Registriert seit
    05.10.2006
    Beiträge
    169
    Danke
    21
    Erhielt 19 Danke für 11 Beiträge

    Standard

    willst du denn Motor direkt am 0-10V Analogausgang betreiben oder schaltest du noch etwas dazwischen?

  3. #3
    Registriert seit
    21.07.2010
    Beiträge
    90
    Danke
    50
    Erhielt 4 Danke für 4 Beiträge

    Standard

    zwischen die S7 und den motor ist noch ein Stromversorgung SM35-45 geschaltet (www.schulz-electronic.de/produktbeschreibung_2.html)

  4. #4
    Registriert seit
    05.10.2006
    Beiträge
    169
    Danke
    21
    Erhielt 19 Danke für 11 Beiträge

    Standard

    Und du möchtest dieses Labernetzgerät über einen Analogausgang ansteuern?

  5. #5
    Registriert seit
    21.07.2010
    Beiträge
    90
    Danke
    50
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Nee, laut Schaltplan geht die Steuerleitung direkt an den Motor (bzw. vom Motor weg auf den anal. Eingang), Saft bekommt dieser aber vom Netzgerät und das Netzgerät liefert dann auch den Stromwert auf einen anderen AI

  6. #6
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Bist Du sicher das dieses gerät von außen geregelt werden kann ?

    Meines erachtens würdest du dafür z.B. die RS232 im Meßgerät und eine CP340 an der Siematic brauchen.
    Standardmäßig sind ja nur Monitorausgänge vorhanden.
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  7. #7
    Registriert seit
    21.07.2010
    Beiträge
    90
    Danke
    50
    Erhielt 4 Danke für 4 Beiträge

    Standard

    s7-314C-2DP und CP340 sind verbaut

  8. #8
    Registriert seit
    05.10.2006
    Beiträge
    169
    Danke
    21
    Erhielt 19 Danke für 11 Beiträge

    Standard

    Wenn du nur den Analogausgang in 20%-Stufen hochfahren möchtest habe ich hier etwas zusammengebastelt:

    Code:
          U     E      0.0                  // Eingang zum Weiterschalten
          FP    M      1.0                  // Hilfsmerker für Flanke
          SPBN  END0
          L     MW    10                    // Temporärer Speicher für Analogwert
          L     27640
          >I    
          L     0
          SPB   END
          L     MW    10
          L     5529                        // Um 2V erhöhen bei Flanke (1/5 von 27648)
          +I    
    END:  T     MW    10
          T     PAW  100                    // Analogausgang schreiben
    
    END0: NOP   0

    Edit:
    Sorry, hab das mit der RS232-Schnittstellen nicht gelesen
    Geändert von Züttu (21.07.2010 um 10:32 Uhr)

  9. #9
    Registriert seit
    21.07.2010
    Beiträge
    90
    Danke
    50
    Erhielt 4 Danke für 4 Beiträge

    Standard

    Kommando zurück, natürlich geht ein analoger AUSGANG zum Motor, kein AI... Fehler im Schaltplan
    und über den muss ich ja dann einfach die 2V, 4V, etc rausbringen oder? Das SM35-45 dürfte dabei dann keine weitere Rolle spielen, ausser dem Auslesen des jeweiligen Stroms.

  10. #10
    Registriert seit
    05.10.2006
    Beiträge
    169
    Danke
    21
    Erhielt 19 Danke für 11 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    na dann müsste mein Gebastel (bin nicht wirklich stolz darauf) eigentlich passen.

Ähnliche Themen

  1. Visualisierung ohne TwinCat laufen lassen
    Von Bambam im Forum CODESYS und IEC61131
    Antworten: 3
    Letzter Beitrag: 10.09.2010, 10:31
  2. WinCC auf einem Rechner 2x laufen lassen
    Von Krumnix im Forum HMI
    Antworten: 5
    Letzter Beitrag: 06.08.2010, 10:01
  3. SFB 5 Zeit rückwärts laufen lassen
    Von trinkiwinki im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 05.09.2008, 11:11
  4. Zwei EM 253 synchron laufen lassen
    Von Superb im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 11.10.2007, 11:01
  5. Motor mit 400Hz laufen lassen...was würde passieren ?
    Von Betriebselektriker28 im Forum Antriebstechnik
    Antworten: 29
    Letzter Beitrag: 10.12.2006, 18:50

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •