Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 9 von 9

Thema: FM354 Problem mit Ink. Encoder

  1. #1
    Registriert seit
    18.02.2009
    Ort
    Köln
    Beiträge
    194
    Danke
    53
    Erhielt 15 Danke für 5 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo alle zusammen,

    habe mir eine gebrauchte FM354 gekauft und wollte die grad in Betrieb nehmen.
    FM ist Hard- & Software seitig komplette eingerichtet und angeschlossen.
    Als Fehlermeldung bekomme ich: "Drahtbruch Ink. Geber"
    Was das theoretisch bedeutet ist mir klar, aber denn noch finde ich den Fehler nicht. Spannungsversorgung 5V/0V kommen aus der FM und kann ich auch am Geber nachmessen. Anschlussleitung vom Geber zur FM habe ich 3ml durchgemessen. Der Geber gibt auch die 5V wieder aus:
    Gemessen:A=5,1V/B=0,1V Welle etwas weiter gedreht A=0,1V/B=5,1V u.s.w.

    Habe auch mal versucht direkt eine Brücke zwischen 5V und A Kanal an der FM zu machen um ein high am Kanal A zu erzeugen und B low zu lassen. Kein erfolgt. Die Störung bleibt.

    Ich habe auch mal von 0V zu Kanal A und B gemessen (ohne Stecker auf der FM): Ergebniss 2,7V
    Kann/darf das sein?
    Vielleicht kann mal jemand ohne Stecker auf der FM an Klemme 9 und 15 nachmessen?

    Hat sonst jemand Ideen?
    Zitieren Zitieren FM354 Problem mit Ink. Encoder  

  2. #2
    rerdma3s ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.02.2009
    Ort
    Köln
    Beiträge
    194
    Danke
    53
    Erhielt 15 Danke für 5 Beiträge

    Standard

    Hat keine eine FM354 wo er für mich mal grad drei Kontakte nachmessen kann?

    Würde mich sehr freuen!

  3. #3
    Registriert seit
    12.05.2009
    Beiträge
    61
    Danke
    21
    Erhielt 14 Danke für 12 Beiträge

    Standard

    Wochenende...

  4. #4
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Zitat Zitat von jack911 Beitrag anzeigen
    Wochenende...
    Ja, einen G110 oder eine S110 plus Motor oder div. SPSen habe ich rumliegen aber ne FM leider nicht!

    Frank
    Grüße Frank

  5. #5
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.725
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Du schreibst hier nur von A/B, die Spuren A Negiert, B Negiert, Null, Null Negiert,
    sind die auch vorhanden und funktionieren?

    Ich kann das praktisch zwar nicht nachmessen, aber deine gemessenen 2,7V könnten imho von Push-Up Widerständen her rühren.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  6. Folgender Benutzer sagt Danke zu MSB für den nützlichen Beitrag:

    rerdma3s (07.09.2010)

  7. #6
    rerdma3s ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.02.2009
    Ort
    Köln
    Beiträge
    194
    Danke
    53
    Erhielt 15 Danke für 5 Beiträge

    Standard

    Mein Encoder hat nur A,B,N, V+, Masse.

    Die FM hat natürlich auch die negierten Signale.
    Das ist ne Idee, welche ich mal überprüfen werde.

    Ich fände es trotz dessen ganz gut zu wissen ob die 2,7V normal sind oder nicht!
    Also wenn es jemand nachmessen kann wäre das nett.

    Gruß Rene

  8. #7
    rerdma3s ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    18.02.2009
    Ort
    Köln
    Beiträge
    194
    Danke
    53
    Erhielt 15 Danke für 5 Beiträge

    Standard

    Kann mir jemand sagen ob mein Encoder auch die negierten Signale haben muss?
    Braucht die FM die negierten Signale auf jeden Fall zusätzlich zu den nicht negierten?

    Dann könnte es ja sein, dass ich einen für die FM354 unbrauchbaren Encoder habe.

    Hat jemand ne Info für mich.

    Gruß Rene

  9. #8
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.725
    Danke
    314
    Erhielt 1.519 Danke für 1.282 Beiträge

    Standard

    Also so wie ich das Handbuch der FM:
    http://support.automation.siemens.co...iew/de/2110628
    überflogen habe, kannst du lediglich "vollbestückte" Inkrementalgeber nach RS422 Spezifikation anschließen,
    alternativ scheinen wohl auch noch SSI-Geber möglich zu sein.

    Wenn was anderes ginge, müsstest du das im Projektierungstool zur FM einstellen können,
    was offensichtlich nicht der Fall ist.

    Lange Rede, kurzer Sinn:
    Dein Geber ist nicht zu FM kompatibel.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  10. #9
    Registriert seit
    06.08.2010
    Ort
    Köln
    Beiträge
    186
    Danke
    13
    Erhielt 30 Danke für 24 Beiträge

    Beitrag


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Korrekt, 5V-Geber nur mit Differenzsignal, 24V-Geber mit A,B,N zu GND
    Sicher das dein Geber das nicht liefert? TTL-Geber ist ungewöhnlich.

Ähnliche Themen

  1. FM354 Messrad
    Von Andy_speedy im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 08.08.2008, 08:25
  2. Biete FM354
    Von rr_zx im Forum Suche - Biete
    Antworten: 4
    Letzter Beitrag: 11.02.2008, 19:48
  3. FM354 schwingt
    Von Anonymous im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 31.01.2006, 14:06
  4. Positionieren mit FM354 und Micromaster?
    Von Torsten05 im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 08.11.2005, 20:07
  5. Welche CPU für FM354?
    Von Kastele im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 27.08.2004, 09:08

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •