Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 10 von 15

Thema: Motormanagement Ansteuerung mit Step 7

  1. #1
    Registriert seit
    02.09.2010
    Beiträge
    14
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hey Leute
    ich habe das Motormanagement (ELR W3/2-500MM) über das Gateway (ELR-PB-Gateway) über Profibus an eine Simatic S7-300 angeschlossen.
    Ich habe bereits die GSD Datei in die HW-Konfig geladen und auf den Profibus gezogen.
    Kann mir jemand erklären wie ich mit Step 7 das MM ansteuern kann?

    danke schon mal im voraus!
    Zitieren Zitieren Motormanagement Ansteuerung mit Step 7  

  2. #2
    Registriert seit
    13.10.2007
    Beiträge
    12.035
    Danke
    2.789
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    Hallo Oli,
    um es vorweg zu nehmen ich habe die Komponeten noch nicht verbaut.
    Aber damit dir jemand helfen kann, muß du schon mitteilen wie deine
    Gerätschaften verbaut sind.
    Hier hast du auf einmal ein Gateway über Profibus, mit Digitalen Ein-bzw.
    Ausgängen und einer Serielen Schnittstelle.
    Jetzt die Frage so das dir jemand helfen kann, wie ist das Motorman-
    gemant Modul mit deinen Gateway verbunden, über Ein und Ausgänge
    oder über die Serielle Schnittstelle.

    Informtionen über die Phönix Geräte findest du übrigens auf der Phönix
    Seite.

    PS. dies ist ein Aufbaunder Thread und bezieht sich auf
    diesen http://www.sps-forum.de/showthread.php?t=38739
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  3. #3
    oli ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.09.2010
    Beiträge
    14
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das Motormanagement ist mit dem Gateway seriell verbunden
    http://www.bilder-upload.eu/show.php...Lg3W90ezR8.jpg




  4. #4
    Registriert seit
    13.10.2007
    Beiträge
    12.035
    Danke
    2.789
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    also ich glaube nicht das du da mit einen einfachen senden von einen
    Ausgangsbyte weiterkommst. Dazu musst du erstmal beide Anleitungen
    der Gerätschaften besorgen und dann erstmal schauen wie Sie
    funktionieren und zu Parametrieren sind.

    Also um deine Frage aufzugreifen mit den Move Befehl von MB1 auf AB0
    wird es nicht gehen.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  5. #5
    oli ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.09.2010
    Beiträge
    14
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    hier ein paar screenshots von meinem problem. Unter Zielsystem, Baugruppenzustand habe ich folgenden Fehler (auch auf dem screenshot zu sehen) Baugruppe nicht verfügbar(Pheripheriezugriffs- oder Parametrierfehler).


    http://s3.directupload.net/file/d/2276/dwv74xkf_jpg.htm
    http://s1.directupload.net/file/d/2276/ayzbmd4g_jpg.htm
    http://s7.directupload.net/file/d/2276/ppwsdtwa_jpg.htm
    http://s5.directupload.net/file/d/2276/iflkw9y3_jpg.htm

  6. #6
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Hallo Oli,

    du hast zwar durch die GSD-Datei dir das DP-Normmodul ELR-PB in die Hardware gezogen (Bild 1) aber ich sehe nirgends was du dir dann für Einzelmodule reingeholt hast, wie z.b.:
    - Digital Inputs
    - Voltage
    - Power
    Wenn die Module rein geschoben werden, wird ja gleich eine Adresse vergeben und genau über die Adresse solltest du dann das Modul steuern können.
    Welche Module du benötigst, welche Bits, Bytes von dem Modul angesprochen werden müssen, sollte in dem Handbuch von dem Teil stehen.
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  7. #7
    oli ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.09.2010
    Beiträge
    14
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo Paule,

    das device control/state modul ist von anfang an drin und hat ein- und ausgangsadresse 0. hab auch schon versucht die ausgänge anzusteuern man sieht auch unter beobachten/steuern das sich an den ausgängen was tut aber der motor läuft trotzdem nicht an.

    noch ne andere frage was ist der unterschied zwischen PAB 0 und AB 0, dass das eine Peripherieausgangsbyte und das andere nur ausgangsbyte heißt weiß ich, aber wann benutzt man was?

  8. #8
    Registriert seit
    13.10.2007
    Beiträge
    12.035
    Danke
    2.789
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard

    PAB und AB sind im Prinzip das selbe, aber wenn du etwas
    mit T PAB X.Y ansprichst wird direkt unverzüglich in
    die Ausgangsadresse geschrieben.
    Wenn du mit T AB X.Y wird das erst später zwischen
    den OB1 Zyklen geschrieben.
    Mit geschrieben meine ich an die Hardware weitergereicht.
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  9. #9
    oli ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    02.09.2010
    Beiträge
    14
    Danke
    1
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    habe jetzt das Einzelmodul Digital Inputs(Eingangsadresse 1) in das DP-Normmodul ELR-PB gezogen. Das Bit E1.0 ist der Eingang1 auf den Eingang1 habe ich den Linkslauf eingestellt.
    Aber ich kann E1.0 nicht setzten wie man auf meinem screenshot sehen kann.
    Muss ich noch irgendwas am Profibus DP einstellen? Die Verbindung zum ELR PB Gateway ist da.

    http://www.fotos-hochladen.net/view/...nt5cr8jyox.jpg

    (das fenster Beobachten/steuern ist von dem Modul Digital Inputs)

  10. #10
    Registriert seit
    13.10.2007
    Beiträge
    12.035
    Danke
    2.789
    Erhielt 3.269 Danke für 2.157 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ein Eingang wird nicht gesetzt, der dient zur Abfrage von Sensoren.
    Ausgänge werden gesetzt, um ein Signal aus der Steuerung zu einen
    Aktor oder anderen Teilnehmer zu bekommen.

    Da fehlen ein wenig Grundlagen Automatiesierungs Technik, währe es
    nicht besser du besuchst erst mal einen Kurs?
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

Ähnliche Themen

  1. Antworten: 2
    Letzter Beitrag: 21.08.2012, 11:22
  2. Funktionsaufrufe Online step by step ansehen
    Von snowleopard1702 im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 03.05.2011, 07:41
  3. Antworten: 10
    Letzter Beitrag: 29.10.2010, 17:06
  4. ABB Motormanagement INSUM
    Von Stefan B. im Forum Antriebstechnik
    Antworten: 6
    Letzter Beitrag: 10.02.2009, 14:45
  5. Antworten: 2
    Letzter Beitrag: 24.01.2006, 06:01

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •