Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 7 ErsteErste 12345 ... LetzteLetzte
Ergebnis 21 bis 30 von 64

Thema: Problem: Selbständiges Urlöschen der CPU nach Einschalten der Maschine

  1. #21
    Registriert seit
    02.04.2006
    Ort
    nähe Muc
    Beiträge
    2.787
    Danke
    115
    Erhielt 126 Danke für 107 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo,

    hatte das auch mal bei einem Speicherüberlauf der MMC oder des CPU Spiechers, weiss nimmer genau. Ist zu lange her.
    JEdenfalls habei ich damals glaub zu viele DB geöffnet und zu viel auf die MMC geschrieben.

    Hast du schon mal eine größere MMC versucht?

    (Bin damals dann auf OPC ausgewichen)
    --

    Ein früherer k
    Kollege hatte das auch mal Programmtechnisch geschaft.
    Er hat sich überlegt das als Sicherheit vor Softwarekopien (bei Serienmaschinen) einzusetzen.
    ___________________________________________





    Sende eine SMS mit dem Stichwort "Feuer" an die 112 und innerhalb von 10 Minuten steht ein roter Partybus mit derbem Sound vor deiner Tür.


    AGB: Wer Rechtschreibfehler findet darf diese behalten. Bitte meine in eile gefertigten, selten anfallenden Vertipsler zu entschuldigen.

  2. #22
    Avatar von IBFS
    IBFS ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    zu viele DB geöffnet und zu viel auf die MMC geschrieben
    ich hatte in meinem Fall ja gar nichts auf die MMC geschrieben,
    das war ja nur eine "Wertesicherungsoperation", die ich da
    angedacht hatte.

    Aber mit dem Link aus Post #19 ist das Thema für die 315-PN/DP
    durch und auch das FW-UPD für die 315-2DP soll wohl bald kommen.


    Gruß

    Frank
    Grüße Frank

  3. #23
    Registriert seit
    30.08.2003
    Beiträge
    2.196
    Danke
    30
    Erhielt 258 Danke für 229 Beiträge

    Standard

    Hallo,

    das ist ein Problem dass mit der Firmware 3.2.3 behoben wird. Dieser ist noch nicht für alle neuen CPU's verfügbar. ZB bei der 6ES7315-2EH14-0AB0 V3.2.3 ist dieses Verhalten schon behoben.

    Mit dem Firmware-Update V3.2.3 werden die folgenden Änderungen wirksam:

    • Nach Netz-aus kommt es nicht mehr sporadisch zu Aktualwertverlusten durch Urlöschanforderung wegen Speichertausch (Ereignis-ID 16# 6526)


    • Die Remanenzsicherung bei Netz-aus wurde stabilisiert (betrifft hochsporadische Remanenzverluste mit Ereignis-ID 16# 4580 „Backup-Pufferinhalt inkonsistent“).


    • Hinzufügen eines Schrittes in S7-Graph und anschließender Baustein-Download führt nicht mehr für einen Zyklus zu einem Bereichslängenfehler. Ab sofort können wieder mehrere Bausteine zusammen eingekettet werden.


    • Antwortet ein Slave auf das erste Datentelegramm des Masters negativ (z.B. mit „habe keinen Speicher für Data-Response“), dann führt dies nicht mehr dazu, dass der Slave später nicht aufgenommen wird.


    • Bei einem mit dem SFC12 aktivierten und anschließend ausgefallenen Slave, wird bei der darauffolgenden Slave-Wiederkehr am DP-Strang nun wieder der OB86 aufgerufen. Auch bleibt bei Slave-Wiederkehren während des Übergangs von STOP nach ANLAUF (u.a. im Hochlauf der CPU) nicht mehr sporadisch die Kennung für einen Peripheriezugriffsfehler gesetzt.


    • Die Befehlsabfolge „L MW 2, TAK, T MW 3, TAK“ funktioniert ab sofort auch, wenn die Bereiche von „T“ und „L“ (wie in der genannten Befehlsabfolge) überlappend sind.


    • Projektierte aber nicht vorhandene PA-Eingänge können nun wieder mittels VAT gesteuert werden.


    • Die Projektierung einer Profinet-Verbindung ohne Devices führt nach dem Download nicht mehr zum Anknipsen der BF2-LED.


    • Die AWL-Anweisung DTB „DWord-To-BCD“ führt bei einem ungültigen Eingangswert (kein BCD-Wert) nicht mehr zum Defekt mit Z1=f11c.


    • Ein SDB0 mit ungültiger Baudrate führt nicht mehr zum Defekt mit Z1=914A; stattdessen wird ab sofort die MPI-Default-Baudrate von 187,5 kBd voreingestellt.


    • Ein Netz-aus während Baustein online beobachten führt nicht mehr sporadisch zu einem Defekt mit Z1=0019 oder Z1=F104.


    • Der SFC1 "READ_CLK" wandelt ab sofort die Jahreszahl immer korrekt in eine BCD-Zahl. Nachfolgende auf das BCD-Format aufsetzende Anweisungen (z.B. BTI „BCD-To-Integer“) führen somit nicht mehr zu Wandlungsfehlern (z.B. Ereignis-ID 16# 2521 „BCD-Wandlungsfehler).
    Beitrags-ID 40360647

    André
    www.raeppel.de
    mit innovativen SPS-Tools schneller ans Ziel ....
    Zitieren Zitieren Firmware  

  4. #24
    Registriert seit
    17.05.2010
    Ort
    Paderborn
    Beiträge
    824
    Danke
    84
    Erhielt 125 Danke für 94 Beiträge

    Standard

    Zitat Zitat von sps-concept Beitrag anzeigen
    Hallo,

    das ist ein Problem dass mit der Firmware 3.2.3 behoben wird. Dieser ist noch nicht für alle neuen CPU's verfügbar. ZB bei der 6ES7315-2EH14-0AB0 V3.2.3 ist dieses Verhalten schon behoben.


    Beitrags-ID 40360647

    André
    Ich muss Dich leider enttäuschen, ich habe eine getauschte (SIEMENS Retouren-Center) CPU 315-PN/DP mit FW V.3.2.3 und eine neue, bei der ich die CPU selbst mit der neusten FW versehen haben, beide haben das gleiche Verhalten!
    ==> Verlust der Aktualdaten!

    siehe auch: http://www.sps-forum.de/showthread.php?t=42393
    Grüße
    Michael

    1001101110110100... Das ist meine Welt

  5. #25
    Avatar von IBFS
    IBFS ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Zitat Zitat von MCerv Beitrag anzeigen
    Ich muss Dich leider enttäuschen, ich habe eine getauschte (SIEMENS Retouren-Center) CPU 315-PN/DP mit FW V.3.2.3 und eine neue, bei der ich die CPU selbst mit der neusten FW versehen haben, beide haben das gleiche Verhalten!
    ==> Verlust der Aktualdaten!

    siehe auch: http://www.sps-forum.de/showthread.php?t=42393


    ...und was sagt SIEMENS dazu????????

    Frank
    Grüße Frank

  6. #26
    Registriert seit
    17.05.2010
    Ort
    Paderborn
    Beiträge
    824
    Danke
    84
    Erhielt 125 Danke für 94 Beiträge

    Standard

    ich hab noch keine Rückmeldung vom Support
    Grüße
    Michael

    1001101110110100... Das ist meine Welt

  7. #27
    Registriert seit
    02.02.2011
    Beiträge
    12
    Danke
    0
    Erhielt 1 Danke für 1 Beitrag

    Standard

    Kann man das Projekt mal sehen, was Du in HWKonfig projektiert hast?
    Zip es mal aus Step7 heraus.

  8. #28
    Registriert seit
    17.05.2010
    Ort
    Paderborn
    Beiträge
    824
    Danke
    84
    Erhielt 125 Danke für 94 Beiträge

    Standard

    Also die Ereignis-ID 16# 6526 „Urlöschanforderung wegen Speichertausch“ kann doch unmöglich etwas mit der Hardwareconfig zu tun haben. Ich habe zwar mal vorsichtshalber die Konfig komplett neu erstellt und meine "Marktbegleiter"-Speicherkarten durch SIEMENS eigene ersetzt. Das Ganze aber auch nur, weil die Anlagen kurz vor der Auslieferung stehen und ich eine Lösung brauche.
    Grüße
    Michael

    1001101110110100... Das ist meine Welt

  9. #29
    Registriert seit
    13.10.2007
    Beiträge
    12.038
    Danke
    2.789
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    Hallo Michael,
    wenn ich mir die Problemme von dir und Frank (IFBS) so anschaue, dann
    wünsche ich mir das Zeitalter der Pufferbatterie zurück. Da wusste mann
    was los war, oder es ging wenigstens eine Lampe am Netzteil an.

    Ich finde das ist Ummöglich, das Siemens eine so wichtige Eigenschaft wie
    Remanenz nicht in den Griff bekommt. Vlt. liegt es auch garnicht an den
    Speicherkarten oder Software, sondern es ist eine Hardwareproblemm der
    CPU.

    gruß helmut
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  10. #30
    Registriert seit
    17.05.2010
    Ort
    Paderborn
    Beiträge
    824
    Danke
    84
    Erhielt 125 Danke für 94 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Gut das es erst vor kurzem von SIEMENS ein Re-Design der CPU's gab
    Grüße
    Michael

    1001101110110100... Das ist meine Welt

Ähnliche Themen

  1. Maschine nach Kanada
    Von Gülle im Forum Schaltschrankbau
    Antworten: 9
    Letzter Beitrag: 23.07.2010, 16:06
  2. Bus-Fehler nach Einschalten
    Von the_elk im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 30.04.2009, 12:06
  3. Export von Maschine nach China
    Von Integer im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 1
    Letzter Beitrag: 19.08.2008, 16:33
  4. SR-Glied nach Einschalten immer gesetzt
    Von knochi im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 02.05.2007, 22:50
  5. C7-626 nach Urlöschen neu laden
    Von JensPipka im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 19.03.2004, 12:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •