Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 7 123 ... LetzteLetzte
Ergebnis 1 bis 10 von 64

Thema: Problem: Selbständiges Urlöschen der CPU nach Einschalten der Maschine

  1. #1
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ich habe in kürzerer Zeit (wenigen Wochen) mehrfach den Fall gehabt, das
    nach dem Wiedereinschalten der Maschine alle Aktualwerte auf die
    Startwerte zurückgesetzt worden sind.

    Einen Fall konnte im Diagnosepuffer auslesen:


    Diagnosepuffer der Baugruppe CPU 315-2 DP
    Bestell-Nr./ Bezeichn. Komponente Ausgabestand
    6ES7 315-2AH14-0AB0 Hardware 2
    - - - Firmware V 3.0.3
    Boot Loader Firmware-Erweiterung A 25.7.5
    Baugruppenträger: 0
    Steckplatz: 2

    Seriennummer: S C-A3XH15672010

    Ereignis 1 von 105: Ereignis-ID 16# 5371
    Dezentrale Peripherie: Ende der Synchronisation mit einem DP-Master
    Steckplatz des DP-Masters: 2
    Anzahl der dezentralen Stationen: 0
    kommendes Ereignis
    23:15:19.009 24.08.2010

    Ereignis 2 von 105: Ereignis-ID 16# 430E
    Urlöschen durchgeführt
    Bisheriger Betriebszustand: STOP (Urlöschen)
    Angeforderter Betriebszustand: STOP (Eigeninitialisierung)
    kommendes Ereignis
    23:15:15.607 24.08.2010

    Ereignis 3 von 105: Ereignis-ID 16# 4546
    STOP durch CPU-Speicherverwaltung
    Bisheriger Betriebszustand: STOP (Eigeninitialisierung)
    Angeforderter Betriebszustand: STOP (Urlöschen)
    interner Fehler, kommendes Ereignis
    23:15:11.331 24.08.2010

    Ereignis 4 von 105: Ereignis-ID 16# 4300
    NETZ-EIN gepuffert
    Bisheriger Betriebszustand: SPANNUNGSLOS
    Angeforderter Betriebszustand: STOP (Eigeninitialisierung)
    kommendes Ereignis
    23:15:11.331 24.08.2010

    Ereignis 5 von 105: Ereignis-ID 16# 6526
    Urlöschanforderung wegen Speichertausch
    Betriebszustand: STOP (Eigeninitialisierung)
    interner Fehler, kommendes Ereignis
    23:15:11.331 24.08.2010

    Ereignis 6 von 105: Ereignis-ID 16# 494E
    Netzausfall
    Bisheriger Betriebszustand: RUN
    Angeforderter Betriebszustand: SPANNUNGSLOS
    externer Fehler, kommendes Ereignis
    23:14:58.799 24.08.2010

    Leider hatte ich zum "Schadenzeitpunkt" nur in diesem einen Fall sofortigen Zugriff auf die CPU.

    Ein Speichertausch fand definitiv nicht statt (siehe Zeitstempel).

    Ich kann mir nicht vorstellen das wir die Einzigen sein sollen, wo sowas aufgetreten ist.

    Es ist an bisher 4 Stück CPU 315-2 DP und einer CPU 315 PN/DP beobachtet worden.





    Gruß

    Frank
    Geändert von IBFS (18.09.2010 um 19:32 Uhr) Grund: RETSCHTCHREIPUNK
    Grüße Frank
    Zitieren Zitieren Problem: Selbständiges Urlöschen der CPU nach Einschalten der Maschine  

  2. #2
    Registriert seit
    05.10.2005
    Beiträge
    2.373
    Danke
    321
    Erhielt 296 Danke für 266 Beiträge

    Standard

    Hallo Frank,

    kannst Du el. Einflüsse von außen ausschließen(Netzteil/BUS/...)? Ich hatte vor längerer Zeit mal eine 416 2DP mit Speicherproblemen. Damals sollten wir auch nach Externen Störquellen suchen(weit verzweigte Anlage mit IBS). Einen richtigen Verursacher haben wir nie gefunden. Der Fehler trat irgendwann nicht mehr auf, obwohl nichts gewechselt wurde. Vielleicht finde ich nochirgendwo die damalige Fehlerhistorie im SanduhrAnzeigeProgramm wieder.
    Thomas

    EDIT: Ist das Verhalten reproduzierbar, in dem du kurz die Spannungsversorgung unterbrichst?
    Geändert von thomass5 (16.09.2010 um 08:43 Uhr)

  3. #3
    Registriert seit
    01.01.2009
    Ort
    Niedersachsen
    Beiträge
    813
    Danke
    180
    Erhielt 79 Danke für 75 Beiträge

    Standard

    Hallo Frank,

    ich hatte vor kurzem ein ähnliches problem.

    Beim Neustart wurden die Aktualwerte in den DBs alle auf 0 (Null) gesetzt.
    Ausserdem wurde ab einer gewissen Anzahl von Bausteinen sehr viele Bausteine nicht mehr angezeigt. Beim Bausteinvergleich waren sie auch nicht vorhanden; aber im Speicher waren sie drin.

    Laut Siemens war es ein Firmware-Problem.

    Nach dem laden der neusten Firmware, waren die Probleme weg.

    Ich meine es war auch eine 315 gewesen.

    Ich schaue mal, ob ich morgen die Fehlerbeschreibung u.s.w. heraussuchen kann.

    Im Zweifelsfall, hilft Siemens-Support weiter.
    Allerdings kann es nach meiner Erfahrung zwischen 3 Stunden und einer Woche dauern, bis eine endgültige Lösung vorliegt.

    Gruß Jan
    Gruß Jan

    Wer fragt, bekommt Antworten.

  4. #4
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Jan Beitrag anzeigen
    Laut Siemens war es ein Firmware-Problem.

    Nach dem laden der neusten Firmware, waren die Probleme weg.
    zumindest die CPU aus der der Diagnosepufferdump stammt hat die neuste Firmware (und ich geh auch davon aus, dass Frank das schon im Blick hatte...)
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  5. #5
    Registriert seit
    01.01.2009
    Ort
    Niedersachsen
    Beiträge
    813
    Danke
    180
    Erhielt 79 Danke für 75 Beiträge

    Standard

    Zitat Zitat von vierlagig Beitrag anzeigen
    zumindest die CPU aus der der Diagnosepufferdump stammt hat die neuste Firmware (und ich geh auch davon aus, dass Frank das schon im Blick hatte...)

    Also kann ich es mir sparen das Problem das ich hatte hier groß auszubreiten?
    Gruß Jan

    Wer fragt, bekommt Antworten.

  6. #6
    Avatar von IBFS
    IBFS ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Zitat Zitat von Jan Beitrag anzeigen
    Also kann ich es mir sparen das Problem das ich hatte hier groß auszubreiten?
    Vierlagig wollte damit nur sagen, dass an anhand des Diagnosehaeders...

    Code:
    Diagnosepuffer der Baugruppe CPU 315-2 DP
    Bestell-Nr./ Bezeichn. Komponente Ausgabestand 
    6ES7 315-2AH14-0AB0 Hardware 2 
    - - - Firmware V 3.0.3 
    Boot Loader Firmware-Erweiterung A 25.7.5

    ....erkennen kann, das ich in meinem Fall den aktuellen FW-Stand habe und ich daher gar keine neuere FW-Version einspielen könnte.

    Das soll aber nicht heißen, dass negative Erfahrungen, die du hattest, nicht doch hier hilfreich sind zu posten.

    Frank
    Grüße Frank

  7. #7
    Registriert seit
    01.01.2009
    Ort
    Niedersachsen
    Beiträge
    813
    Danke
    180
    Erhielt 79 Danke für 75 Beiträge

    Standard

    Hallo Frank,

    dann werde ich mal meine Fehlerbeschreibung von damals reinstellen.
    Hätte ich gewusst, dass der Siemenssupport schon durch meine dürftige telefonische Beschreibung weiß was los ist, hätte ich mir diese Arbeit nicht gemacht.
    Aber vieleicht hilft es dir oder anderen noch weiter.
    Angehängte Dateien Angehängte Dateien
    Gruß Jan

    Wer fragt, bekommt Antworten.

  8. #8
    Avatar von IBFS
    IBFS ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard

    Leider liegt bei mir der Fall etwas anders. Es passiert nicht
    beim Laden sondern beim Wiedereinschalten der CPU.
    Es wird halt in dem einen speziellen Fall nur das Neustecken
    der MMC-Karte erkannt obwohl die Keiner angefasst hat.

    Wenn das nur bei einer CPU aufgetreten wäre - Montags-CPU.
    Aber speziell bei den 315-DP2 sind mehrere Baugleiche CPUs
    betroffen wobei mit zunehmender Betriebszeit das Auftreten
    des Fehlers immer geringer wurde.

    Und wenn man dann im Fehlerfall nicht in CPU-Nähe ist,
    kommt man ja auch an den DIAG-Pufferinhalt nicht ran. MIST.

    Wie soll man dann sowaß beim Kunden und SIEMENS nachweisen.

    Kann man nach dem RAM to ROM nur hoffen, dass der Kunde die
    Betriebsparameter nicht mehr ändert. Dann kann sich die CPU
    Urlöschen sooft sie will

    Frank
    Grüße Frank

  9. #9
    Registriert seit
    05.10.2005
    Beiträge
    2.373
    Danke
    321
    Erhielt 296 Danke für 266 Beiträge

    Standard

    Hallo Frank,

    nach Deinen Schilderungen sieht das nach Hardwarefehler aus. Das sind jetzt nur Vermutungen. Bei Spannungsverlust versucht die CPU den Speicherinhalt noch auf MMC zu bekommen, aber ihr geht der Puffer aus. Wie lang war die CPU denn schon in Betrieb? Ich könnte mir vorstellen, das mit zunehmender Betriebsdauer der Pufferkondensator "besser"/"voller" wird. Lass es mal eine gleiche Charge von Kondensatoren sein.

    Abhilfe beim Kunden? Eventuell wenn durch Kunden Betriebsparameter geändert wurden programmtechnisch die Parameter auf die MMC schreiben (Übernahmebutton an HMI ...).

    Thomas

  10. #10
    Avatar von IBFS
    IBFS ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    25.06.2007
    Ort
    Dresden
    Beiträge
    3.930
    Danke
    465
    Erhielt 878 Danke für 634 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von thomass5 Beitrag anzeigen
    Abhilfe beim Kunden? Eventuell wenn durch Kunden Betriebsparameter geändert wurden programmtechnisch die Parameter auf die MMC schreiben (Übernahmebutton an HMI ...).
    Thomas
    WRITE_DBL und READ_DBL haben wir.
    Aber wenn die Startwerte UNGLEICH Null sind - nach RAM to ROM
    kann der Kunde die minimale "Rück"-Veränderung von z.B.
    245,5mm auf nun 145,3 mm nicht erkennen.

    Daher habe ich mir schon überlegt einen Sonder DB anzulegen
    mit Startwert NULL und Aktualwerte EINS. Aber das EINS-setzen
    natürlich erst NACH dem RAM to ROM sonst funzt es ja nicht.
    Falls dieser Wert wieder auf Null zurückgefallen ist, dann ist der
    URLÖSCH-Fall eingetreten und man kann dann das READ_DBL
    machen. Hoffentlich drückt im Fehlerfall keinen versehentlich
    WRITE_DBL sonst ist alles zu spät

    Frank

    P.S.

    Es sind in dem einen Fall vier baugleiche CPUs und auch die
    MMC wurde gemeinsam bestellt, im anderen Fall ist es eine
    CPO 315 PN/DP frisch aus dem Werk. Bin mal gespannt wie das
    weitergeht.
    Grüße Frank

Ähnliche Themen

  1. Maschine nach Kanada
    Von Gülle im Forum Schaltschrankbau
    Antworten: 9
    Letzter Beitrag: 23.07.2010, 16:06
  2. Bus-Fehler nach Einschalten
    Von the_elk im Forum Simatic
    Antworten: 12
    Letzter Beitrag: 30.04.2009, 12:06
  3. Export von Maschine nach China
    Von Integer im Forum Maschinensicherheit - Normen und Richtlinien
    Antworten: 1
    Letzter Beitrag: 19.08.2008, 16:33
  4. SR-Glied nach Einschalten immer gesetzt
    Von knochi im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 02.05.2007, 22:50
  5. C7-626 nach Urlöschen neu laden
    Von JensPipka im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 19.03.2004, 12:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •