Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 30 von 30

Thema: SIEMENS S7 mit PNOZmulti über Ethernet verbinden?

  1. #21
    Registriert seit
    06.10.2009
    Ort
    Hessen
    Beiträge
    560
    Danke
    24
    Erhielt 43 Danke für 40 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ja klar, aber er sagt ja #7000 .. Lt. Hilfe bedeutet das kein Auftrag zum Aufbauen aktiv!
    Das, was man weiß, hat doppelten Wert, wenn man zugleich das, was man nicht weiß, nicht zu wissen eingesteht.

  2. #22
    Registriert seit
    13.10.2007
    Beiträge
    12.039
    Danke
    2.790
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    Alles flankengesteuert, was sagt den das done Bit
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  3. #23
    Registriert seit
    06.10.2009
    Ort
    Hessen
    Beiträge
    560
    Danke
    24
    Erhielt 43 Danke für 40 Beiträge

    Standard

    Done = 0..

    ... Ich habe den REQ Aufruf mit dem Done verknüpft..

    UN DONE
    S REQ
    U DONE
    R REQ

    Ich mache irgendwas elementares Falsch, komm aber nicht drauf.. würde dir das TIA Projekt helfen?
    Das, was man weiß, hat doppelten Wert, wenn man zugleich das, was man nicht weiß, nicht zu wissen eingesteht.

  4. #24
    Registriert seit
    13.10.2007
    Beiträge
    12.039
    Danke
    2.790
    Erhielt 3.273 Danke für 2.159 Beiträge

    Standard

    Ich denke da wird dein Auftrag garnicht angestoßen, das kannst
    mit Busy Bit prüfen. Als Ergebnis muss dann das 'fertig' oder
    'fehlerbit' kommen.

    Auf der Hompage von Siemens gibt es fertige Beispiele, nimm die mal zu
    Hilfe und hier kannst du auch ein wenig lesen TCP-SOCKET Kommunikation mit WinAC RTX
    - - -
    Wer als Werkzeug nur einen Hammer hat, sieht in jedem Problem einen Nagel.

  5. #25
    Registriert seit
    06.10.2009
    Ort
    Hessen
    Beiträge
    560
    Danke
    24
    Erhielt 43 Danke für 40 Beiträge

    Standard

    Die Verbindung steht so wie das aussieht.
    Ich habe den Aufbau genauso realisiert wie in dem Beispiel-Projekt openTCP von Siemens.
    Dann habe ich mir aus dem Beispielprojekt von Pilz den DB99 genommen und die Zugriffadresse und Länge genauso wie in diesem Beispiel parametriert.
    Nun bekomm ich aber immer den STATUS 8088 bei SEND/RECV.
    Das bedeutet wohl:

    Empfangsbereich ist zu klein

    Wert in LEN ist größer als der durch DATA vorgegebene Empfangsbereich

    Kann ich aber nicht wirklich nachvollziehen weil der Datenbaustein ja aus dem PILZ-Projekt ist. // EDIT ... Hab den Fehler gefunden.. da Die Bausteine im TIA etwas anders zu Parametrieren sind hatte er die Länge zwar angenommen aber hatte keinen Datentyp (Byte) am Pointer stehen... Vielen Dank für die Hilfe!
    Geändert von c.wehn (12.06.2013 um 12:32 Uhr)
    Das, was man weiß, hat doppelten Wert, wenn man zugleich das, was man nicht weiß, nicht zu wissen eingesteht.

  6. #26
    Registriert seit
    06.10.2009
    Ort
    Hessen
    Beiträge
    560
    Danke
    24
    Erhielt 43 Danke für 40 Beiträge

    Standard

    Mh... Ab und zu gibt's hier noch Probleme mit dem Verbindungsaufbau..

    Ist das ein Problem wenn man über die gleiche Schnittstelle Verbindung zu zwei Sinamics, einem Panel und der Pnoz aufbaut?
    Sind ja quasi.. verschiedene Protokolle..
    Das, was man weiß, hat doppelten Wert, wenn man zugleich das, was man nicht weiß, nicht zu wissen eingesteht.

  7. #27
    Registriert seit
    07.08.2014
    Beiträge
    8
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von zwiebelernst Beitrag anzeigen
    Ja, hab ich schonmal gemacht und je 1 Byte E/A übertragen. Du brauchst dazu die passende GSD bzw. hier XML Datei für das mc9p Anybus Modul.
    Hab im Anhang mal ein Screenshot der HWconfig und die XML drangehängt.

    Gruss, Thomas
    Ist schon was älter die Aussage, aber ich kram die nochmal vor
    Du hast das mc9P Modul aber auch verbaut?
    Oder direkter Ethernetanschluß am PNOZ?

    Gruß aus Remscheid

  8. #28
    Registriert seit
    06.03.2017
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Serwus zusammen,

    wollte wissen ob jemand von euch die Verbindung zum PNOZmulit über ETH auch schon mit einer S7-1500 und TIA realisiert hat?

    Gruß Reiter Robert

  9. #29
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.735
    Danke
    321
    Erhielt 1.523 Danke für 1.283 Beiträge

    Standard

    Zitat Zitat von bengei Beitrag anzeigen
    Serwus zusammen,

    wollte wissen ob jemand von euch die Verbindung zum PNOZmulit über ETH auch schon mit einer S7-1500 und TIA realisiert hat?

    Gruß Reiter Robert
    Ich hab zwar schon seit x Jahren kein PNOZ Multi mehr eingesetzt, weil wir auf F-CPUs bzw. Phoenix Trisafe umgestiegen sind,
    jedoch scheint es so, das Pnoz-Multi Ethernet-seitig ja u.a. Modbus TCP unterstützt, und das mittlerweile bei der S7-12/15xx recht gut implementiert ist,
    Deshalb sollte das jetzt kein gesteigertes Problem darstellen.
    https://support.industry.siemens.com.../view/94766380
    Im Fall vom PNOZ ist halt S7-Seitig nur die Client Seite relevant.
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  10. #30
    Registriert seit
    06.03.2017
    Beiträge
    2
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von MSB Beitrag anzeigen
    Ich hab zwar schon seit x Jahren kein PNOZ Multi mehr eingesetzt, weil wir auf F-CPUs bzw. Phoenix Trisafe umgestiegen sind,
    jedoch scheint es so, das Pnoz-Multi Ethernet-seitig ja u.a. Modbus TCP unterstützt, und das mittlerweile bei der S7-12/15xx recht gut implementiert ist,
    Deshalb sollte das jetzt kein gesteigertes Problem darstellen.
    https://support.industry.siemens.com.../view/94766380
    Im Fall vom PNOZ ist halt S7-Seitig nur die Client Seite relevant.
    Ich hatte bis jetzt auch immer F-CPUs, aber wenns der Kunde mit PNOZ will...

    Mein Problem war eher, weil die PNOZ multi "mini" kein Feldbusmodul für Profinet haben - die PNOZ muliti (neuere Generation) schon.
    Jetzt haben wir aber ein mini, und ich muss das ganze mit TCP-Verbindung machen.
    Hat sich in soweit gelöst, dass PILZ mir ein Programm mit S7-1500er CPU geschickt hat und ich mir das ganze nicht aus den Fingern saugen musste.

    Danke für die schnelle Antwort
    Gruß Bengei

Ähnliche Themen

  1. S7 via ethernet verbinden
    Von EBT070 im Forum Simatic
    Antworten: 32
    Letzter Beitrag: 28.10.2010, 12:57
  2. Vipa 312 5BE03 über Ethernet mit Step7 verbinden
    Von sps-aimoehl im Forum Sonstige Steuerungen
    Antworten: 4
    Letzter Beitrag: 11.04.2010, 17:04
  3. Zwei S7 über Ethernet verbinden
    Von S7_Mich im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 19.07.2008, 05:50
  4. PNOZmulti über Profibus einbinden
    Von Felix82 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 17.03.2008, 14:35
  5. Antworten: 6
    Letzter Beitrag: 12.04.2005, 11:44

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •