Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 10 von 10

Thema: Bitflankern über OPC

  1. #1
    Registriert seit
    16.09.2010
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Guten Mittag,

    ich habe auf einem Projekt, wo wir von einer selbst programmierten Visu auf ein OPC Server zugreifen, der wiederum mit einer SPS verbunden ist.

    Irgendwo auf diesem Weg haben wir Bitflakern, so dass das SPS Programm nicht richtig läuft.

    Nun haben wir das Problem, dass die PC Programmierer das auf die SPS schieben, ich als SPS Programmierer aber weiß, dass es nicht an der SPS liegen kann.

    Meine Frage ist nun, ob es an den Einstellungen am OPC Server liegen kann, dass ein Bit flakert. Ist bei einem von euch schon mal etwas aufgetreten?
    Bei der SPS bin ich mir so sicher weil wir kürzlich erst von SoftSPS auf Hardware SPS umgestellt haben und das Problem dennoch auftritt.

    Ich hoffe mir kann jemand helfen.

    Liebe Grüße
    André
    Zitieren Zitieren Bitflankern über OPC  

  2. #2
    Registriert seit
    23.10.2008
    Ort
    Rhein-Main-Gebiet
    Beiträge
    25
    Danke
    9
    Erhielt 4 Danke für 3 Beiträge

    Standard

    Hallo André,
    setze doch im SPS einen Zähler auf dein Bit und beobachte es. Damit kannst Du ein Flakern bestätigen oder ausschließen.

    Gruß: Geza

  3. #3
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Die Frage wäre eher, was genau diese Bits tun. Werden sie von SPS und PC gleichzeitig angesteuert (gesetzt, rückgesetzt) ? Dann kann es durchaus zu Timingproblemen kommen. Oder flackern da Bits, die ausschließlich von der SPS beschrieben und von der Visu nur angezeigt werden? Das darf eigentlich nicht passieren.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  4. #4
    Heiti ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.09.2010
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hallo,

    danke für das schnelle Melden.
    Die Bits flakern auch bei direkten Zuweisungen zum Beispiel bei der Lampe.
    Ich kann die Lampe flakern sehen, während ich in der Visu den Taster gedrückt habe. Ich kann es also eindeutig bestätigen, dass dort eins ist, ich will aber wissen, ob es an der Visu liegt oder dem OPC.
    Es gibt auch keine Doppelzuweisungen, was ich als erstes Vermutet habe.

  5. #5
    Registriert seit
    01.08.2005
    Beiträge
    149
    Danke
    0
    Erhielt 20 Danke für 19 Beiträge

    Standard

    So wirklich hast du die berechtigte Frage von Ralle aber noch nicht beantwortet: Wird das Bit das du über eure Visu setzt in der SPS nur gelesen oder schreibt die SPS auch auf das gleiche Bit?

    Wie wird das Bit gesetzt? Evlt. schreibt die Visu ja das ganze Byte?

    Bei käuflichen Visus gibt es ja die Möglichkeiten
    - setze Bit beim Drücken =1
    - setze Bit beim Loslassen =0
    - direkt

    Beschreib mal etwas genauer was da passiert!
    Ich denke nicht das es am OPC Server liegt (was denn für einer?) ich denke das Problem ist eure Visu (wenn in der SPS wirklich das Bit nicht manipuliert wird).

  6. #6
    Heiti ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.09.2010
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Das kann ich dir leider nicht beantworten.
    Was ich sagen kann ist, dass die PC Programmierer steif und fest behaupten, dass es laufen müsste. Meines wissens nach schreiben Sie aber ganze Bytes.

    Es ist Simatic Net installiert.

    Ich gehe auch nicht davon aus. Ich werde mal mit den PC Programmierern, sprechen, ob wir nicht ne Möglichkeit haben zwischen OPC und Visu zu kontrollieren was los geschickt wird.

  7. #7
    Registriert seit
    01.08.2005
    Beiträge
    149
    Danke
    0
    Erhielt 20 Danke für 19 Beiträge

    Standard

    Tja - was passiert denn wenn du die Visu "aus" machst? Dann müsste dein Bit ja stabil bleiben.

    Wenn die ein Byte schreiben - dann gibt es natürlich mannigfaltige Möglichkeiten was da falsch laufen kann.

    Ich kann dir den kostenlosen MatrikonOPC Analyzer empfehlen - da siehst du was das PC Programm vom OPC Server liest/schreibt.

    Sind die PC Programmierer deine Kollegen? Wenn ja sollen Sie doch einfach mal loggen was sie zum OPC Server schicken!

  8. #8
    Registriert seit
    27.05.2004
    Ort
    Thüringen/Berlin
    Beiträge
    12.220
    Danke
    533
    Erhielt 2.696 Danke für 1.948 Beiträge

    Standard

    Wenn nur die Visu schreibt, dann würde ich mal den OB1 der SPS leerräumen und nur das eingehende Bit auf einen Zähler legen z.Bsp. Wenn dann die Taste an der Visu betätigt wird, sollte da was hochzählen und zwar um mehr als 1. solange man die Taste hält. Das wär dann sicher ein Beweis, das es eher nicht an der SPS liegt.

    PS: Ich liebe Kollegen, die immer steif und fest behaupten, es liege nicht an ihnen. Die haben einfach zu oft unrecht und sind einfach nur zu faul zum Nachdenken.
    Gruß
    Ralle

    ... there\'re 10 kinds of people ... those who understand binaries and those who don\'t …
    and the third kinds of people … those who love TIA-Portal

  9. #9
    Heiti ist offline Neuer Benutzer
    Themenstarter
    Registriert seit
    16.09.2010
    Beiträge
    21
    Danke
    0
    Erhielt 0 Danke für 0 Beiträge

    Ausrufezeichen

    Soo vielen Dank an alle.

    Fehler war Visu hat über OPC das Merkerwort 0 überschrieben und dass führte (erst lesen, dann verarbeiten, dann zurückschreiben in der VISU) dazu, dass der Takt nicht sauber wieder gegeben wurde.
    Da in der SPS Programmierung der Takt öfter genutzt wurde flakerten einige Bits sehr unregelmäßig.

  10. #10
    Registriert seit
    01.08.2005
    Beiträge
    149
    Danke
    0
    Erhielt 20 Danke für 19 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Tja mit solchen Problemen hatte ich auch schon zu kämpfen. Ein ganzes Wort schreiben wenn man nur ein Bit ändern will ist immer blöd. Man sollte dann auch wirklich nur das entsprechende Bit schreiben.

    Vor Jahren haben wir das bei einer "Spar-Visu" so gelöst das ein DB nur gelesen wurde und einer nur geschrieben wurde.
    Das geht solange gut, wie es nur eine Visu gibt.

    Interessant dabei fand ich den Lernfaktor. Da sieht man erst mal mit welchen Problemen sich WinCC, InTouch, RSView,.... auseinander setzen müssen.

    Ich hatte aktuell ein sehr ähnliches Problem: Visu setzt Bit auf 1 (und zeigt den Wert an) - SPS setzt kurz danach das Bit auf 0 -> Ergebnis Visu bleibt auf 1. Der DDE Server "dachte" ich habe es auf 1 gesetzt also ist es 1.

    Schön wenn der Fehler beim Anderen liegt!

Ähnliche Themen

  1. Steuerung über LAN, Internet über WLAN?
    Von Pittie im Forum Simatic
    Antworten: 7
    Letzter Beitrag: 27.10.2011, 18:37
  2. Antworten: 0
    Letzter Beitrag: 08.01.2010, 16:34
  3. Antworten: 3
    Letzter Beitrag: 17.08.2009, 20:22
  4. Antworten: 33
    Letzter Beitrag: 10.02.2009, 21:14
  5. Antworten: 2
    Letzter Beitrag: 25.09.2008, 10:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •