Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 4 ErsteErste 1234 LetzteLetzte
Ergebnis 11 bis 20 von 39

Thema: Sfc 14

  1. #11
    Registriert seit
    20.08.2007
    Beiträge
    40
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von JesperMP Beitrag anzeigen
    Und, was meldet RETVAL dann ?

    8090. Wie vorher auch.

    Gruß

  2. #12
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    wenn das einfache lesen alá jesper auch nicht funktioniert ist es ein grundsätzliches problem!
    die HW-konfig ist im letzten stand übertragen?

    was hast du eigetnlich für ne CPU?
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  3. #13
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.631
    Danke
    377
    Erhielt 802 Danke für 643 Beiträge

    Standard

    Zitat Zitat von vierlagig Beitrag anzeigen
    die HW-konfig ist im letzten stand übertragen?
    Da liegt es glaube ich.

    8090:
    • You have not configured a module for the specified logical base address or
    • you have ignored the restriction concerning the length of consistent data or
    • you have not entered the start address in the LADDR parameter in hexadecimal format.
    Jesper M. Pedersen

  4. #14
    Registriert seit
    20.08.2007
    Beiträge
    40
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von vierlagig Beitrag anzeigen
    wenn das einfache lesen alá jesper auch nicht funktioniert ist es ein grundsätzliches problem!
    die HW-konfig ist im letzten stand übertragen?

    was hast du eigetnlich für ne CPU?

    Siemens CPU 414-3 PN/DP

    Hardware ist ok. GErade eben nochmal übertragen.

  5. #15
    Registriert seit
    20.08.2007
    Beiträge
    40
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    Da liegt es glaube ich.


    8090:
    • You have not configured a module for the specified logical base address or
    • you have ignored the restriction concerning the length of consistent data or
    • you have not entered the start address in the LADDR parameter in hexadecimal format.

    Habe die Hilfe zu SFC14 auch schon gelesen. Ich kann den PST aber komplett über E/A ansprechen. Die Hardware sollte somit in Ordnung sein.

    Gruß

  6. #16
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.631
    Danke
    377
    Erhielt 802 Danke für 643 Beiträge

    Standard

    Zitat Zitat von trinkiwinki Beitrag anzeigen
    Habe die Hilfe zu SFC14 auch schon gelesen. Ich kann den PST aber komplett über E/A ansprechen.
    Wenn die E/A innerhalb von Prozesabbild sind, dann sind SFC14/SFC15 überflüssig. Ob SFC14/SFC15 damit ein Problem hat weiss ich nicht.
    Warum hast du die DP Slaves innerhalb von Prozesabbild plaziert ?
    Jesper M. Pedersen

  7. #17
    Registriert seit
    20.08.2007
    Beiträge
    40
    Danke
    11
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    Wenn die E/A innerhalb von Prozesabbild sind, dann sind SFC14/SFC15 überflüssig. Ob SFC14/SFC15 damit ein Problem hat weiss ich nicht.
    Warum hast du die DP Slaves innerhalb von Prozesabbild plaziert ?
    Gute Frage. Wenn ich sie aber außerhalb mache, dann geht es auch nicht......

  8. #18
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von JesperMP Beitrag anzeigen
    Ob SFC14/SFC15 damit ein Problem hat weiss ich nicht.
    das tät ich auch gern wissen, kann es mir auch irgendwie bildhaft vorstellen
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  9. #19
    Registriert seit
    06.10.2004
    Ort
    Kopenhagen.
    Beiträge
    4.631
    Danke
    377
    Erhielt 802 Danke für 643 Beiträge

    Standard

    Zitat Zitat von trinkiwinki Beitrag anzeigen
    Gute Frage. Wenn ich sie aber außerhalb mache, dann geht es auch nicht......
    Keine Lösung zu das Problem mit SFC14/SFC15.
    Aber wenn die Daten schon in Prozesabbild sind, kannst du anstatt SFC14/SFC15 eine einfache SFC20 BLKMOV in deiner FB verwenden.
    Jesper M. Pedersen

  10. #20
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von JesperMP Beitrag anzeigen
    Keine Lösung zu das Problem mit SFC14/SFC15.
    Aber wenn die Daten schon in Prozesabbild sind, kannst du anstatt SFC14/SFC15 eine einfache SFC20 BLKMOV in deiner FB verwenden.
    richtig, aber der zugriff mit sfc14 muß doch aber eigentlich trotzdem funktionieren... das scheint alles noch ein wenig spanisch...

    auf was steht denn in der Maske Eigenschaften-DP SlaveAdresse/Kennung der Parameter ”Konsistent über :” ???
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

Stichworte

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •