Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: S5 eprom

  1. #1
    Registriert seit
    21.07.2005
    Beiträge
    222
    Danke
    54
    Erhielt 2 Danke für 2 Beiträge

    Frage


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo!
    Habe eine CPU 115U 943B! Es wurde ein neuer EPROM (Typ: 6ES5 375-1LA41) gesteckt. Habe nun das Problem das nach jedem Spannungsausfall die CPU mit dem EPROM Programm geladen wird. CPU Batterie ist i.O. Kann man das irgendwo einstellen oder entsprechend programmieren. Beim EPROM der vorher verwendet wurde war das nicht der Fall.
    Danke
    Alles wird Gut!
    Zitieren Zitieren S5 eprom  

  2. #2
    Registriert seit
    02.10.2010
    Beiträge
    453
    Danke
    62
    Erhielt 87 Danke für 69 Beiträge

    Standard

    Hallo Klauserl,

    laut Handbuch liest das Betriebssystem nach Netzwiederkehr immer das EPROM-Modul aus.
    Wenn ich mich recht erinnere, passiert das nicht bei RAM-Speichermodulen. Bist Du Dir sicher, das vorher kein RAM im Einsatz war? RAM-Module haben die Bezeichnung 6ES5 375-0LDXX.
    Welche Bezeichnung hatte das alte Modul?

    Gruß
    Corosop15

  3. #3
    Avatar von klauserl
    klauserl ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.07.2005
    Beiträge
    222
    Danke
    54
    Erhielt 2 Danke für 2 Beiträge

    Standard

    laut Handbuch liest das Betriebssystem nach Netzwiederkehr immer das EPROM-Modul aus.
    Wenn ich mich recht erinnere, passiert das nicht bei RAM-Speichermodulen. Bist Du Dir sicher, das vorher kein RAM im Einsatz war? RAM-Module haben die Bezeichnung 6ES5 375-0LDXX.
    Welche Bezeichnung hatte das alte Modul?
    Das alte Modul hat die Bezeichnung 6ES5-375-0LA61! Ist aber laut Aufdruck auch ein EPROM. Bei diesem Modul hab ich aber dieses Prolbem nicht.
    Alles wird Gut!
    Zitieren Zitieren S5 eprom  

  4. #4
    Registriert seit
    21.07.2003
    Ort
    Bangkok / Thailand
    Beiträge
    98
    Danke
    24
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Hallo Klauserl,

    Wie hast du denn gemerkt dass jetzt immer das Programm vom EPROM geladen wird?

    Gehe ich richtig in der Annahme dass es durch Werte aus einem DB aufgefallen ist?
    Ich vermute dass während des Betriebs der Anlage, einige Werte per
    VISU eingestellt werden und dann nach Spannungsausfall immer wieder
    auf die falschen/alten Werte zurück springen.....

    Wenn dem so ist, hast du ein(ige) DB('s) zuviel auf dem EPROM.
    Und wenn das alte EPROM noch lesbar ist, must du mal nachschauen
    welche Bausteine ursprünglich gebrannt waren...
    Es kann gut sein dass nicht alle Bausteine (DB's) des Projekts auf dem EPROM sein dürfen.

    Gruß
    Guido

  5. #5
    Avatar von klauserl
    klauserl ist offline Erfahrener Benutzer
    Themenstarter
    Registriert seit
    21.07.2005
    Beiträge
    222
    Danke
    54
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo Guido
    Mit den falschen DB Werten hast du schon recht.
    Aber wie meinst du das nicht alle DB`s auf dem EPROM sein dürfen?
    Sollten DB`s zur Laufzeit erzeugt werden, hätte ich ja früher auch schon das Problem mit den falschen Werten nach Spannungsausfall gehabt.
    Oder sehe ich da das ganze falsch?
    S5 ist doch nicht mehr so alltäglich für mich.
    Gruß
    Klauserl
    Alles wird Gut!

  6. #6
    Registriert seit
    21.07.2003
    Ort
    Bangkok / Thailand
    Beiträge
    98
    Danke
    24
    Erhielt 7 Danke für 7 Beiträge

    Standard

    Hallo Klauserl,

    wenn sich die Werte nach Spannungsausfall ändern, sind wir dem Problem dicht auf den Fersen.

    Bei der S5 kann man DB's zur Laufzeit erzeugen, falls diese noch nicht im RAM Speicher vorhanden sind.
    Sind die DB's bereits vorhanden wird nicht geändert und auch keine Werte überschrieben. Das ist sehr wahrscheinlich der Grund warum das vorher richtig funktioniert hat.

    Prüf mal in den Bausteinen OB21/OB22 ob du dort Anweisungen findest wie :
    Code:
    LKF +200
    E DB xyz
    Diese Anweisung Lädt eine Konstante von Wert=+200 und
    "E"rzeugt einen DB xyz mit einer Länge von 200 Worten.

    Wenn du die obengenannten Anweisungen findest, würde ich mal
    das EPROM neu brennen und die DB's, die bei CPU-Anlauf erzeugt werden, weglassen.

    Gruss
    Guido

  7. Folgender Benutzer sagt Danke zu Guido für den nützlichen Beitrag:

    klauserl (18.10.2010)

  8. #7
    Registriert seit
    02.10.2010
    Beiträge
    453
    Danke
    62
    Erhielt 87 Danke für 69 Beiträge

    Standard

    Hallo Klauserl,

    Du hast geschrieben, daß auch eine Pufferbatterie im Einsatz ist, welche i.O. ist. Der Einsatz einer Pufferbatterie bei EPROM's ergibt nur einen Sinn,
    wenn im RAM der CPU Datenbausteine stehen, bei denen Werte während der zyklischen Bearbeitung neu geschrieben werden.
    Diese DB's dürfen nicht auf dem EPROM sein. Im Hochlauf werden die Datenbausteine mit dem Befehl "E DBX" erzeugt (wenn nicht vorhanden), die Länge des DB's wird vorher in den Akku geladen.

    Beispiel:
    L KF +255
    E DB100

    So wird ein DB100 mit der Länge von 255 Datenworten erzeugt.

    Gruß
    Corosop15

  9. Folgender Benutzer sagt Danke zu Corosop15 für den nützlichen Beitrag:

    klauserl (18.10.2010)

  10. #8
    Registriert seit
    17.03.2008
    Beiträge
    103
    Danke
    4
    Erhielt 24 Danke für 23 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Es gibt noch eine Erklärung für dieses Verhalten:
    Wenn die CPU die Bausteine einmal vom EPROM geladen hat (z.B. nach Urlöschen), dann wird nach jedem Netz aus-ein wieder vom EPROM gelesen. Wenn aber die Bausteine mittels PG ins RAM der CPU übertragen wurden und das EPROM nachträglich quasi als Datensicherung gesteckt wurde ohne nochmals ein Urlöschen durchzuführen, dann werden auch keine Bausteine aus dem EPROM gelesen.

Ähnliche Themen

  1. Eprom/cp524
    Von Elmi im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 31.10.2010, 12:16
  2. S5 eprom
    Von William700 im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 11.08.2009, 19:51
  3. Eprom s5
    Von Tom08 im Forum Simatic
    Antworten: 20
    Letzter Beitrag: 23.07.2009, 19:13
  4. EPROM für S5 CPU 103
    Von Rudi im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 28.08.2007, 19:41
  5. S5 & Eprom
    Von Anonymous im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 21.01.2005, 16:54

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •