Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 2 ErsteErste 12
Ergebnis 11 bis 19 von 19

Thema: Kommunikation ET200S und SENTRON PAC3200 über PN?

  1. #11
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Ach und welchen Firmwarestand hat die IM ?!? Die Ersten Dinger konnten keinen Port 502...
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

  2. #12
    Registriert seit
    21.10.2010
    Beiträge
    40
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Hab ich gecheckt...
    Die ID die ich zuvor auf 1 gesetzt habe is Online auf 0 sonst alle wie Offline.
    Ist es auch richtig dass ich die IP bei rem_staddr reingeschrieben habe denn der letzte Wert meine IP, in meinem fall 236 also EC ändert sich Online ständig von EC EB EC EB....
    Und was is rem_tsap_id?

    Danke für deine Hilfe

  3. #13
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard

    IP Adresse steht in "TCP_IP.rem_staddr", richtig - aber ändern darf sich da nix !
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

  4. #14
    Registriert seit
    21.10.2010
    Beiträge
    40
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    2.7.
    Ok... das heißt also die remote Port no 502 muss ich auch noch versehen... und bestimmt auch die local port no 2000

  5. #15
    Registriert seit
    22.05.2005
    Ort
    sonniges Maifeld
    Beiträge
    1.067
    Danke
    77
    Erhielt 205 Danke für 159 Beiträge

    Standard

    Yep...2.7 ist gut
    "Man kann auf seinem Standpunkt stehen, aber man sollte nicht darauf sitzen" - Erich Kästner

  6. #16
    Registriert seit
    21.10.2010
    Beiträge
    40
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Leider hab ich es immernoch nich hinbekommen
    Mein UDT65 hat jetz folgenden Werte:

    block_length W#16#40
    id W#16#1
    connection_type B#16#1
    active_est FALSE
    local_device_id B#16#1
    local_tsap_id_len B#16#0
    rem_subnet_id_len B#16#0
    rem_staddr_len B#16#0
    rem_tsap_id_len B#16#2
    next_staddr_len B#16#0
    local_tsap_id B#16#2, B#16#0, B#16#0, B#16#0, B#16#0, usw.
    rem_subnet_id B#16#0, B#16#0, B#16#0, B#16#0, B#16#0, B#16#0
    rem_staddr B#16#C0, B#16#A8, B#16#0, B#16#EC, B#16#0, B#16#0
    rem_tsap_id B#16#5, B#16#0, B#16#2, B#16#0, B#16#0, B#16#0, usw.
    next_staddr B#16#0, B#16#0, B#16#0, B#16#0, B#16#0, B#16#0
    spare W#16#0


    Hab ich irgenwas verkehrt gemacht?
    Und brauch ich nichts im PARA_DB ändern?

  7. #17
    Registriert seit
    05.12.2008
    Beiträge
    13
    Danke
    2
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Hallo,

    leider bekomme ich keine Daten vom PAC3200 übertragen. Zu Grunde liegen die Bausteine von oben.

    Mein PAC3200 (V2.1) habe ich an einer IM151-8 (V3.2.1).

    Einen Connect über TCON mit den Einstellung (IP, Port, ...) funktioniert.

    Auch der Modbus Request per Send bringt Done.
    Nur der RECV bringt ständig nur BUSY (Status #7002) und bringt keine Daten (Response).

    Ich weiss nur nicht ob der Request gültig beim PAC ankommt.

    Hat jemand einen Vorschlag wie ich den Fehler diagnostizieren kann ????

    Danke.

    @Vassily
    Ich denke bei Dir sind die Ports falsch angegben in den TSAP.
    local_tsap_id B#16#7, B#16#D0 = Port 2000
    rem_tsap_id B#16#1, B#16#F6 = Port 502
    Geändert von JaZs (08.06.2011 um 15:53 Uhr)
    Zitieren Zitieren connect ok, TRCV bleibt Busy  

  8. #18
    Registriert seit
    21.10.2010
    Beiträge
    40
    Danke
    4
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Vorschlag wie den Fehler diagnostizieren kannst hab ich nich... ist auch schon ne weile her als ich damit zu tun hatte.

    Du musst dich lediglich an die pdf halten und die IP und TCP_IP.local_device_id in der Quelle ändern... mehr war das glaub ich garnicht

    70131.pdf

  9. #19
    Registriert seit
    05.12.2008
    Beiträge
    13
    Danke
    2
    Erhielt 5 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Danke.

    Die IP und die Local_Device_ID hab ich ja geändert, das stimmt auch. Der Connect funktioniert ja, bloss beim Send/Recv hat er Probleme.

    Zur Info: Ich hab es auch mit einer 315 2DP/PN versucht, mit dem gleichen Ergebnis (Local_Device_ID hab ich natürlich vorher geändert).

    Das PAC3200 ist übrigens ein 7KM2111-1BA00-3AA0 (V2.1.0).

Ähnliche Themen

  1. Modbus TCP Kommunikation von SENTRON PAC3200
    Von Vassily im Forum Simatic
    Antworten: 47
    Letzter Beitrag: 11.03.2016, 21:08
  2. TCP Kommunikation PAC3200 mit S7 315-2PN
    Von Guschdl im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 09.05.2014, 12:36
  3. Sentron PAC3200 Firmwareupdate
    Von thomass5 im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 20.06.2011, 09:00
  4. Profinet-Kommunikation mit einer ET200S
    Von rkoe1 im Forum Simatic
    Antworten: 0
    Letzter Beitrag: 06.03.2008, 12:55
  5. Kommunikation S7 - ET200M - ET200S
    Von Anonymous im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 05.08.2003, 16:24

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •