Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 7 von 7

Thema: CP340 - keine Kommunikation

  1. #1
    Registriert seit
    20.02.2010
    Beiträge
    83
    Danke
    18
    Erhielt 5 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Hallo liebe Forumsgemeinde,

    habe hier eine CPU315-2DP mit einer CP340. Ich möchte über einen RFID-Baustein den Code eines Transponders auslesen und über die RS232-Schnittstelle an meine SPS übergeben. Die Kommunikation des Bausteins mit meinem PC funktioniert einwandfrei. Doch die Kommunikation mit der CP340 funktioniert nicht. An der CP leuchtet dann die SF-Diode sowie die RXD-Diode auf. Laut Handbuch bedeutet dies eine Unterbrechung der Leitung. Doch wie gesagt funktioniert das Kabel ja, da mit PC und Hyperterminal getestet. Habe auch die gleichen Verbindungseinstellungen. Weiß jemand woran dies noch liegen könnte?

    bin dankbar für jeden hinweis
    Zitieren Zitieren CP340 - keine Kommunikation  

  2. #2
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.203
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Hast Du mal die Pinbelegung der CP340-Schnittstelle mit einer PC-COMx-Schnittstelle verglichen?
    Hast Du mal den RS232-Pegel des RFID-Bausteins gemessen?
    PC-Schnittstellen funktionieren meist schon mit +/-3V, die CP340 hält sich ganz penibel an die Mindestpegel der RS232-Norm.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  3. #3
    lubof ist offline Benutzer
    Themenstarter
    Registriert seit
    20.02.2010
    Beiträge
    83
    Danke
    18
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Zitat Zitat von PN/DP Beitrag anzeigen
    Hast Du mal die Pinbelegung der CP340-Schnittstelle mit einer PC-COMx-Schnittstelle verglichen?
    ja, habe ich. die sind gleich.

    Zitat Zitat von PN/DP Beitrag anzeigen
    Hast Du mal den RS232-Pegel des RFID-Bausteins gemessen?
    PC-Schnittstellen funktionieren meist schon mit +/-3V, die CP340 hält sich ganz penibel an die Mindestpegel der RS232-Norm.
    ja, die pegel sind auch in ordnung.

    kann es sein, dass die CP keine gekreuzte leitung benötigt? sprich dass ich ein 1:1-Kabel verwenden muss und kein nullmodem-kabel?

  4. #4
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.203
    Danke
    926
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Wie lang ist das RS232-Kabel vom RFID-Baustein? Länger als 15m?

    Zitat Zitat von lubof Beitrag anzeigen
    Zitat Zitat von PN/DP Beitrag anzeigen
    Hast Du mal die Pinbelegung der CP340-Schnittstelle mit einer PC-COMx-Schnittstelle verglichen?
    ja, habe ich. die sind gleich.
    Stimmt, ich habe es gerade nochmal im Handbuch nachgesehen.

    Zitat Zitat von lubof Beitrag anzeigen
    kann es sein, dass die CP keine gekreuzte leitung benötigt? sprich dass ich ein 1:1-Kabel verwenden muss und kein nullmodem-kabel?
    Wenn das Kabel vom RFID-Baustein an einem PC funktioniert, dann darf es zum CP340 nicht zusätzlich gekreuzt
    werden, da die RS232-Schnittstellen PC und CP340 ja gleich sind.
    Es könnte aber sein, daß Dein RFID-Baustein nicht alle Handshake-Signale liefert (RTS -> CTS, DTR -> DSR).
    Die fehlenden Signale müssten am CP340 mit Pin 4 (DTR) verbunden werden.
    (Ich habe es jetzt nicht im Kopf, ob beim CP340 das Hardware-Handshake abgeschaltet werden kann.)

    Wie heißt Dein RFID-Baustein genau?
    Hast Du einen Link zum Handbuch?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  5. #5
    lubof ist offline Benutzer
    Themenstarter
    Registriert seit
    20.02.2010
    Beiträge
    83
    Danke
    18
    Erhielt 5 Danke für 4 Beiträge

    Standard

    ist ein bausatz von pollin.

    http://www.pollin.de/shop/dt/MDQ5OTg...mpfaenger.html

    laut dem schaltplan kann er die handshake signale gar nicht können, da auf der rs232 schnittstelle nur RXD, TXD und GND belegt sind....

  6. #6
    Registriert seit
    04.02.2007
    Beiträge
    2.544
    Danke
    167
    Erhielt 731 Danke für 528 Beiträge

    Standard

    Wenn du die Parametierung des CP's nicht gleich dem PC machst geht es nicht.

    Wenn du nur die drei adern verwendest, darf an der CP kein Hardwarehandshake aktiviert werde.

    Nur mal so da es sehr oft als Fehler gemacht wird.
    Hast du in der Hardwarkonfig den Button Parameter wenn du auf die CP340 klickst, die Voreinstellung ist 3964R und das kan Hypterterminal nicht.
    Der Button erschein erst nach der Installation der CP340 Software.
    Einstellung muß sein ASCII
    „Wenn du ein Problem hast, versuche es zu lösen. Kannst du es nicht lösen, dann mache kein Problem daraus.“
    Siddhartha Gautama

  7. #7
    lubof ist offline Benutzer
    Themenstarter
    Registriert seit
    20.02.2010
    Beiträge
    83
    Danke
    18
    Erhielt 5 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    nein. hab schon das richtige protokoll. ASCII ist eingestellt

Ähnliche Themen

  1. CP340 low level Kommunikation
    Von payne im Forum Simatic
    Antworten: 2
    Letzter Beitrag: 09.07.2010, 10:48
  2. CP340 Kommunikation
    Von Freakadelle im Forum Simatic
    Antworten: 3
    Letzter Beitrag: 23.03.2009, 16:16
  3. CP340 Kommunikation ASCII
    Von Black Scorpion im Forum Simatic
    Antworten: 10
    Letzter Beitrag: 21.03.2009, 18:39
  4. Kommunikation mit CP340
    Von capri-fan im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 30.05.2005, 09:40
  5. Kommunikation über CP340
    Von capri-fan im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 10.03.2005, 11:55

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •