Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 2 von 3 ErsteErste 123 LetzteLetzte
Ergebnis 11 bis 20 von 25

Thema: S7-1200 Analogeingang Stromsensor

  1. #11
    Registriert seit
    15.01.2005
    Ort
    In der Mitte zwischen Bayreuth/Weiden
    Beiträge
    6.732
    Danke
    314
    Erhielt 1.520 Danke für 1.282 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Irgendwie verbaust du mir da zuviel Bauteile.

    Welchen Sinn oder Zweck sollen die Dioden haben?

    Das ganze ist ganz einfach:

    Code:
    I1(x) --- Eingang 0 --- 2M ---- 0V
             |----R470-----------|
    Das ganze für I2(y) exakt genau so, ohne Dioden oder sonstigen Kram der die Messung in irgend einer Form beeinflusst.

    Mfg
    Manuel
    Warum denn einfach, wenn man auch Siemens einsetzen kann!

    Wer die grundlegenden Freiheiten aufgibt, um vorübergehend ein wenig Sicherheit zu bekommen, verdient weder Freiheit noch Sicherheit (B. Franklin).

  2. #12
    Registriert seit
    27.11.2006
    Ort
    Ostschweiz
    Beiträge
    528
    Danke
    43
    Erhielt 86 Danke für 77 Beiträge

    Standard

    wieso führst du x und y des Sensors auf denselben SPS-Analogeingang und nicht auf 2 verschiedene?

    wegen der Unterschiede von x und y: Interressant wären die Werte ohne Shunt und Diodenbeschaltung, ob du da auch schon Unterschiede hast. Müssten ja je 12mA sein

    o.s.t.
    Geändert von o.s.t. (03.11.2010 um 21:54 Uhr)

  3. #13
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.191
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    2M der Analogeingänge muß mit GND der Spannungsversorgung des Sensors AIS
    verbunden werden, am besten ein direkter Draht vom AIS-GND-Anschluß zu 2M.

    Die Dioden sind unnötig und Mist, die verfälschen (je nach Diodentyp) sehr
    wahrscheinlich das Meßergebnis nichtlinear besonders im unteren Strombereich.

    Welche maximale Bürde kann der Sensor?

    Wie heißt Dein "AIS"-Sensor genau?
    Hast Du einen Link auf das Datenblatt?

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  4. #14
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von MSB Beitrag anzeigen
    Irgendwie verbaust du mir da zuviel Bauteile.

    Welchen Sinn oder Zweck sollen die Dioden haben?

    Das ganze ist ganz einfach:

    Code:
    I1(x) --- Eingang 0 --- 2M ---- 0V
             |----R470-----------|
    Das ganze für I2(y) exakt genau so, ohne Dioden oder sonstigen Kram der die Messung in irgend einer Form beeinflusst.

    Mfg
    Manuel
    genau so habe ich es ursprünglich auch gemacht, funktioniert einwandfrei mit einem shunt, sobald ich das zweite sensorsignal dazu gebe mit einem 2ten shunt (auf Eingang 1 das Sensorsignal und parallel wie oben den Widerstand also zw. I2 und Eingang2) dann steigt meine Spannung auf knapp 10V an.
    Mit den Sperrdioden kann ich den hohen anstieg verhindern, aber die Spannungen sind dann verschieden ....

  5. #15
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von o.s.t. Beitrag anzeigen
    wieso führst du x und y des Sensors auf denselben SPS-Analogeingang und nicht auf 2 verschiedene?

    wegen der Unterschiede von x und y: Interressant wären die Werte ohne Shunt und Diodenbeschaltung, ob du da auch schon Unterschiede hast. Müssten ja je 12mA sein

    o.s.t.
    ich gehe ja auf 2 verschiedene Eingänge -> hier die Schaltung

    keine Unterschiede ohne shunts bei den Strompegeln

  6. #16
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von PN/DP Beitrag anzeigen
    2M der Analogeingänge muß mit GND der Spannungsversorgung des Sensors AIS
    verbunden werden, am besten ein direkter Draht vom AIS-GND-Anschluß zu 2M.
    wenn ich das mache steigt wieder die Spannung an den Shunts -> ohne die Masse zu verbinden habe ich zumindest ein Signal mit dem ich etwas anfangen kann (sonst knapp 10V!)

    Zitat Zitat von PN/DP Beitrag anzeigen
    Die Dioden sind unnötig und Mist, die verfälschen (je nach Diodentyp) sehr
    wahrscheinlich das Meßergebnis nichtlinear besonders im unteren Strombereich.
    Mit Dioden bekomme ich ein halbwegs vernünftiges Sensorsignal (ca. 7V und 7,6V -> ohne den Dioden bin ich knapp auf 10V!)

    Meine Überlegung bei den Dioden war die, dass bei steigendem Sensorstrom (je nachdem ob Sensor1 od. Sensor2 bzw. x-y Wert) den Parallelwiderstand "überlagert"und über diesen zurück in den Senor wandert ....

    Zitat Zitat von PN/DP Beitrag anzeigen
    Welche maximale Bürde kann der Sensor?

    Wie heißt Dein "AIS"-Sensor genau?
    Hast Du einen Link auf das Datenblatt?
    AIS_59S5_englisch.pdf
    k.A. der über die Bürde ...

    danke und lg!!!

  7. #17
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.191
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Das Datenblatt des AIS 59S5 ist ja sehr dürftig ...

    Hast Du mal den Sensor ganz alleine getestet (ohne Anschluß an SPS)?
    Also nur 24VDC an Supply+ und Supply- und je 1 Widerstand von X nach Supply- und von Y nach Supply-?
    Wie sind dann die Spannungen über den Widerständen von X nach Supply- und Y nach Supply-?
    Wird es besser, wenn Du statt 470 Ohm nur 50 oder 100 Ohm verwendest?

    Wenn dabei schon die Spannung hoch geht, dann ist mit dem Sensor was nicht in Ordnung.
    Dann wende Dich an den Distributor http://www.ais-sensors.de / Tel 0841-9938757-0
    Die AIS GmbH bietet Ihren Kunden den kompletten Service zur Instandhaltung und Reparatur von AIS Beschleunigungssensoren.
    Gerne reparieren wir auch die Sensoren unserer Mitbewerber.
    Wenn es alleine OK ist, dann zusätzlich zu den Widerständen noch 3 Leitungen anschließen:
    AIS:X zu SPS:0
    AIS:Y zu SPS:1
    AIS:Supply- zu SPS:2M

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  8. #18
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    @harald: klingt interessant!

    alles ohne SPS:

    beide Signale einzeln:
    green = X/Signal+ mit 470R auf Masse, U über R = 5,37V
    white = Y/Signal+ mit 470R auf Masse, U über R = 5,53V

    (hier liegt green schon mal außerhalb des Toleranzbereiches laut Datenblatt -> versorge die Sensoren aber auch höher als "recommended" nämlich mit 26,2V)

    jetzt beide parallel wie von Dir beschrieben (d.h. parallel auf Masse):
    green = X/Signal+ mit 470R auf Masse, U über R = 6,53V
    white = Y/Signal+ mit 470R auf Masse, U über R = 7,3V

    d.h. der Sensor hat was?

    wenn ich mit beiden Signalen parallel auf meinen analogen Spannungseingang gehe, steigen die Spannungen noch höher an -> mit Sperrdiode reduziere ich das ein wenig ...)

    könnte das Ganze jetzt noch mit den Dioden zusammen testen, allmählich vergeht mir aber die Lust an der Sache ...

    danke und lg!
    Geändert von christophersn (04.11.2010 um 20:24 Uhr)

  9. #19
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.191
    Danke
    923
    Erhielt 3.292 Danke für 2.661 Beiträge

    Standard

    Zitat Zitat von christophersn Beitrag anzeigen
    d.h. der Sensor hat was?
    Zusammenfassung:
    Du hast am Sensor nur die Betriebsspannung und rein ohmsche Lasten angeschlossen.
    Die Ausgangströme X/Y beeinflussen sich gegenseitig, auch schon ohne angeschlossene
    SPS-Analogeingänge.

    So wie der Sensor in dem knappen Datenblatt beschrieben ist, soll er an X und Y
    2 unabhängige Normsignale 4-20mA (12+/-8mA) liefern. Das tut der Sensor aber nicht.

    Die 4-20mA-Ausgänge müssten laut Datenblatt von 7V bis 24V Betriebsspannung
    unabhängig von der Last (0 Ohm bis maximale Bürde) ca. 12mA Ruhestrom liefern.
    (Das wird normalerweise mit gesteuerten Konstantstromquellen realisiert.)

    Aus der minimalen Betriebsspannung 7V spekuliere ich nun mal eine maximale Bürde
    von ca. 300 Ohm. Es könnte sein, daß die maximale Bürde betriebsspannungsabhängig
    ist und bei 24V auch größer als 300 Ohm sein kann. Davon steht aber nichts im
    Datenblatt.

    Sehr merkwürdig ist, daß die Ausgangsströme X/Y bei steigender Gesamtbelastung
    ansteigen! Das sieht mir stark nach Defekt aus.

    Du solltest noch einen letzten Versuch mit kleineren Widerständen (50 bis 200 Ohm)
    machen. Wenn das Verhalten so bleibt, dann rufe wegen Deinem Problem bei AIS an.
    Von den 26V solltest Du da besser nichts erwähnen, die sind nicht nur außerhalb
    des recommended Bereich sondern auch größer als die maximal zulässigen 24V.

    Übrigens:
    In diesem Datenblatt steht, daß es den Sensor optional mit voltage output gibt.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  10. #20
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    @harald: was meinst Du mit "Minimaler Betriebsspannung 7V" -> die Spannung die sich ergibt, wenn ich die beiden Sensorsignale parallel belaste?

    Werde das noch mit den kleineren Widerständen versuchen ...

    Ich weiß darüber Bescheid, dass es eine "Spannungsversion" des Sensors gibt, leider habe ich dafür zu lange Leitungen ...

    Danke und lg!

Ähnliche Themen

  1. Datenaustausch zwischen S7-1200 und S7-1200
    Von baschan im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 09.12.2011, 00:27
  2. S5 Analogeingang
    Von mariob im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 26.04.2011, 21:16
  3. Analogeingang bei S5-95U
    Von bayersepper im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 01.11.2010, 11:29
  4. Analogeingang S7 314-IFM
    Von der-rasende-dee im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 22.01.2009, 17:54
  5. Stromsensor
    Von demmy86 im Forum Elektronik
    Antworten: 6
    Letzter Beitrag: 13.06.2008, 17:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •