Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 3 von 3 ErsteErste 123
Ergebnis 21 bis 25 von 25

Thema: S7-1200 Analogeingang Stromsensor

  1. #21
    Registriert seit
    22.06.2009
    Ort
    Sassnitz
    Beiträge
    11.163
    Danke
    921
    Erhielt 3.286 Danke für 2.655 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von christophersn Beitrag anzeigen
    @harald: was meinst Du mit "Minimaler Betriebsspannung 7V"
    Im Datenblatt ist die zulässige Betriebsspannung des Sensors als 7 - 24 VDC angegeben.
    Damit der Sensor bei 7V Betriebsspannung über den Bürdenwiderstand 20mA treiben kann,
    darf dieser Widerstand höchstens ca. 300 Ohm groß sein.

    Über einem Bürdenwiderstand von 500 Ohm würden bei 20mA 10V abfallen, was bei 7V
    Betriebsspannung nicht möglich ist.

    Harald
    Es ist immer wieder überraschend, wie etwas plötzlich funktioniert, sobald man alles richtig macht.

    FAQ: Linkliste SIMATIC-Kommunikation über Ethernet

  2. #22
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    ok soweit, nur wenn ich gut 24V Betriebsspannung habe, sollten die 500 Ohm auch kein Problem darstellen, oder verstehe ich etwas falsch?

  3. #23
    Registriert seit
    23.10.2010
    Beiträge
    13
    Danke
    1
    Erhielt 2 Danke für 2 Beiträge

    Standard

    Hallo Christopherson,

    ich denke da gibt es ein Verständnisproblem.
    Du must dir das als Spannungsteiler vorstellen.

    Die 500Ohm Widerstände musst du paralell
    zu den Spannungseingängen der SPS (AI) schalten,
    AI0 gegen GND und AI1 gegen GND

    wenn dann zb. 20mA in deiner Schleife fliessen
    fallen am Eingang über den 500Ohm Widerstand (20mAx500Ohm) 10V ab, der Rest an deinem Geber.
    Der Innenwiderstand der Karte ist dabei unerheblich


    Anschluss:
    (Geber (X oder Y) und Widerstand auf AI0+)
    (Geber - und Widerstand auf AI0 GND)


    Gruß
    Zitieren Zitieren Stromeingang  

  4. #24
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von Joseppe Beitrag anzeigen
    Hallo Christopherson,

    ich denke da gibt es ein Verständnisproblem.
    Du must dir das als Spannungsteiler vorstellen.

    Die 500Ohm Widerstände musst du paralell
    zu den Spannungseingängen der SPS (AI) schalten,
    AI0 gegen GND und AI1 gegen GND

    wenn dann zb. 20mA in deiner Schleife fliessen
    fallen am Eingang über den 500Ohm Widerstand (20mAx500Ohm) 10V ab, der Rest an deinem Geber.
    Der Innenwiderstand der Karte ist dabei unerheblich


    Anschluss:
    (Geber (X oder Y) und Widerstand auf AI0+)
    (Geber - und Widerstand auf AI0 GND)


    Gruß
    wenn´s nur ein Verständisproblem wäre ...

    scheinbar stimmt was mit dem Sensor nicht! so wie Du beschrieben habe ich natürlich den Sensor angeschlossen. Wenn Du die letzten Beiträge von harald und mir gelesen hast, dann stimmen die Werte des Sensors auch ohne SPS nicht bei 2 Parallelwiderständen -> je ein Parallelwiderstand ist ok, aber beide gleichzeitig bringen den Sensor durcheinander ...

    lg

  5. #25
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Zitat Zitat von PN/DP Beitrag anzeigen
    Du solltest noch einen letzten Versuch mit kleineren Widerständen (50 bis 200 Ohm)
    machen. Wenn das Verhalten so bleibt, dann rufe wegen Deinem Problem bei AIS an.
    Von den 26V solltest Du da besser nichts erwähnen, die sind nicht nur außerhalb
    des recommended Bereich sondern auch größer als die maximal zulässigen 24V.
    Harald
    Ich habe jetzt die Eine Sensorkennlinie mit 50R, 100R, 150R und 220R aufgenommen.
    Die Spannungen lag bei 24V (U+ und U- sind +-5%).
    Ux und Uy sind Spannungen an je einem Widerstand ohne Parallelschaltung.
    Uxg und Uyg sind die Spannungen an den Widerständen bei Parallelschaltung.
    Sensorkennlinie.gif
    lg

Ähnliche Themen

  1. Datenaustausch zwischen S7-1200 und S7-1200
    Von baschan im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 09.12.2011, 00:27
  2. S5 Analogeingang
    Von mariob im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 26.04.2011, 21:16
  3. Analogeingang bei S5-95U
    Von bayersepper im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 01.11.2010, 11:29
  4. Analogeingang S7 314-IFM
    Von der-rasende-dee im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 22.01.2009, 17:54
  5. Stromsensor
    Von demmy86 im Forum Elektronik
    Antworten: 6
    Letzter Beitrag: 13.06.2008, 17:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •