Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Seite 1 von 3 123 LetzteLetzte
Ergebnis 1 bis 10 von 25

Thema: S7-1200 Analogeingang Stromsensor

  1. #1
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    leider hat auf meinen anderen Beitrag noch niemand geantwortet, daher vesuche ich es mit einem neuen ....

    Ich möchte über 2 Analoge Spannungseingänge auf meiner S7-1200 1211CC (hat leider nur A-Spannungseingänge on board) 2 analoge Stromsensoren mit 4-20 mA Auswerten.
    Mit einem Shunt Parallelwiderstand von 470 Ohm (hab leider keinen 500 Ohm bekommen) funktioniert das mit einem Sensor auch ganz gut, wenn ich jetzt einen 2ten Sensor auch mit einem Shunt hinzufügen möchte, beeinflussen sich klarerweise die beiden Widerstände (Parallelschaltung, ...) -> ich habe dann je eine Diode in Sperrichtung in Serie zu den Shunt Widerständen geschaltet und plötzlich ist die Spannung unterschiedlich hoch an den beiden Eingängen (1x 7V, 1x 7,8V).
    Bei den Sensoren handelt es sich um Beschleunigungssensoren der Fa. AIS mit einem 0-Punkt Signal von 12mA -> d.h. 12mA * 470 Ohm + 0,7V (Diode) sollten eigentlich im Bereich um 6,34 liegen - mit Toleranzen ev. mehr, jedoch so viel mehr und noch dazu unterschiedlich verstehe ich nicht.

    Hat jemand eine Idee, Erfahrung wie ich das anders lösen könnte -> meine Idee wäre als erstes einen kleineren Widerstand zu nehmen um mit der Spannung herunter zu kommen...

    Danke!
    Zitieren Zitieren S7-1200 Analogeingang Stromsensor  

  2. #2
    Registriert seit
    27.11.2006
    Ort
    Ostschweiz
    Beiträge
    528
    Danke
    43
    Erhielt 86 Danke für 77 Beiträge

    Standard

    irgendwie versteh ich deine Schaltung nicht. Du hast 2 Sensoren und 2 Eingänge. Jeder Sensor hat seinen eigenen Shunt und seine eigenen Eingang, also vollständig voneinander isoliert (Abgesehen von 0V/GND) Dann brauchst du auch keine Diode. Schnalls jetzt nicht, warum und wie du die beiden Shunts und/oder Sensoren miteinander parallelschaltest.

    Sind das 2- , 3- oder 4-Draht Sensoren? Woher bekommen die Sensoren die Speisung?

    gruss, o.s.t.
    Geändert von o.s.t. (03.11.2010 um 17:45 Uhr) Grund: Schreibfehler....

  3. #3
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Messumformer:
    4-20mA auf 0-10V

  4. #4
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    das ist ein vibrationssenor mit 4 draht -> 1x U+, 1x GND, 1x X-Richtung, 1x Y-Richtung
    Versorgung über externe 24V Pufferbatterie -> dieselbe wie die der Steuerung.

    Nachdem ich immer auf gemeisame Masse mit beiden Shunt am Analogeingang gehem muss, um eine zum Strom protortionale Spannung zu bekommen, beeinflussen sie sich -> ohne Sperrdioden war das noch extremer.

    in etwas so sieht die schaltung aus:

  5. #5
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Ich check das nicht.....

    Du hast 2x
    4-20mA

    Das sind 4 Schnüre

    auf der Skizze sind es aber nur 2.

  6. #6
    Registriert seit
    08.02.2007
    Ort
    A-2320
    Beiträge
    2.252
    Danke
    244
    Erhielt 332 Danke für 303 Beiträge

    Standard

    Ich glaub langsam ich verstehe es....
    Der AIS gibt x 4-20mA gegen GND aus und y ebenso.
    Sind die Minuseingänge der 1200er Karte auch mit GND verbunden?

  7. #7
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    das Ding mit AIS ist der Sensor - hängt auf +24VDC und GND -> das unten ist die SPS, hängt auch auf derselben +24VDC und GND (jedoch nur über die +24VDC und die GND von L+ und M) -> muss ich das 2M mit dem M verbinden? Sollte eigentlich laut Siemens nicht erforderlich sein ....

    sorry, ist etwas verwirrend gezeichnet ...

  8. #8
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    so, hab jetzt die 2M Masse mit der M bzw. GND Verbunden - macht auch keinen Unterschied

  9. #9
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard

    Zitat Zitat von borromeus Beitrag anzeigen
    Ich glaub langsam ich verstehe es....
    Der AIS gibt x 4-20mA gegen GND aus und y ebenso.
    Sind die Minuseingänge der 1200er Karte auch mit GND verbunden?
    ganz genau - stell dir das ganze nur mit einem Signal und ohne Diode vor -> dann liegt auf dem SPANNUNGSEINGANG mit 500 Ohm Widerstand eine dem Stromsignal proportionale Spannung an ... mit 2 wird´s dann zum Sperren ... und +0,7 Volt dazu zählen ...

    -> hat die Diode in Sperrichtung einen beachtlichen Innenwiederstand od. geht der gegen unendlich (2teres würde ich tippen - find nix im web)

    lg

  10. #10
    Registriert seit
    27.09.2010
    Beiträge
    43
    Danke
    3
    Erhielt 0 Danke für 0 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    ok hab nochmal nach gemessen:

    Sensor 2 liefert 11,2 mA bei Ruhelage -> laut DB sollte er 12 +-0,3mA liefern (das ist mir jetzt einmal egal)

    wenn ich jetzt den 470R parallel anlege, komme ich auf eine Spannung von 5,43V d.h. für mich ok

    wenn ich jetzt die Diode in Serie hänge, komme ich bei einem R und einer Z auf 6,2V -> d.h. für mich ok

    dasselbe gilt für Sensor 1 egal an welchen Analogeingängen (0 od. 1).

    Wenn ich aber jetzt beide gleichzeitig anhänge, laufen die Spannungen auseinander (X an Einang 0 hat jetzt 7,1V / Y an Eingang 1 hat jetzt 7,9V) - wenn ich die Sensoren vertausche, vertauschen sich die Spannungspegel, wenn ich die R+Z vertausche, bleiben die Spannungen wie sie sind)

    jemand eine Idee obs an der Steuerung od. am Sensor liegt?

Ähnliche Themen

  1. Datenaustausch zwischen S7-1200 und S7-1200
    Von baschan im Forum Simatic
    Antworten: 4
    Letzter Beitrag: 09.12.2011, 00:27
  2. S5 Analogeingang
    Von mariob im Forum Simatic
    Antworten: 6
    Letzter Beitrag: 26.04.2011, 21:16
  3. Analogeingang bei S5-95U
    Von bayersepper im Forum Simatic
    Antworten: 11
    Letzter Beitrag: 01.11.2010, 11:29
  4. Analogeingang S7 314-IFM
    Von der-rasende-dee im Forum Simatic
    Antworten: 14
    Letzter Beitrag: 22.01.2009, 17:54
  5. Stromsensor
    Von demmy86 im Forum Elektronik
    Antworten: 6
    Letzter Beitrag: 13.06.2008, 17:45

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •