Zuviel Werbung? - > Hier kostenlos beim SPS-Forum registrieren

Ergebnis 1 bis 8 von 8

Thema: Baustein lässt sich nicht mehr öffnen

  1. #1
    Registriert seit
    20.02.2010
    Beiträge
    83
    Danke
    18
    Erhielt 5 Danke für 4 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    hallo zusammen

    habe schon die suche bemüht aber nichts gefunden zu dem tehma. ich habe einen FB programmiert. dieser funktioniert auch einwandfrei. wenn ich diesen mit CALL aufrufe, wird auch die schnittstelle angezeigt und er arbeitet auch richtig.

    doch ich kann den Baustein in meinem Projekt nicht mehr öffnen. wenn ich auf den fb doppelt klicke, dann öffnet sich das fenster des awl/kop/fup-editor kurz und schließt sich sofort selbst wieder.

    hat jemand sowas schon mal erlebt? oder ne idee was das sein könnte?

    hab auch schon versucht den baustein umzubenennen, kopieren, ausschneiden und einfügen. nichts immer das selbe spiel...
    Zitieren Zitieren Baustein lässt sich nicht mehr öffnen  

  2. #2
    Registriert seit
    23.04.2009
    Ort
    Allgäu
    Beiträge
    3.042
    Danke
    241
    Erhielt 863 Danke für 617 Beiträge

    Standard

    Probiere mal "Speichern unter" und dabei den Haken setzen: "Reorganisieren langsam".

    Andere Möglichkeit wäre einen Konsistenzprüfung
    Gruß
    Paule
    ----------------------------------------------------------------------------
    > manchmal verliert man und manchmal gewinnen die anderen <

  3. Folgender Benutzer sagt Danke zu Paule für den nützlichen Beitrag:

    lubof (09.11.2010)

  4. #3
    Registriert seit
    02.10.2010
    Beiträge
    453
    Danke
    62
    Erhielt 87 Danke für 69 Beiträge

    Standard

    Hallo, verstehe es nicht verkehrt...

    aber Du hast den Baustein doch wohl nicht mit einem KnowHow-Schutz versehen?

    Gruß
    Corosop15

  5. #4
    Registriert seit
    08.08.2007
    Ort
    Dresden
    Beiträge
    9.648
    Danke
    1.059
    Erhielt 2.046 Danke für 1.627 Beiträge

    Standard

    Zitat Zitat von Corosop15 Beitrag anzeigen
    Hallo, verstehe es nicht verkehrt...

    aber Du hast den Baustein doch wohl nicht mit einem KnowHow-Schutz versehen?

    Gruß
    Corosop15
    nope, das würde der editor schon mitteilen und sich nicht einfach wortlos schließen...
    ich schließe mich paule an...
    [SIGNATUR]
    Ironie setzt Intelligenz beim Empfänger voraus.
    [/SIGNATUR]

  6. #5
    lubof ist offline Benutzer
    Themenstarter
    Registriert seit
    20.02.2010
    Beiträge
    83
    Danke
    18
    Erhielt 5 Danke für 4 Beiträge

    Standard

    Zitat Zitat von Corosop15 Beitrag anzeigen
    Hallo, verstehe es nicht verkehrt...

    aber Du hast den Baustein doch wohl nicht mit einem KnowHow-Schutz versehen?
    nein. das projekt ist noch in der entwicklung, daher auch kein knowhow-schutz.

    Zitat Zitat von Paule Beitrag anzeigen
    Probiere mal "Speichern unter" und dabei den Haken setzen: "Reorganisieren langsam".

    Andere Möglichkeit wäre einen Konsistenzprüfung
    gut. das werde ich morgen mal ausprobieren. danke schonmal an paule und vierlagig für den tipp

  7. #6
    Registriert seit
    29.03.2004
    Beiträge
    5.793
    Danke
    144
    Erhielt 1.706 Danke für 1.238 Beiträge

    Standard

    Es gibt so bestimmte Befehlskombinationen die der Editor nicht mag.
    Dadurch lässt sich entweder Programmcode verstecken oder auch den Editor zum Absturz bringen.

    Ein "BLD of Death" ist z.B. dieser Code wenn er in einem FB aufgerufen wird:
    Code:
    BLD 14
    UC FC1 // Dummy Aufruf, Baustein sollte existieren
    BLD 15
    Beim Abspeichern stürzt der Editor gleich ab. Er lässt sich danach auch nicht mehr öffnen und es lässt sich daraus auch keine AWL-Quelle mehr generieren.

    Gibt da nur noch einen Trick um da wieder ranzukommen...

  8. #7
    Registriert seit
    06.10.2003
    Beiträge
    3.447
    Danke
    454
    Erhielt 509 Danke für 411 Beiträge

    Standard

    Zitat Zitat von Thomas_v2.1 Beitrag anzeigen
    Es gibt so bestimmte Befehlskombinationen die der Editor nicht mag.
    Dadurch lässt sich entweder Programmcode verstecken oder auch den Editor zum Absturz bringen.

    Ein "BLD of Death" ist z.B. dieser Code wenn er in einem FB aufgerufen wird:
    Code:
    BLD 14
    UC FC1 // Dummy Aufruf, Baustein sollte existieren
    BLD 15
    Beim Abspeichern stürzt der Editor gleich ab. Er lässt sich danach auch nicht mehr öffnen und es lässt sich daraus auch keine AWL-Quelle mehr generieren.

    Gibt da nur noch einen Trick um da wieder ranzukommen...

    Wow, woher bekommt man solche Tricks?
    Geändert von Onkel Dagobert (10.11.2010 um 00:04 Uhr)
    Es gibt viel mehr Leute, die freiwillig aufgeben, als solche, die echt scheitern.
    Henry Ford

  9. #8
    Registriert seit
    17.06.2004
    Ort
    Offenau
    Beiträge
    3.758
    Danke
    209
    Erhielt 421 Danke für 338 Beiträge

    Standard


    Zuviel Werbung?
    -> Hier kostenlos registrieren
    Kannst's mit meinem Deleted Block Viewer probieren:

    http://www.sps-forum.de/showthread.php?t=38988
    ---------------------------------------------
    Jochen Kühner
    https://github.com/jogibear9988/DotN...ToolBoxLibrary - Bibliothek zur Kommunikation mit PLCs und zum öffnen von Step 5/7 Projekten

Ähnliche Themen

  1. Graph Quelle lässt sich nicht öffnen
    Von Wassermann im Forum Simatic
    Antworten: 5
    Letzter Beitrag: 20.07.2011, 18:14
  2. Antworten: 8
    Letzter Beitrag: 30.05.2011, 12:39
  3. WinCC flex lässt sich nicht öffnen
    Von Felse im Forum HMI
    Antworten: 8
    Letzter Beitrag: 09.07.2010, 12:32
  4. Bibliothek lässt sich nicht öffnen
    Von Anger im Forum Simatic
    Antworten: 1
    Letzter Beitrag: 25.05.2010, 13:02
  5. Antworten: 6
    Letzter Beitrag: 02.03.2008, 12:07

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •